summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2013-10-27 16:47:02 +0000
committerFabian Groffen <grobian@gentoo.org>2013-10-27 16:47:02 +0000
commit3b327a084c157673b2c7777ec3797fcde86e41c2 (patch)
tree9bf1aa7393ab6522f59a71ef203f75d3fb06212e /sys-apps/baselayout-prefix
parentvanilla-3.11.6 + genpatches-3.11-9 + grsecurity-2.9.1-3.11.6-201310260850 (diff)
downloadgentoo-2-3b327a084c157673b2c7777ec3797fcde86e41c2.tar.gz
gentoo-2-3b327a084c157673b2c7777ec3797fcde86e41c2.tar.bz2
gentoo-2-3b327a084c157673b2c7777ec3797fcde86e41c2.zip
Fix build on platforms with strlcpy/strlcat
(Portage version: 2.2.7-prefix/cvs/Darwin i386, signed Manifest commit with key 0x5F75F607C5C74E89)
Diffstat (limited to 'sys-apps/baselayout-prefix')
-rw-r--r--sys-apps/baselayout-prefix/ChangeLog6
-rw-r--r--sys-apps/baselayout-prefix/baselayout-prefix-2.2-r2.ebuild96
-rw-r--r--sys-apps/baselayout-prefix/baselayout-prefix-2.2-r3.ebuild7
3 files changed, 7 insertions, 102 deletions
diff --git a/sys-apps/baselayout-prefix/ChangeLog b/sys-apps/baselayout-prefix/ChangeLog
index e51a94ece692..e4a390a079da 100644
--- a/sys-apps/baselayout-prefix/ChangeLog
+++ b/sys-apps/baselayout-prefix/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/baselayout-prefix
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout-prefix/ChangeLog,v 1.32 2013/10/23 07:28:36 haubi Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout-prefix/ChangeLog,v 1.33 2013/10/27 16:47:02 grobian Exp $
+
+ 27 Oct 2013; Fabian Groffen <grobian@gentoo.org>
+ -baselayout-prefix-2.2-r2.ebuild, baselayout-prefix-2.2-r3.ebuild:
+ Fix build on platforms with strlcpy/strlcat
23 Oct 2013; Michael Haubenwallner <haubi@gentoo.org>
+files/einfo-1.0.3-checkfuncs-aix.patch, baselayout-prefix-2.2-r3.ebuild:
diff --git a/sys-apps/baselayout-prefix/baselayout-prefix-2.2-r2.ebuild b/sys-apps/baselayout-prefix/baselayout-prefix-2.2-r2.ebuild
deleted file mode 100644
index 983f7a2b8c9b..000000000000
--- a/sys-apps/baselayout-prefix/baselayout-prefix-2.2-r2.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout-prefix/baselayout-prefix-2.2-r2.ebuild,v 1.7 2013/10/17 14:35:50 haubi Exp $
-
-EAPI=3
-
-inherit eutils multilib
-
-MY_P=${P/-prefix/} # just use "upstream" sources
-EINFO=einfo-1.0.3
-DESCRIPTION="Minimal baselayout and e-functions for Gentoo Prefix installs"
-HOMEPAGE="http://www.gentoo.org/"
-SRC_URI="mirror://gentoo/${MY_P}.tar.bz2
- http://dev.gentoo.org/~vapier/dist/${MY_P}.tar.bz2
- http://dev.gentoo.org/~grobian/distfiles/${EINFO}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~arm ~arm-linux ~ppc-aix ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
-IUSE="build kernel_linux"
-
-S=${WORKDIR}/${EINFO}
-
-pkg_preinst() {
- # This is written in src_install (so it's in CONTENTS), but punt all
- # pending updates to avoid user having to do etc-update (and make the
- # pkg_postinst logic simpler).
- rm -f "${EROOT}"/etc/._cfg????_gentoo-release
-}
-
-src_prepare() {
- # POSIX specifies <termios.h>, AIX lacks <sys/termios.h>
- sed -i -e 's|<sys/termios.h>|<termios.h>|' src/libeinfo/libeinfo.c || die
-}
-
-src_configure() {
- econf --libexecdir="${EPREFIX}/usr/lib/einfo"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- # make functions.sh available in /etc/init.d
- # Note: we cannot replace the symlink with a file here, or Portage will
- # config-protect it, and etc-update can't handle symlink to file updates
- dodir etc/init.d
- dosym ../../usr/lib/einfo/sh/functions.sh /etc/init.d/functions.sh
-
- pushd "${WORKDIR}"/${MY_P} > /dev/null || die
- dodir etc
- sed \
- -e "/PATH=/!s:/\(etc\|usr/bin\|bin\):\"${EPREFIX}\"/\1:g" \
- -e "/PATH=/s|\([:\"]\)/|\1${EPREFIX}/|g" \
- -e "/PATH=.*\/sbin/s|\"$|:/usr/sbin:/sbin\"|" \
- -e "/PATH=.*\/bin/s|\"$|:/usr/bin:/bin\"|" \
- etc/profile > "${ED}"/etc/profile || die
- dodir etc/env.d
- sed \
- -e "s:/\(etc/env.d\|opt\|usr\):${EPREFIX}/\1:g" \
- -e "/^PATH=/s|\"$|:${EPREFIX}/usr/sbin:${EPREFIX}/sbin\"|" \
- etc/env.d/00basic > "${ED}"/etc/env.d/00basic || die
- dodoc ChangeLog.svn
- popd > /dev/null
-
- # add the host OS MANPATH
- if [[ -d "${ROOT}"/usr/share/man ]] ; then
- echo 'MANPATH="/usr/share/man"' > "${ED}"/etc/env.d/99basic || die
- fi
-
- # rc-scripts version for testing of features that *should* be present
- echo "Gentoo Prefix Base System release ${PV}" > "${ED}"/etc/gentoo-release
-
- # FHS compatibility symlinks stuff
- dosym /var/tmp /usr/tmp
-
- # add a dummy to avoid Portage shebang errors
- dodir sbin
- cat > "${ED}"/sbin/runscript <<- EOF
- #!/bin/sh
-
- echo "runscript not supported by Gentoo Prefix Base System release ${PV}" 1>&2
- exit 1
- EOF
- chmod 755 "${ED}"/sbin/runscript || die
-}
-
-pkg_postinst() {
- # Take care of the etc-update for the user
- if [ -e "${EROOT}"/etc/._cfg0000_gentoo-release ] ; then
- mv "${EROOT}"/etc/._cfg0000_gentoo-release "${EROOT}"/etc/gentoo-release
- fi
-
- # baselayout leaves behind a lot of .keep files, so let's clean them up
- find "${EROOT}"/lib/rcscripts/ -name .keep -exec rm -f {} + 2>/dev/null
- find "${EROOT}"/lib/rcscripts/ -depth -type d -exec rmdir {} + 2>/dev/null
-}
diff --git a/sys-apps/baselayout-prefix/baselayout-prefix-2.2-r3.ebuild b/sys-apps/baselayout-prefix/baselayout-prefix-2.2-r3.ebuild
index 4e73f9720adf..33c7585d1e2e 100644
--- a/sys-apps/baselayout-prefix/baselayout-prefix-2.2-r3.ebuild
+++ b/sys-apps/baselayout-prefix/baselayout-prefix-2.2-r3.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout-prefix/baselayout-prefix-2.2-r3.ebuild,v 1.2 2013/10/23 07:28:36 haubi Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout-prefix/baselayout-prefix-2.2-r3.ebuild,v 1.3 2013/10/27 16:47:02 grobian Exp $
EAPI=3
inherit eutils multilib libtool
MY_P=${P/-prefix/} # just use "upstream" sources
-EINFO=einfo-1.0.3
+EINFO=einfo-1.0.4
DESCRIPTION="Minimal baselayout and e-functions for Gentoo Prefix installs"
HOMEPAGE="http://www.gentoo.org/"
SRC_URI="mirror://gentoo/${MY_P}.tar.bz2
@@ -29,9 +29,6 @@ pkg_preinst() {
}
src_prepare() {
- epatch "${FILESDIR}"/${EINFO}-checkfuncs-aix.patch # generic aix port
- # POSIX specifies <termios.h>, AIX lacks <sys/termios.h>
- sed -i -e 's|<sys/termios.h>|<termios.h>|' src/libeinfo/libeinfo.c || die
# exotic platforms still aren't fixed in upstream libtool
elibtoolize
}