summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Vermeulen <swift@gentoo.org>2013-03-09 13:52:59 +0000
committerSven Vermeulen <swift@gentoo.org>2013-03-09 13:52:59 +0000
commit6a3f55a82d49a42291e06cf4802c7defb042d42d (patch)
treecc0bc372ce6341c4008a2808f4549ea377c565f8 /sec-policy
parentClean up redundant USE flag check calls, replace them with a single call in _... (diff)
downloadgentoo-2-6a3f55a82d49a42291e06cf4802c7defb042d42d.tar.gz
gentoo-2-6a3f55a82d49a42291e06cf4802c7defb042d42d.tar.bz2
gentoo-2-6a3f55a82d49a42291e06cf4802c7defb042d42d.zip
Ensure USE=unconfined is set if POLICY_TYPES=targeted exists
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key 0xCDBA2FDB)
Diffstat (limited to 'sec-policy')
-rw-r--r--sec-policy/selinux-base-policy/ChangeLog6
-rw-r--r--sec-policy/selinux-base-policy/selinux-base-policy-2.20120725-r12.ebuild10
2 files changed, 14 insertions, 2 deletions
diff --git a/sec-policy/selinux-base-policy/ChangeLog b/sec-policy/selinux-base-policy/ChangeLog
index 10cbd37ff21c..39cb5c7da2d5 100644
--- a/sec-policy/selinux-base-policy/ChangeLog
+++ b/sec-policy/selinux-base-policy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sec-policy/selinux-base-policy
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-base-policy/ChangeLog,v 1.126 2013/03/09 12:36:47 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-base-policy/ChangeLog,v 1.127 2013/03/09 13:52:59 swift Exp $
+
+ 09 Mar 2013; Sven Vermeulen <swift@gentoo.org>
+ selinux-base-policy-2.20120725-r12.ebuild:
+ Fix bug #458876 - USE=unconfined if targeted is set
*selinux-base-policy-2.20120725-r12 (09 Mar 2013)
diff --git a/sec-policy/selinux-base-policy/selinux-base-policy-2.20120725-r12.ebuild b/sec-policy/selinux-base-policy/selinux-base-policy-2.20120725-r12.ebuild
index 9137e998aa8f..8b1b4771f1fb 100644
--- a/sec-policy/selinux-base-policy/selinux-base-policy-2.20120725-r12.ebuild
+++ b/sec-policy/selinux-base-policy/selinux-base-policy-2.20120725-r12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-base-policy/selinux-base-policy-2.20120725-r12.ebuild,v 1.1 2013/03/09 12:36:47 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-base-policy/selinux-base-policy-2.20120725-r12.ebuild,v 1.2 2013/03/09 13:52:59 swift Exp $
EAPI="4"
inherit eutils
@@ -28,6 +28,14 @@ PATCHBUNDLE="${DISTDIR}/patchbundle-selinux-base-policy-${BASEPOL}.tar.bz2"
# itself), when reworked reinclude it. Only postinstall (where -b base.pp is
# added) needs to remain then.
+pkg_pretend() {
+ for i in ${POLICY_TYPES}; do
+ if [[ "${i}" == "targeted" ]] && ! use unconfined; then
+ die "If you use POLICY_TYPES=targeted, then USE=unconfined is mandatory."
+ fi
+ done
+}
+
src_prepare() {
local modfiles