summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2007-01-06 20:11:57 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2007-01-06 20:11:57 +0000
commita95ce58487d902303099158fa128dc0c0b728b7f (patch)
tree0c9183e5c7d794c079a227a2062a7c4b839e10a4 /sci-visualization
parentQA: Removed unused versions. (diff)
downloadgentoo-2-a95ce58487d902303099158fa128dc0c0b728b7f.tar.gz
gentoo-2-a95ce58487d902303099158fa128dc0c0b728b7f.tar.bz2
gentoo-2-a95ce58487d902303099158fa128dc0c0b728b7f.zip
Version bump, fixes bug 151029.
(Portage version: 2.1.2_rc4-r5)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/quickplot/ChangeLog10
-rw-r--r--sci-visualization/quickplot/files/digest-quickplot-0.8.133
-rw-r--r--sci-visualization/quickplot/files/digest-quickplot-0.8.52
-rw-r--r--sci-visualization/quickplot/quickplot-0.8.13.ebuild50
4 files changed, 63 insertions, 2 deletions
diff --git a/sci-visualization/quickplot/ChangeLog b/sci-visualization/quickplot/ChangeLog
index 3958339b05bf..251ad1e2c776 100644
--- a/sci-visualization/quickplot/ChangeLog
+++ b/sci-visualization/quickplot/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-visualization/quickplot
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/quickplot/ChangeLog,v 1.2 2006/02/16 19:30:11 swegener Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/quickplot/ChangeLog,v 1.3 2007/01/06 20:11:57 cryos Exp $
+
+*quickplot-0.8.13 (06 Jan 2007)
+
+ 06 Jan 2007; Marcus D. Hanwell <cryos@gentoo.org>
+ +quickplot-0.8.13.ebuild:
+ Version bump, fixes bug 151029.
29 Jan 2006; Marcus D. Hanwell <cryos@gentoo.org> +metadata.xml,
+quickplot-0.8.5.ebuild:
diff --git a/sci-visualization/quickplot/files/digest-quickplot-0.8.13 b/sci-visualization/quickplot/files/digest-quickplot-0.8.13
new file mode 100644
index 000000000000..8cedd3d79066
--- /dev/null
+++ b/sci-visualization/quickplot/files/digest-quickplot-0.8.13
@@ -0,0 +1,3 @@
+MD5 aa259ab1090ed9180ea809e018d13024 quickplot-0.8.13.tar.bz2 410677
+RMD160 34f43f267e7302641e6ef701dc20f65935489023 quickplot-0.8.13.tar.bz2 410677
+SHA256 52a2a635ae9faebfa114dbd1128a1cfc8e17a1749411c7ff8e39e50064147368 quickplot-0.8.13.tar.bz2 410677
diff --git a/sci-visualization/quickplot/files/digest-quickplot-0.8.5 b/sci-visualization/quickplot/files/digest-quickplot-0.8.5
index 226cb64c5a6d..41f64f4feabd 100644
--- a/sci-visualization/quickplot/files/digest-quickplot-0.8.5
+++ b/sci-visualization/quickplot/files/digest-quickplot-0.8.5
@@ -1 +1,3 @@
MD5 55b90fd8e26b89574f2f9de98e85f10f quickplot-0.8.5.tar.bz2 394128
+RMD160 2d0b6829e57a2363532a439a8862c0f2bde54c01 quickplot-0.8.5.tar.bz2 394128
+SHA256 7015023a003ba370d79766eca2be68f4c5e412ea5ee7f28b18e48992e526d7cc quickplot-0.8.5.tar.bz2 394128
diff --git a/sci-visualization/quickplot/quickplot-0.8.13.ebuild b/sci-visualization/quickplot/quickplot-0.8.13.ebuild
new file mode 100644
index 000000000000..68604db441d6
--- /dev/null
+++ b/sci-visualization/quickplot/quickplot-0.8.13.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/quickplot/quickplot-0.8.13.ebuild,v 1.1 2007/01/06 20:11:57 cryos Exp $
+
+inherit eutils
+
+DESCRIPTION="A fast interactive 2D plotter."
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://quickplot.sourceforge.net/"
+
+IUSE="sndfile"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND=">=dev-cpp/gtkmm-2.4.5
+ sndfile? ( >=media-libs/libsndfile-1.0.5 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.15"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # Some files have been moved around to more appropriate locations
+ sed -i -e 's|quickplot_icon.png|/usr/share/pixmaps/quickplot.png|' \
+ index.html.in
+ sed -i -e 's|href="ChangeLog"|href="../ChangeLog.gz"|' index.html.in
+ sed -i -e 's|href="COPYING"|href="/usr/portage/licenses/GPL-2"|' \
+ about.html.in
+}
+
+src_compile() {
+ econf `use_with sndfile libsndfile` || die "econf step failed."
+ emake htmldir=/usr/share/doc/${PF}/html || die "emake step failed."
+}
+
+src_install () {
+ make install DESTDIR=${D} htmldir=/usr/share/doc/${PF}/html \
+ || die "make install step failed."
+ dodoc AUTHORS ChangeLog README README.devel TODO
+ # Remove COPYING as it is specified in LICENCE. Move other stuff.
+ cd ${D}/usr/share/doc/${PF}/html
+ rm COPYING quickplot_icon.png ChangeLog
+ mv ${D}/usr/share/pixmaps/quickplot_icon.png \
+ ${D}/usr/share/pixmaps/quickplot.png
+ make_desktop_entry 'quickplot --no-pipe' Quickplot quickplot.png Graphics
+ mv ${D}/usr/share/applications/quickplot\ --no-pipe.desktop \
+ ${D}/usr/share/applications/quickplot.desktop
+}