summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2015-04-19 13:15:00 +0000
committerMatthias Maier <tamiko@gentoo.org>2015-04-19 13:15:00 +0000
commit88616681b4963c3446ae0dd7e3643f5055a0fed3 (patch)
tree85548d29915fb6babf9eaa69a7703ab8a913f790 /sci-visualization
parentrm calls to die consistent with updated EAPI, noted by pacho (diff)
downloadgentoo-2-88616681b4963c3446ae0dd7e3643f5055a0fed3.tar.gz
gentoo-2-88616681b4963c3446ae0dd7e3643f5055a0fed3.tar.bz2
gentoo-2-88616681b4963c3446ae0dd7e3643f5055a0fed3.zip
version bump (bug #538690), fix dependencies (bug #538168), fix freetype-2.5.5 compatibility also in 4.1.0-r2 (bug #541012), fix protobuf compatibility in 4.2.0 and 4.3.1 (bug #537988)
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key BD3A97A3)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/paraview/ChangeLog13
-rw-r--r--sci-visualization/paraview/files/paraview-4.1.0-vtk-freetype.patch22
-rw-r--r--sci-visualization/paraview/files/paraview-4.2.0-protobuf-2.patch161
-rw-r--r--sci-visualization/paraview/files/paraview-4.2.0-protobuf.patch (renamed from sci-visualization/paraview/files/paraview-4.2.0-Protobuf.patch)0
-rw-r--r--sci-visualization/paraview/paraview-4.1.0-r2.ebuild17
-rw-r--r--sci-visualization/paraview/paraview-4.2.0-r1.ebuild17
-rw-r--r--sci-visualization/paraview/paraview-4.3.1.ebuild (renamed from sci-visualization/paraview/paraview-4.0.1-r2.ebuild)57
7 files changed, 245 insertions, 42 deletions
diff --git a/sci-visualization/paraview/ChangeLog b/sci-visualization/paraview/ChangeLog
index 7ef2e2510b45..72d401f6648f 100644
--- a/sci-visualization/paraview/ChangeLog
+++ b/sci-visualization/paraview/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for sci-visualization/paraview
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/paraview/ChangeLog,v 1.88 2015/04/08 18:23:57 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/paraview/ChangeLog,v 1.89 2015/04/19 13:15:00 tamiko Exp $
+
+*paraview-4.3.1 (19 Apr 2015)
+
+ 19 Apr 2015; Matthias Maier <tamiko@gentoo.org>
+ +files/paraview-4.1.0-vtk-freetype.patch,
+ +files/paraview-4.2.0-protobuf-2.patch, +files/paraview-4.2.0-protobuf.patch,
+ +paraview-4.3.1.ebuild, -files/paraview-4.2.0-Protobuf.patch,
+ -paraview-4.0.1-r2.ebuild, paraview-4.1.0-r2.ebuild, paraview-4.2.0-r1.ebuild:
+ version bump (bug #538690), fix dependencies (bug #538168), fix freetype-2.5.5
+ compatibility also in 4.1.0-r2 (bug #541012), fix protobuf compatibility in
+ 4.2.0 and 4.3.1 (bug #537988)
08 Apr 2015; Michał Górny <mgorny@gentoo.org> paraview-4.0.1-r2.ebuild,
paraview-4.1.0-r2.ebuild, paraview-4.2.0-r1.ebuild:
diff --git a/sci-visualization/paraview/files/paraview-4.1.0-vtk-freetype.patch b/sci-visualization/paraview/files/paraview-4.1.0-vtk-freetype.patch
new file mode 100644
index 000000000000..b7d3e409cde1
--- /dev/null
+++ b/sci-visualization/paraview/files/paraview-4.1.0-vtk-freetype.patch
@@ -0,0 +1,22 @@
+--- a/ParaView-v4.2.0-source/VTK/Rendering/FreeType/vtkFreeTypeTools.cxx_orig 2014-12-23 09:25:35.000000000 +0100
++++ b/ParaView-v4.2.0-source/VTK/Rendering/FreeType/vtkFreeTypeTools.cxx 2014-12-24 09:40:31.886953389 +0100
+@@ -1185,7 +1185,7 @@
+ if (bitmap)
+ {
+ metaData.ascent = std::max(bitmapGlyph->top - 1, metaData.ascent);
+- metaData.descent = std::min(-(bitmap->rows - (bitmapGlyph->top - 1)),
++ metaData.descent = std::min(-(static_cast<int>(bitmap->rows) - (bitmapGlyph->top - 1)),
+ metaData.descent);
+ }
+ ++heightString;
+@@ -1952,8 +1952,8 @@
+ if (bitmap)
+ {
+ bbox[0] = std::min(bbox[0], pen[0] + bitmapGlyph->left);
+- bbox[1] = std::max(bbox[1], pen[0] + bitmapGlyph->left + bitmap->width);
+- bbox[2] = std::min(bbox[2], pen[1] + bitmapGlyph->top - 1 - bitmap->rows);
++ bbox[1] = std::max(bbox[1], pen[0] + bitmapGlyph->left + static_cast<int>(bitmap->width));
++ bbox[2] = std::min(bbox[2], pen[1] + bitmapGlyph->top - 1 - static_cast<int>(bitmap->rows));
+ bbox[3] = std::max(bbox[3], pen[1] + bitmapGlyph->top - 1);
+ }
+ else
diff --git a/sci-visualization/paraview/files/paraview-4.2.0-protobuf-2.patch b/sci-visualization/paraview/files/paraview-4.2.0-protobuf-2.patch
new file mode 100644
index 000000000000..f1ea7b5b01bc
--- /dev/null
+++ b/sci-visualization/paraview/files/paraview-4.2.0-protobuf-2.patch
@@ -0,0 +1,161 @@
+diff --git a/ParaViewCore/ServerImplementation/Core/vtkPVMessage.proto b/ParaViewCore/ServerImplementation/Core/vtkPVMessage.proto
+index 60e084c..aed5832 100644
+--- a/ParaViewCore/ServerImplementation/Core/vtkPVMessage.proto
++++ b/ParaViewCore/ServerImplementation/Core/vtkPVMessage.proto
+@@ -21,7 +21,7 @@ message Variant {
+ MAP = 7;
+ }
+
+- required Type type = 1;
++ optional Type type = 1;
+ repeated sint64 idtype = 3;
+ repeated sint32 integer = 4;
+ repeated double float64 = 5;
+@@ -47,8 +47,8 @@ message MessageCollection
+
+ message Message
+ {
+- required uint64 global_id = 1;
+- required uint32 location = 2;
++ optional uint64 global_id = 1;
++ optional uint32 location = 2;
+ optional bool share_only = 3 [default = false];
+ optional bool req_def = 4 [default = false];
+ optional uint32 client_id = 5 [default = 0];
+@@ -62,10 +62,10 @@ message DefinitionHeader
+ {
+ extend Message {
+ // The classname for the driver process i.e. the client, typically
+- required string client_class = 10;
++ optional string client_class = 10;
+
+ // The classname for the process where the processing occurs
+- required string server_class = 11;
++ optional string server_class = 11;
+ }
+ }
+
+@@ -76,32 +76,32 @@ message ProxyState
+
+ message SubProxy
+ {
+- required string name = 1;
+- required uint32 global_id = 2;
++ optional string name = 1;
++ optional uint32 global_id = 2;
+ }
+
+ message Annotation
+ {
+- required string key = 1;
+- required string value = 2;
++ optional string key = 1;
++ optional string value = 2;
+ }
+
+ message UserData
+ {
+- required string key = 1;
++ optional string key = 1;
+ repeated Variant variant = 2;
+ }
+
+ message Property
+ {
+- required string name = 1;
++ optional string name = 1;
+ optional Variant value = 2;
+ repeated UserData user_data = 3;
+ }
+
+ extend Message {
+- required string xml_group = 20;
+- required string xml_name = 21;
++ optional string xml_group = 20;
++ optional string xml_name = 21;
+ optional string xml_sub_proxy_name = 22;
+ repeated Property property = 23;
+ repeated SubProxy subproxy = 24;
+@@ -118,8 +118,8 @@ message PXMRegistrationState
+ message Entry
+ {
+ optional string group = 1;
+- required string name = 2;
+- required uint64 global_id = 3;
++ optional string name = 2;
++ optional uint64 global_id = 3;
+ }
+
+ extend Message {
+@@ -135,9 +135,9 @@ message ProxyDefinitionState
+ {
+ message ProxyXMLDefinition
+ {
+- required string group = 1;
+- required string name = 2;
+- required string xml = 3;
++ optional string group = 1;
++ optional string name = 2;
++ optional string xml = 3;
+ }
+
+ extend Message {
+@@ -181,9 +181,9 @@ message LinkState {
+ OUTPUT = 2;
+ }
+
+- required uint32 proxy = 1;
++ optional uint32 proxy = 1;
+ optional string property_name = 2;
+- required Direction direction = 3;
++ optional Direction direction = 3;
+ }
+
+ extend Message {
+@@ -206,7 +206,7 @@ message MousePointer {
+ }
+
+ extend Message {
+- required uint32 view = 70;
++ optional uint32 view = 70;
+ optional double x = 71 [default = 0];
+ optional double y = 72 [default = 0];
+ optional bool forceShow = 73 [default = false];
+@@ -219,7 +219,7 @@ message MousePointer {
+ message ChartViewBounds {
+
+ extend Message {
+- required uint32 view = 75;
++ optional uint32 view = 75;
+ repeated double range = 76;
+ }
+ }
+@@ -229,7 +229,7 @@ message ChartViewBounds {
+ message ClientsInformation {
+
+ message ClientInfo {
+- required uint32 user = 1;
++ optional uint32 user = 1;
+ optional string name = 2;
+ optional bool is_master = 3 [default = false];
+ optional bool follow_cam = 4 [default = false];
+@@ -242,8 +242,8 @@ message ClientsInformation {
+
+ message ChatMessage {
+ extend Message {
+- required uint32 author = 84;
+- required string txt = 85;
++ optional uint32 author = 84;
++ optional string txt = 85;
+ }
+ }
+
+@@ -256,7 +256,7 @@ message QtEvent {
+ }
+
+ extend Message {
+- required QtEventType type = 98;
++ optional QtEventType type = 98;
+ }
+ }
+
diff --git a/sci-visualization/paraview/files/paraview-4.2.0-Protobuf.patch b/sci-visualization/paraview/files/paraview-4.2.0-protobuf.patch
index 498ad9b78ac0..498ad9b78ac0 100644
--- a/sci-visualization/paraview/files/paraview-4.2.0-Protobuf.patch
+++ b/sci-visualization/paraview/files/paraview-4.2.0-protobuf.patch
diff --git a/sci-visualization/paraview/paraview-4.1.0-r2.ebuild b/sci-visualization/paraview/paraview-4.1.0-r2.ebuild
index 6d9dcd9f2531..ecf52a91d90a 100644
--- a/sci-visualization/paraview/paraview-4.1.0-r2.ebuild
+++ b/sci-visualization/paraview/paraview-4.1.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/paraview/paraview-4.1.0-r2.ebuild,v 1.3 2015/04/08 18:23:57 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/paraview/paraview-4.1.0-r2.ebuild,v 1.4 2015/04/19 13:15:00 tamiko Exp $
EAPI=5
@@ -35,8 +35,8 @@ RDEPEND="
media-libs/libtheora
media-libs/tiff:0=
sci-libs/hdf5[mpi=]
- || ( ( >=sci-libs/netcdf-4.2[hdf5] >=sci-libs/netcdf-cxx-4.2:3 )
- ~sci-libs/netcdf-4.1.3[cxx,hdf5] )
+ >=sci-libs/netcdf-4.2[hdf5]
+ >=sci-libs/netcdf-cxx-4.2:3
sys-libs/zlib
virtual/jpeg:0
virtual/opengl
@@ -45,6 +45,7 @@ RDEPEND="
x11-libs/libXext
x11-libs/libXmu
x11-libs/libXt
+ boost? ( >=dev-libs/boost-1.40.0[mpi?,${PYTHON_USEDEP}] )
coprocessing? (
plugins? (
dev-python/PyQt4
@@ -57,12 +58,11 @@ RDEPEND="
python? (
${PYTHON_DEPS}
dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/mpi4py
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/sip[${PYTHON_USEDEP}]
- dev-python/twisted-core
+ dev-python/twisted-core[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]
- mpi? ( dev-python/mpi4py )
+ mpi? ( dev-python/mpi4py[${PYTHON_USEDEP}] )
qt4? ( dev-python/PyQt4[opengl,webkit,${PYTHON_USEDEP}] )
)
qt4? (
@@ -77,8 +77,6 @@ RDEPEND="
tcl? ( dev-lang/tcl:0= )
tk? ( dev-lang/tk:0= )"
DEPEND="${RDEPEND}
- ${PYTHON_DEPS}
- boost? ( >=dev-libs/boost-1.40.0[mpi?,${PYTHON_USEDEP}] )
doc? ( app-doc/doxygen )"
S=${WORKDIR}/${MY_P%-source}
@@ -96,7 +94,8 @@ src_prepare() {
"${FILESDIR}"/${PN}-4.0.1-vtk-cg-path.patch \
"${FILESDIR}"/${PN}-4.0.1-Protobuf.patch \
"${FILESDIR}"/${P}-glxext-legacy.patch \
- "${FILESDIR}"/${P}-no-fatal-warnings.patch
+ "${FILESDIR}"/${P}-no-fatal-warnings.patch \
+ "${FILESDIR}"/${P}-vtk-freetype.patch
# lib64 fixes
sed -i \
diff --git a/sci-visualization/paraview/paraview-4.2.0-r1.ebuild b/sci-visualization/paraview/paraview-4.2.0-r1.ebuild
index 26dcb8e6af91..7a702b14ce9e 100644
--- a/sci-visualization/paraview/paraview-4.2.0-r1.ebuild
+++ b/sci-visualization/paraview/paraview-4.2.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/paraview/paraview-4.2.0-r1.ebuild,v 1.3 2015/04/08 18:23:57 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/paraview/paraview-4.2.0-r1.ebuild,v 1.4 2015/04/19 13:15:00 tamiko Exp $
EAPI=5
@@ -35,8 +35,8 @@ RDEPEND="
media-libs/libtheora
media-libs/tiff:0=
sci-libs/hdf5[mpi=]
- || ( ( >=sci-libs/netcdf-4.2[hdf5] >=sci-libs/netcdf-cxx-4.2:3 )
- ~sci-libs/netcdf-4.1.3[cxx,hdf5] )
+ >=sci-libs/netcdf-4.2[hdf5]
+ >=sci-libs/netcdf-cxx-4.2:3
sys-libs/zlib
virtual/jpeg:0
virtual/opengl
@@ -45,6 +45,7 @@ RDEPEND="
x11-libs/libXext
x11-libs/libXmu
x11-libs/libXt
+ boost? ( >=dev-libs/boost-1.40.0[mpi?,${PYTHON_USEDEP}] )
coprocessing? (
plugins? (
dev-python/PyQt4
@@ -57,12 +58,11 @@ RDEPEND="
python? (
${PYTHON_DEPS}
dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/mpi4py
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/sip[${PYTHON_USEDEP}]
- dev-python/twisted-core
+ dev-python/twisted-core[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]
- mpi? ( dev-python/mpi4py )
+ mpi? ( dev-python/mpi4py[${PYTHON_USEDEP}] )
qt4? ( dev-python/PyQt4[opengl,webkit,${PYTHON_USEDEP}] )
)
qt4? (
@@ -77,8 +77,6 @@ RDEPEND="
tcl? ( dev-lang/tcl:0= )
tk? ( dev-lang/tk:0= )"
DEPEND="${RDEPEND}
- ${PYTHON_DEPS}
- boost? ( >=dev-libs/boost-1.40.0[mpi?,${PYTHON_USEDEP}] )
doc? ( app-doc/doxygen )"
S="${WORKDIR}/${MY_P}"
@@ -93,7 +91,8 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-4.0.1-xdmf-cstring.patch \
"${FILESDIR}"/${P}-removesqlite.patch \
"${FILESDIR}"/${PN}-4.0.1-gcc-4.7.patch \
- "${FILESDIR}"/${P}-Protobuf.patch \
+ "${FILESDIR}"/${P}-protobuf.patch \
+ "${FILESDIR}"/${P}-protobuf-2.patch \
"${FILESDIR}"/${PN}-4.1.0-no-fatal-warnings.patch \
"${FILESDIR}"/${P}-vtk-freetype.patch
diff --git a/sci-visualization/paraview/paraview-4.0.1-r2.ebuild b/sci-visualization/paraview/paraview-4.3.1.ebuild
index 72935098ec49..7c484c0526be 100644
--- a/sci-visualization/paraview/paraview-4.0.1-r2.ebuild
+++ b/sci-visualization/paraview/paraview-4.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/paraview/paraview-4.0.1-r2.ebuild,v 1.3 2015/04/08 18:23:57 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/paraview/paraview-4.3.1.ebuild,v 1.1 2015/04/19 13:15:00 tamiko Exp $
EAPI=5
@@ -13,19 +13,21 @@ MY_P="ParaView-v${PV}-source"
DESCRIPTION="ParaView is a powerful scientific data visualization application"
HOMEPAGE="http://www.paraview.org"
-SRC_URI="http://www.paraview.org/files/v${MAJOR_PV}/${MY_P}.tgz"
+SRC_URI="http://www.paraview.org/files/v${MAJOR_PV}/${MY_P}.tar.gz"
RESTRICT="mirror"
LICENSE="paraview GPL-2"
KEYWORDS="~amd64 ~x86"
SLOT="0"
IUSE="boost cg coprocessing development doc examples ffmpeg mpi mysql nvcontrol plugins python qt4 sqlite tcl test tk"
+RESTRICT="test"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
mysql? ( sqlite )" # "vtksqlite, needed by vtkIOSQL" and "vtkIOSQL, needed by vtkIOMySQL"
RDEPEND="
dev-libs/expat
+ >=dev-libs/jsoncpp-0.10.1
dev-libs/libxml2:2
dev-libs/protobuf
media-libs/freetype
@@ -33,8 +35,8 @@ RDEPEND="
media-libs/libtheora
media-libs/tiff:0=
sci-libs/hdf5[mpi=]
- || ( ( >=sci-libs/netcdf-4.2[hdf5] >=sci-libs/netcdf-cxx-4.2:3 )
- ~sci-libs/netcdf-4.1.3[cxx,hdf5] )
+ >=sci-libs/netcdf-4.2[hdf5]
+ >=sci-libs/netcdf-cxx-4.2:3
sys-libs/zlib
virtual/jpeg:0
virtual/opengl
@@ -55,7 +57,6 @@ RDEPEND="
python? (
${PYTHON_DEPS}
dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/mpi4py
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/sip[${PYTHON_USEDEP}]
dev-python/twisted-core
@@ -64,6 +65,7 @@ RDEPEND="
qt4? ( dev-python/PyQt4[opengl,webkit,${PYTHON_USEDEP}] )
)
qt4? (
+ dev-qt/designer:4
dev-qt/qtgui:4
dev-qt/qtopengl:4
dev-qt/qthelp:4[compat]
@@ -78,7 +80,7 @@ DEPEND="${RDEPEND}
boost? ( >=dev-libs/boost-1.40.0[mpi?,${PYTHON_USEDEP}] )
doc? ( app-doc/doxygen )"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
pkg_setup() {
python-single-r1_pkg_setup
@@ -87,12 +89,13 @@ pkg_setup() {
src_prepare() {
# see patch headers for description
- epatch "${FILESDIR}"/${P}-xdmf-cstring.patch \
- "${FILESDIR}"/${P}-removesqlite.patch \
- "${FILESDIR}"/${P}-gcc-4.7.patch \
- "${FILESDIR}"/${P}-vtknetcd.patch \
- "${FILESDIR}"/${P}-vtk-cg-path.patch \
- "${FILESDIR}"/${P}-Protobuf.patch
+ epatch "${FILESDIR}"/${PN}-4.0.1-xdmf-cstring.patch \
+ "${FILESDIR}"/${PN}-4.2.0-removesqlite.patch \
+ "${FILESDIR}"/${PN}-4.0.1-gcc-4.7.patch \
+ "${FILESDIR}"/${PN}-4.2.0-protobuf.patch \
+ "${FILESDIR}"/${PN}-4.2.0-protobuf-2.patch \
+ "${FILESDIR}"/${PN}-4.1.0-no-fatal-warnings.patch \
+ "${FILESDIR}"/${PN}-4.2.0-vtk-freetype.patch
# lib64 fixes
sed -i \
@@ -107,7 +110,10 @@ src_prepare() {
Plugins/SciberQuestToolKit/CMakeLists.txt \
ParaViewConfig.cmake.in \
CoProcessing/PythonCatalyst/vtkCPPythonScriptPipeline.cxx \
- ParaViewCore/ClientServerCore/Core/vtkProcessModuleInitializePython.h || die
+ ParaViewCore/ClientServerCore/Core/vtkProcessModuleInitializePython.h \
+ ParaViewCore/ClientServerCore/Core/vtkPVPluginTracker.cxx \
+ Plugins/SciberQuestToolKit/ParaViewPlugin/CMakeLists.txt \
+ Plugins/SciberQuestToolKit/SciberQuest/CMakeLists.txt || die
# no proper switch
use nvcontrol || {
@@ -120,15 +126,16 @@ src_prepare() {
src_configure() {
local mysql_lib mysql_includedir
- if [[ $(mysql_config --version | sed 's/\.//g') -lt 5529 ]] ; then
- mysql_lib="/usr/$(get_libdir)/mysql/libmysqlclient.so"
- mysql_includedir="/usr/include/mysql"
- else
- mysql_lib="$(mysql_config --variable=pkglibdir)/libmysqlclient.so"
- mysql_includedir="$(mysql_config --variable=pkgincludedir)"
+ if use mysql ; then
+ if [[ $(mysql_config --version | sed 's/\.//g') -lt 5529 ]] ; then
+ mysql_lib="/usr/$(get_libdir)/mysql/libmysqlclient.so"
+ mysql_includedir="/usr/include/mysql"
+ else
+ mysql_lib="$(mysql_config --variable=pkglibdir)/libmysqlclient.so"
+ mysql_includedir="$(mysql_config --variable=pkgincludedir)"
+ fi
fi
- # TODO: use system jsoncpp
# VTK_USE_SYSTEM_QTTESTING
# PARAVIEW_USE_SYSTEM_AUTOBAHN
local mycmakeargs=(
@@ -144,7 +151,9 @@ src_configure() {
-DVTK_USE_SYSTEM_GL2PS=ON
-DVTK_USE_SYSTEM_HDF5=ON
-DVTK_USE_SYSTEM_JPEG=ON
+ -DVTK_USE_SYSTEM_JSONCPP=ON
-DVTK_USE_SYSTEM_LIBXML2=ON
+ -DVTK_USE_SYSTEM_NETCDF=ON
-DVTK_USE_SYSTEM_OGGTHEORA=ON
-DVTK_USE_SYSTEM_PNG=ON
-DVTK_USE_SYSTEM_PROTOBUF=ON
@@ -152,8 +161,8 @@ src_configure() {
-DVTK_USE_SYSTEM_XDMF2=OFF
-DVTK_USE_SYSTEM_ZLIB=ON
-DPARAVIEW_USE_SYSTEM_MPI4PY=ON
- -DPARAVIEW_USE_SYSTEM_ZOPE=ON
- -DPARAVIEW_USE_SYSTEM_TWISTED=ON
+ -DVTK_USE_SYSTEM_ZOPE=ON
+ -DVTK_USE_SYSTEM_TWISTED=ON
-DCMAKE_VERBOSE_MAKEFILE=ON
-DCMAKE_COLOR_MAKEFILE=TRUE
-DVTK_USE_OFFSCREEN=TRUE
@@ -236,6 +245,7 @@ src_configure() {
$(cmake-utils_use plugins PARAVIEW_BUILD_PLUGIN_ForceTime)
$(cmake-utils_use plugins PARAVIEW_BUILD_PLUGIN_GMVReader)
$(cmake-utils_use plugins PARAVIEW_BUILD_PLUGIN_H5PartReader)
+ $(cmake-utils_use plugins RAVIEW_BUILD_PLUGIN_MobileRemoteControl)
$(cmake-utils_use plugins PARAVIEW_BUILD_PLUGIN_Moments)
$(cmake-utils_use plugins PARAVIEW_BUILD_PLUGIN_NonOrthogonalSource)
$(cmake-utils_use plugins PARAVIEW_BUILD_PLUGIN_PacMan)
@@ -245,6 +255,7 @@ src_configure() {
$(cmake-utils_use plugins PARAVIEW_BUILD_PLUGIN_SLACTools)
$(cmake-utils_use plugins PARAVIEW_BUILD_PLUGIN_SciberQuestToolKit)
$(cmake-utils_use plugins PARAVIEW_BUILD_PLUGIN_SierraPlotTools)
+ $(cmake-utils_use plugins PARAVIEW_BUILD_PLUGIN_StreamingParticles)
$(cmake-utils_use plugins PARAVIEW_BUILD_PLUGIN_SurfaceLIC)
$(cmake-utils_use plugins PARAVIEW_BUILD_PLUGIN_UncertaintyRendering)
# these are always needed for plugins
@@ -265,7 +276,7 @@ src_install() {
# set up the environment
echo "LDPATH=${EPREFIX}/usr/${PVLIBDIR}" > "${T}"/40${PN}
- newicon "${S}"/Applications/ParaView/pvIcon.png paraview.png
+ newicon "${S}"/Applications/ParaView/pvIcon-32x32.png paraview.png
make_desktop_entry paraview "Paraview" paraview
use python && python_optimize "${D}"/usr/$(get_libdir)/${PN}-${MAJOR_PV}