summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Gardner <je_fro@gentoo.org>2007-07-19 08:11:02 +0000
committerJeffrey Gardner <je_fro@gentoo.org>2007-07-19 08:11:02 +0000
commit46b7247eaaf9a2a632d2eb7e966e345541c24f6f (patch)
treeabfac8a74494f16c8002507aa215877cda65334d /sci-visualization
parentMoved to testing, fixes bug 185832. Sorry. (diff)
downloadgentoo-2-46b7247eaaf9a2a632d2eb7e966e345541c24f6f.tar.gz
gentoo-2-46b7247eaaf9a2a632d2eb7e966e345541c24f6f.tar.bz2
gentoo-2-46b7247eaaf9a2a632d2eb7e966e345541c24f6f.zip
Add patch to fix compilation with >=linux headers-2.6.19. See bug 185828.
(Portage version: 2.1.2.9)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/opendx/ChangeLog6
-rw-r--r--sci-visualization/opendx/files/opendx-sys.h.patch23
-rw-r--r--sci-visualization/opendx/opendx-4.3.2-r1.ebuild13
3 files changed, 38 insertions, 4 deletions
diff --git a/sci-visualization/opendx/ChangeLog b/sci-visualization/opendx/ChangeLog
index e5ab8111acc1..150da523dcec 100644
--- a/sci-visualization/opendx/ChangeLog
+++ b/sci-visualization/opendx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-visualization/opendx
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/opendx/ChangeLog,v 1.4 2007/02/22 01:09:47 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/opendx/ChangeLog,v 1.5 2007/07/19 08:11:02 je_fro Exp $
+
+ 19 Jul 2007; Jeff Gardner <je_fro@gentoo.org> +files/opendx-sys.h.patch,
+ opendx-4.3.2-r1.ebuild:
+ Add patch to fix compilation with >=linux headers-2.6.19. See bug 185828.
22 Feb 2007; Markus Ullmann <jokey@gentoo.org> ChangeLog:
Redigest for Manifest2
diff --git a/sci-visualization/opendx/files/opendx-sys.h.patch b/sci-visualization/opendx/files/opendx-sys.h.patch
new file mode 100644
index 000000000000..93bf18efb38c
--- /dev/null
+++ b/sci-visualization/opendx/files/opendx-sys.h.patch
@@ -0,0 +1,23 @@
+diff -aurN dx-4.3.2-orig/configure.ac dx-4.3.2/configure.ac
+--- dx-4.3.2-orig/configure.ac 2007-07-19 00:59:55.000000000 -0500
++++ dx-4.3.2/configure.ac 2007-07-19 01:02:34.000000000 -0500
+@@ -1004,7 +1004,7 @@
+ Xm/ScrolledWP.h Xm/SelectioB.h Xm/SeparatoG.h Xm/SeparatoGP.h Xm/Separator.h \
+ Xm/Text.h Xm/TextF.h Xm/ToggleB.h Xm/ToggleBG.h Xm/Xm.h Xm/XmP.h Xm/XmStrDefs.h \
+ gl.h gl/device.h gl/gl.h invent.h iop/afb.h iop/mov.h iop/pfs.h license.h \
+- linux/kernel.h linux/sys.h math.h mingw32/dir.h mon.h net/if_arp.h net/route.h \
++ linux/kernel.h math.h mingw32/dir.h mon.h net/if_arp.h net/route.h \
+ os2.h setjmp.h starbase.c.h stddef.h stdio.h synch.h sys/access.h \
+ sys/ipc.h sys/m88kbcs.h sys/mman.h sys/mode.h sys/pstat.h sys/resource.h \
+ sys/svs.h sys/sysconfig.h sys/syslimits.h sys/sysmacros.h ulocks.h x11/xlibxtra.h \
+diff -aurN dx-4.3.2-orig/src/exec/libdx/memory.c dx-4.3.2/src/exec/libdx/memory.c
+--- dx-4.3.2-orig/src/exec/libdx/memory.c 2007-07-19 00:59:54.000000000 -0500
++++ dx-4.3.2/src/exec/libdx/memory.c 2007-07-19 01:01:57.000000000 -0500
+@@ -66,7 +66,6 @@
+
+ #if linux
+ #include <linux/kernel.h>
+-#include <linux/sys.h>
+ #include <sys/sysinfo.h>
+ #endif
+
diff --git a/sci-visualization/opendx/opendx-4.3.2-r1.ebuild b/sci-visualization/opendx/opendx-4.3.2-r1.ebuild
index 0a4120ff3d4d..dbf418dcaf66 100644
--- a/sci-visualization/opendx/opendx-4.3.2-r1.ebuild
+++ b/sci-visualization/opendx/opendx-4.3.2-r1.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/opendx/opendx-4.3.2-r1.ebuild,v 1.2 2007/06/26 02:45:02 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/opendx/opendx-4.3.2-r1.ebuild,v 1.3 2007/07/19 08:11:02 je_fro Exp $
# Set SMP="no" to force disable of SMP compilation.
# Set SMP="yes" to force enable of SMP compilation.
# Otherwise it will be autodetected from /usr/src/linux.
-inherit eutils flag-o-matic linux-info
+inherit eutils flag-o-matic linux-info autotools
DESCRIPTION="A 3D data visualization tool"
HOMEPAGE="http://www.opendx.org/"
@@ -58,6 +58,13 @@ smp_check() {
}
src_compile() {
+
+ if has_version '>=sys-kernel/linux-headers-2.6.19' ; then
+ epatch ${FILESDIR}/opendx-sys.h.patch || die "Failed to apply sys.h patch."
+ fi
+
+ eautoreconf || die "Failed running eautoreconf."
+
local myconf="--with-x \
--host=${CHOST}"