summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-02-01 12:16:54 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-02-01 12:16:54 +0000
commit2686c33abff640f8ce144717769e3d0b7e5a3814 (patch)
treec1af045f68b36de6ca050ae909f03bba0f891b73 /sci-visualization
parentamd64/x86 stable, bug #256858 (diff)
downloadgentoo-2-2686c33abff640f8ce144717769e3d0b7e5a3814.tar.gz
gentoo-2-2686c33abff640f8ce144717769e3d0b7e5a3814.tar.bz2
gentoo-2-2686c33abff640f8ce144717769e3d0b7e5a3814.zip
Version bump, removed old versions
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/gwyddion/ChangeLog10
-rw-r--r--sci-visualization/gwyddion/gwyddion-2.10.ebuild5
-rw-r--r--sci-visualization/gwyddion/gwyddion-2.12.ebuild74
-rw-r--r--sci-visualization/gwyddion/gwyddion-2.5.ebuild37
-rw-r--r--sci-visualization/gwyddion/gwyddion-2.9.ebuild39
-rw-r--r--sci-visualization/gwyddion/metadata.xml10
6 files changed, 92 insertions, 83 deletions
diff --git a/sci-visualization/gwyddion/ChangeLog b/sci-visualization/gwyddion/ChangeLog
index 68bbb9fb1cb8..23d0eafb0338 100644
--- a/sci-visualization/gwyddion/ChangeLog
+++ b/sci-visualization/gwyddion/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-visualization/gwyddion
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gwyddion/ChangeLog,v 1.15 2008/12/03 22:36:31 maekke Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gwyddion/ChangeLog,v 1.16 2009/02/01 12:16:54 bicatali Exp $
+
+*gwyddion-2.12 (30 Jan 2009)
+
+ 30 Jan 2009; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml,
+ -gwyddion-2.5.ebuild, -gwyddion-2.9.ebuild, +gwyddion-2.12.ebuild:
+ Version bump, removed older versions
03 Dec 2008; Markus Meier <maekke@gentoo.org> gwyddion-2.10.ebuild:
amd64/x86 stable, bug #249408
diff --git a/sci-visualization/gwyddion/gwyddion-2.10.ebuild b/sci-visualization/gwyddion/gwyddion-2.10.ebuild
index f9a9e0c6ef8d..88520929f912 100644
--- a/sci-visualization/gwyddion/gwyddion-2.10.ebuild
+++ b/sci-visualization/gwyddion/gwyddion-2.10.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gwyddion/gwyddion-2.10.ebuild,v 1.3 2008/12/03 22:36:31 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gwyddion/gwyddion-2.10.ebuild,v 1.4 2009/02/01 12:16:54 bicatali Exp $
DESCRIPTION="A software framework for SPM data analysis"
HOMEPAGE="http://gwyddion.net/"
@@ -32,6 +32,7 @@ src_compile() {
$(use_enable nls) \
$(use_with fftw fftw3) \
$(use_with tiff) \
+ --disable-pascal \
--disable-desktop-file-update \
--enable-library-bloat
emake || die "emake failed."
diff --git a/sci-visualization/gwyddion/gwyddion-2.12.ebuild b/sci-visualization/gwyddion/gwyddion-2.12.ebuild
new file mode 100644
index 000000000000..65c735a948a1
--- /dev/null
+++ b/sci-visualization/gwyddion/gwyddion-2.12.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gwyddion/gwyddion-2.12.ebuild,v 1.1 2009/02/01 12:16:54 bicatali Exp $
+
+EAPI=2
+inherit fdo-mime gnome2-utils
+
+DESCRIPTION="A software framework for SPM data analysis"
+HOMEPAGE="http://gwyddion.net/"
+SRC_URI="http://gwyddion.net/download/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="fftw gnome kde nls opengl perl python ruby sourceview tiff xml"
+
+RDEPEND=">=x11-libs/gtk+-2.8
+ x11-libs/cairo
+ x11-libs/pango
+ x11-libs/libXmu
+ fftw? ( >=sci-libs/fftw-3 )
+ gnome? ( gnome-base/gconf )
+ kde? ( >=kde-base/kdelibs-4 )
+ opengl? ( virtual/opengl x11-libs/gtkglext )
+ perl? ( dev-lang/perl )
+ python? ( dev-python/pygtk )
+ ruby? ( dev-ruby/narray )
+ sourceview? ( >=x11-libs/gtksourceview-2 )
+ tiff? ( media-libs/tiff )
+ xml? ( dev-libs/libxml2 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( dev-util/gtk-doc )"
+
+src_configure() {
+ econf \
+ --disable-desktop-file-update \
+ --disable-rpath \
+ --enable-library-bloat \
+ --enable-plugin-proxy \
+ $(use_enable doc gtk-doc) \
+ $(use_enable nls) \
+ $(use_enable python pygwy) \
+ $(use_with perl) \
+ $(use_with python) \
+ $(use_with ruby) \
+ $(use_with fftw fftw3) \
+ $(use_with opengl gl) \
+ $(use_with sourceview gtksourceview) \
+ $(use_with tiff) \
+ $(use_with xml spml) \
+ $(use_with X x) \
+ $(use_with kde kde4-thumbnailer)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+ use python && dodoc modules/pygwy/README.pygwy
+}
+
+pkg_postinst() {
+ use gnome && gnome2_gconf_install
+ fdo-mime_desktop_database_update
+}
+
+pkg_prerm() {
+ use gnome && gnome2_gconf_uninstall
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}
diff --git a/sci-visualization/gwyddion/gwyddion-2.5.ebuild b/sci-visualization/gwyddion/gwyddion-2.5.ebuild
deleted file mode 100644
index 60ed89a21b76..000000000000
--- a/sci-visualization/gwyddion/gwyddion-2.5.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gwyddion/gwyddion-2.5.ebuild,v 1.4 2008/04/21 16:09:51 bicatali Exp $
-
-DESCRIPTION="A software framework for SPM data analysis"
-HOMEPAGE="http://gwyddion.net/"
-SRC_URI="http://gwyddion.net/download/${PV}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-IUSE="python perl ruby nls"
-
-RDEPEND="virtual/opengl
- python? ( virtual/python )
- perl? ( dev-lang/perl )
- ruby? ( virtual/ruby )
- >=x11-libs/gtk+-2.6
- x11-libs/gtkglext"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-src_compile() {
- econf \
- $(use_enable python) \
- $(use_enable perl) \
- $(use_enable ruby) \
- $(use_enable nls) \
- --disable-desktop-file-update \
- || die "econf failed."
- emake || die "emake failed."
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed."
- dodoc AUTHORS ChangeLog NEWS README THANKS TODO
-}
diff --git a/sci-visualization/gwyddion/gwyddion-2.9.ebuild b/sci-visualization/gwyddion/gwyddion-2.9.ebuild
deleted file mode 100644
index 42e23edf3c4c..000000000000
--- a/sci-visualization/gwyddion/gwyddion-2.9.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gwyddion/gwyddion-2.9.ebuild,v 1.2 2008/04/21 16:09:51 bicatali Exp $
-
-DESCRIPTION="A software framework for SPM data analysis"
-HOMEPAGE="http://gwyddion.net/"
-SRC_URI="http://gwyddion.net/download/${PV}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="python perl ruby nls"
-
-RDEPEND="virtual/opengl
- python? ( virtual/python )
- perl? ( dev-lang/perl )
- ruby? ( virtual/ruby )
- >=x11-libs/gtk+-2.8
- x11-libs/pango
- x11-libs/cairo
- x11-libs/gtkglext"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-src_compile() {
- econf \
- $(use_enable python) \
- $(use_enable perl) \
- $(use_enable ruby) \
- $(use_enable nls) \
- --disable-desktop-file-update \
- || die "econf failed."
- emake || die "emake failed."
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed."
- dodoc AUTHORS ChangeLog NEWS README THANKS TODO
-}
diff --git a/sci-visualization/gwyddion/metadata.xml b/sci-visualization/gwyddion/metadata.xml
index ad4880a3551e..9c631024fce7 100644
--- a/sci-visualization/gwyddion/metadata.xml
+++ b/sci-visualization/gwyddion/metadata.xml
@@ -7,8 +7,12 @@
</maintainer>
<longdescription>
Gwyddion is a modular program for SPM data analysis. Primarily it is
- supposed to be used for analysis of height fields obtained by means of
- scanning probe microscopy techniques (AFM, MFM, STM, NSOM), but generally it
- can be used for any other height field analysis or image analysis.
+ supposed to be used for analysis of height fields obtained by means of
+ scanning probe microscopy techniques (AFM, MFM, STM, NSOM), but
+ generally it can be used for any other height field analysis or
+ image analysis.
</longdescription>
+ <use>
+ <flag name="sourceview">Enable support for <pkg>x11-libs/gtksourceview</pkg></flag>
+ </use>
</pkgmetadata>