summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-12-18 22:57:38 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-12-18 22:57:38 +0000
commit424b7ebcd4002396053b7c1d1194ac3c52a6464c (patch)
treec5046b2057683e60530e26fd72935a4163b7670b /sci-visualization/qtiplot
parentVersion bump, #249271. Fixes #145727, #193731, #204702, #211250, #226009 and ... (diff)
downloadgentoo-2-424b7ebcd4002396053b7c1d1194ac3c52a6464c.tar.gz
gentoo-2-424b7ebcd4002396053b7c1d1194ac3c52a6464c.tar.bz2
gentoo-2-424b7ebcd4002396053b7c1d1194ac3c52a6464c.zip
Added patch to fix problem with sip-4.7.9 and qtiplot's sip file (see bug #250014).
(Portage version: 2.2_rc17/cvs/Linux 2.6.27-gentoo-r5 x86_64)
Diffstat (limited to 'sci-visualization/qtiplot')
-rw-r--r--sci-visualization/qtiplot/ChangeLog7
-rw-r--r--sci-visualization/qtiplot/files/qtiplot-0.9.7.3-sip.patch30
-rw-r--r--sci-visualization/qtiplot/qtiplot-0.9.7.3.ebuild3
3 files changed, 38 insertions, 2 deletions
diff --git a/sci-visualization/qtiplot/ChangeLog b/sci-visualization/qtiplot/ChangeLog
index 19bcc6cce651..d3f6aaf46fa7 100644
--- a/sci-visualization/qtiplot/ChangeLog
+++ b/sci-visualization/qtiplot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-visualization/qtiplot
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/ChangeLog,v 1.37 2008/11/14 14:04:46 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/ChangeLog,v 1.38 2008/12/18 22:57:38 markusle Exp $
+
+ 18 Dec 2008; Markus Dittrich <markusle@gentoo.org>
+ +files/qtiplot-0.9.7.3-sip.patch, qtiplot-0.9.7.3.ebuild:
+ Added patch to fix problem with sip-4.7.9 and qtiplot's sip files
+ (see bug #250014).
13 Nov 2008; Markus Dittrich <markusle@gentoo.org>
+files/qtiplot-0.9.7.3-no-python.patch, qtiplot-0.9.7.3.ebuild:
diff --git a/sci-visualization/qtiplot/files/qtiplot-0.9.7.3-sip.patch b/sci-visualization/qtiplot/files/qtiplot-0.9.7.3-sip.patch
new file mode 100644
index 000000000000..2182c14e673e
--- /dev/null
+++ b/sci-visualization/qtiplot/files/qtiplot-0.9.7.3-sip.patch
@@ -0,0 +1,30 @@
+diff -Naur qtiplot-0.9.7.3/qtiplot/src/scripting/qti.sip qtiplot-0.9.7.3.new/qtiplot/src/scripting/qti.sip
+--- qtiplot-0.9.7.3/qtiplot/src/scripting/qti.sip 2008-10-20 06:32:35.000000000 -0400
++++ qtiplot-0.9.7.3.new/qtiplot/src/scripting/qti.sip 2008-12-18 17:24:44.000000000 -0500
+@@ -74,8 +74,6 @@
+ MdiSubWindow(const MdiSubWindow&);
+ };
+
+-typedef QList<MdiSubWindow*> MDIWindowList;
+-
+ class Table: MdiSubWindow
+ {
+ %TypeHeaderCode
+@@ -1072,7 +1070,7 @@
+ Graph3D* plotParametricSurface(const QString&, const QString&, const QString&,
+ double, double, double, double, int=40, int=40, bool=true, bool=true) /PyName=plot3D/;
+
+- MDIWindowList windowsList() /PyName=windows/;
++ QList<MdiSubWindow*> windowsList() /PyName=windows/;
+
+ // folders
+ Folder *activeFolder() /NoDerived/;
+@@ -1867,7 +1865,7 @@
+ #include "src/core/Folder.h"
+ %End
+ public:
+- MDIWindowList windowsList() /PyName=windows/;
++ QList<MdiSubWindow*> windowsList() /PyName=windows/;
+ // TODO: implement signal Folder::nameChanged and make it update the project explorer; adjust renaming from GUI accordingly
+ // void setFolderName(const QString&) /PyName=setName/;
+ QString name();
diff --git a/sci-visualization/qtiplot/qtiplot-0.9.7.3.ebuild b/sci-visualization/qtiplot/qtiplot-0.9.7.3.ebuild
index 706c7f0890aa..07e5a5bdb096 100644
--- a/sci-visualization/qtiplot/qtiplot-0.9.7.3.ebuild
+++ b/sci-visualization/qtiplot/qtiplot-0.9.7.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/qtiplot-0.9.7.3.ebuild,v 1.2 2008/11/14 14:04:46 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/qtiplot-0.9.7.3.ebuild,v 1.3 2008/12/18 22:57:38 markusle Exp $
EAPI="1"
inherit eutils multilib qt4 fdo-mime python
@@ -50,6 +50,7 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-0.9.7-gcc4.3.patch
epatch "${FILESDIR}"/${PN}-0.9.7.2-liborigin-gcc4.3.patch
epatch "${FILESDIR}"/${P}-no-python.patch
+ epatch "${FILESDIR}"/${P}-sip.patch
sed -i \
-e '/manual/d'\