summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2008-05-27 21:09:44 +0000
committerAndrey Grozin <grozin@gentoo.org>2008-05-27 21:09:44 +0000
commit310c1f699abd5d6874a2c50415930508ba2de6d0 (patch)
treef3593772c139e43191ec46b6a6435b3dad0cbcd0 /sci-visualization/qtiplot
parentFirst release candidate for OpenOffice.org 2.4.1, masked for testing (diff)
downloadgentoo-2-310c1f699abd5d6874a2c50415930508ba2de6d0.tar.gz
gentoo-2-310c1f699abd5d6874a2c50415930508ba2de6d0.tar.bz2
gentoo-2-310c1f699abd5d6874a2c50415930508ba2de6d0.zip
Python files are now installed to the proper place and compiled (bugs #223671, #223673)
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-visualization/qtiplot')
-rw-r--r--sci-visualization/qtiplot/ChangeLog7
-rw-r--r--sci-visualization/qtiplot/files/qtiplot-0.9.6.2-pro.patch7
-rw-r--r--sci-visualization/qtiplot/qtiplot-0.9.6.2.ebuild25
3 files changed, 26 insertions, 13 deletions
diff --git a/sci-visualization/qtiplot/ChangeLog b/sci-visualization/qtiplot/ChangeLog
index f05047845925..a84b01ce01fd 100644
--- a/sci-visualization/qtiplot/ChangeLog
+++ b/sci-visualization/qtiplot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-visualization/qtiplot
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/ChangeLog,v 1.26 2008/05/24 17:02:04 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/ChangeLog,v 1.27 2008/05/27 21:09:44 grozin Exp $
+
+ 28 May 2008; Andrey Grozin <grozin@gentoo.org>
+ files/qtiplot-0.9.6.2-pro.patch, qtiplot-0.9.6.2.ebuild:
+ Python files are now installed to the proper place and compiled (bugs
+ #223671, #223673)
25 May 2008; Andrey Grozin <grozin@gentoo.org>
files/qtiplot-0.9.6.2-pro.patch:
diff --git a/sci-visualization/qtiplot/files/qtiplot-0.9.6.2-pro.patch b/sci-visualization/qtiplot/files/qtiplot-0.9.6.2-pro.patch
index db7dbbe2ca87..fb8ba3f71fd9 100644
--- a/sci-visualization/qtiplot/files/qtiplot-0.9.6.2-pro.patch
+++ b/sci-visualization/qtiplot/files/qtiplot-0.9.6.2-pro.patch
@@ -60,10 +60,3 @@ diff -r -U2 qtiplot-0.9.6.2.orig/qtiplot/qtiplot.pro qtiplot-0.9.6.2/qtiplot/qti
+# SOURCES += ../3rdparty/liborigin/OPJFile.cpp
###############################################################
-@@ -474,5 +475,5 @@
- qti_wordlist.txt \
-
-- unix: pythonconfig.path = /usr/local/qtiplot
-+ unix: pythonconfig.path = /usr/share/qtiplot
- win32: pythonconfig.path = $$INSTALLBASE
- DEFINES += PYTHON_CONFIG_PATH="\\\"$$replace(pythonconfig.path," ","\ ")\\\"
diff --git a/sci-visualization/qtiplot/qtiplot-0.9.6.2.ebuild b/sci-visualization/qtiplot/qtiplot-0.9.6.2.ebuild
index d47c9eddb4d8..c32bc23b0502 100644
--- a/sci-visualization/qtiplot/qtiplot-0.9.6.2.ebuild
+++ b/sci-visualization/qtiplot/qtiplot-0.9.6.2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/qtiplot-0.9.6.2.ebuild,v 1.3 2008/05/24 09:08:15 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/qtiplot-0.9.6.2.ebuild,v 1.4 2008/05/27 21:09:44 grozin Exp $
EAPI="1"
-inherit eutils multilib qt4 fdo-mime
+inherit eutils multilib qt4 fdo-mime python
DESCRIPTION="Qt based clone of the Origin plotting package"
HOMEPAGE="http://soft.proindependent.com/qtiplot.html"
@@ -47,9 +47,13 @@ src_unpack() {
-e '/manual/d'\
-e '/3rd/d' \
qtiplot.pro || die "sed qtiplot.pro failed"
+
+ python_version
+
sed -i \
-e '/manual/d' \
-e "s:doc/${PN}:doc/${PF}:" \
+ -e "s:local/${PN}:$(get_libdir)/python${PYVER}/site-packages:" \
qtiplot/qtiplot.pro || die " sed for qtiplot/qtiplot.pro failed"
if ! use python; then
@@ -83,6 +87,7 @@ src_compile() {
src_install() {
emake INSTALL_ROOT="${D}" install || die 'emake install failed'
rm -f "${D}"/usr/share/${PN}/translations/*.ts
+ use python && chmod -x "${D}"/usr/$(get_libdir)/python${PYVER}/site-packages/qti_wordlist.txt
newicon qtiplot_logo.png qtiplot.png
make_desktop_entry qtiplot QtiPlot qtiplot
@@ -97,15 +102,25 @@ src_install() {
pkg_postinst() {
fdo-mime_desktop_database_update
+
+ if use python; then
+ python_version
+ for pymod in qtiplotrc qtiUtil; do
+ python_mod_compile "${ROOT}"usr/$(get_libdir)/python${PYVER}/site-packages/${pymod}.py
+ done
+ fi
+
if use doc; then
elog "On the first start, do Help -> Choose Help Folder"
elog "and select /usr/share/doc/${PF}/html"
- elog "Also do View -> Preferences, in the tab File Locations"
- elog "set Python Configuration Files to /usr/share/${PN}"
- elog "and Translations to /usr/share/${PN}/translations"
fi
}
pkg_postrm() {
fdo-mime_desktop_database_update
+
+ if use python; then
+ python_version
+ python_mod_cleanup
+ fi
}