summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2006-10-10 21:48:15 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2006-10-10 21:48:15 +0000
commiteca690257ff8a31f5e863be527b2a364f759321c (patch)
treef7151e56f1e95c43efe057c95d5755c86d71963f /sci-visualization/gnuplot
parentStable for HPPA (bug #146939). (diff)
downloadgentoo-2-eca690257ff8a31f5e863be527b2a364f759321c.tar.gz
gentoo-2-eca690257ff8a31f5e863be527b2a364f759321c.tar.bz2
gentoo-2-eca690257ff8a31f5e863be527b2a364f759321c.zip
add masked rc and fix bug #82940
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'sci-visualization/gnuplot')
-rw-r--r--sci-visualization/gnuplot/ChangeLog9
-rw-r--r--sci-visualization/gnuplot/files/digest-gnuplot-4.2_rc13
-rw-r--r--sci-visualization/gnuplot/gnuplot-4.0-r1.ebuild4
-rw-r--r--sci-visualization/gnuplot/gnuplot-4.2_rc1.ebuild142
4 files changed, 155 insertions, 3 deletions
diff --git a/sci-visualization/gnuplot/ChangeLog b/sci-visualization/gnuplot/ChangeLog
index d7c54ca67a03..d9dbec214ee1 100644
--- a/sci-visualization/gnuplot/ChangeLog
+++ b/sci-visualization/gnuplot/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-visualization/gnuplot
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gnuplot/ChangeLog,v 1.4 2006/07/12 02:32:19 g2boojum Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gnuplot/ChangeLog,v 1.5 2006/10/10 21:48:15 g2boojum Exp $
+
+*gnuplot-4.2_rc1 (10 Oct 2006)
+
+ 10 Oct 2006; Grant Goodyear <g2boojum@gentoo.org> gnuplot-4.0-r1.ebuild,
+ +gnuplot-4.2_rc1.ebuild:
+ Added 4.2 rc (masked) and added addwrite statements to
+ close bug #82940.
12 Jul 2006; Grant Goodyear <g2boojum@gentoo.org> ChangeLog:
Removed 3.x gnuplot builds.
diff --git a/sci-visualization/gnuplot/files/digest-gnuplot-4.2_rc1 b/sci-visualization/gnuplot/files/digest-gnuplot-4.2_rc1
new file mode 100644
index 000000000000..a6431d58da44
--- /dev/null
+++ b/sci-visualization/gnuplot/files/digest-gnuplot-4.2_rc1
@@ -0,0 +1,3 @@
+MD5 eb254de6bed84f7d862ca547a0badb9a gnuplot-4.2.rc1.tar.gz 2808610
+RMD160 6080bfca41aaedc75842b0272f1f82d7c61a9fe1 gnuplot-4.2.rc1.tar.gz 2808610
+SHA256 b8294f526710d622e3831a5d37d880aa16070baf3445d3981a216f678418020c gnuplot-4.2.rc1.tar.gz 2808610
diff --git a/sci-visualization/gnuplot/gnuplot-4.0-r1.ebuild b/sci-visualization/gnuplot/gnuplot-4.0-r1.ebuild
index 5d53b7b039a6..cd721ecb1490 100644
--- a/sci-visualization/gnuplot/gnuplot-4.0-r1.ebuild
+++ b/sci-visualization/gnuplot/gnuplot-4.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gnuplot/gnuplot-4.0-r1.ebuild,v 1.2 2006/03/24 16:40:14 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gnuplot/gnuplot-4.0-r1.ebuild,v 1.3 2006/10/10 21:48:15 g2boojum Exp $
inherit eutils elisp-common
@@ -62,7 +62,7 @@ src_compile() {
# This is a hack to avoid sandbox violations when using the Linux console.
# Creating the DVI and PDF tutorials require /dev/svga to build the
# example plots.
- addwrite /dev/svga
+ addwrite /dev/svga /dev/mouse /dev/tts/0
econf ${myconf} || die
emake || die
diff --git a/sci-visualization/gnuplot/gnuplot-4.2_rc1.ebuild b/sci-visualization/gnuplot/gnuplot-4.2_rc1.ebuild
new file mode 100644
index 000000000000..1d89518bff29
--- /dev/null
+++ b/sci-visualization/gnuplot/gnuplot-4.2_rc1.ebuild
@@ -0,0 +1,142 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gnuplot/gnuplot-4.2_rc1.ebuild,v 1.1 2006/10/10 21:48:15 g2boojum Exp $
+
+inherit eutils elisp-common
+
+MY_P="${P/_/.}"
+
+DESCRIPTION="Command-line driven interactive plotting program"
+HOMEPAGE="http://www.gnuplot.info/"
+SRC_URI="mirror://sourceforge/gnuplot/${MY_P}.tar.gz"
+
+LICENSE="gnuplot"
+SLOT="0"
+KEYWORDS="alpha amd64 ~hppa ia64 ppc ppc-macos ppc64 s390 sparc x86"
+IUSE="doc emacs gd ggi pdf plotutils png readline svga X xemacs"
+
+DEPEND="
+ xemacs? ( virtual/xemacs )
+ emacs? ( virtual/emacs !app-emacs/gnuplot-mode )
+ pdf? ( media-libs/pdflib )
+ ggi? ( media-libs/libggi )
+ png? ( media-libs/libpng )
+ gd? ( >=media-libs/gd-2 )
+ doc? ( virtual/tetex )
+ X? ( || ( x11-libs/libXaw virtual/x11 ) )
+ svga? ( media-libs/svgalib )
+ readline? ( >=sys-libs/readline-4.2 )
+ plotutils? ( media-libs/plotutils )"
+
+S=${WORKDIR}/${MY_P}
+
+E_SITEFILE="50gnuplot-gentoo.el"
+
+#src_unpack() {
+# unpack ${A}
+# cd ${S}
+# epatch ${FILESDIR}/header-order.patch
+# epatch ${FILESDIR}/pdflib-6-compat.patch
+#}
+
+src_compile() {
+ local myconf="--with-gihdir=/usr/share/${PN}/gih"
+
+ myconf="${myconf} $(use_with X x)"
+ myconf="${myconf} $(use_with svga linux-vga)"
+ myconf="${myconf} $(use_with gd)"
+ myconf="${myconf} $(use_with plotutils plot /usr/lib)"
+ myconf="${myconf} $(use_with png png /usr/lib)"
+ myconf="${myconf} $(use_with pdf pdf /usr/lib)"
+
+ use ggi \
+ && myconf="${myconf} --with-ggi=/usr/lib --with-xmi=/usr/lib" \
+ || myconf="${myconf} --without-ggi"
+
+ use readline \
+ && myconf="${myconf} --with-readline=gnu --enable-history-file" \
+ || myconf="${myconf} --with-readline"
+
+ myconf="${myconf} --without-lisp-files"
+
+ # This is a hack to avoid sandbox violations when using the Linux console.
+ # Creating the DVI and PDF tutorials require /dev/svga to build the
+ # example plots.
+ addwrite /dev/svga /dev/mouse /dev/tts/0
+
+ econf ${myconf} || die
+ emake || die
+
+ if use doc ; then
+ cd docs
+ make pdf || die
+ cd ../tutorial
+ make pdf || die
+ fi
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ if use emacs; then
+ cd lisp
+ einfo "Configuring gnuplot-mode for emacs..."
+ EMACS="emacs" lispdir="/usr/share/emacs/site-lisp/${PN}" econf || die
+ make DESTDIR=${D} install || die
+ make clean
+ cd ..
+
+ # Gentoo emacs site-lisp configuration
+ string="(add-to-list 'load-path \"/usr/share/emacs/site-lisp/${PN}\")"
+ echo -e ";;; Gnuplot site-lisp configuration\n\n${string}\n" > ${E_SITEFILE}
+ sed '/^;; move/,+4 d' lisp/dotemacs >> ${E_SITEFILE}
+ elisp-site-file-install ${E_SITEFILE}
+ fi
+
+ if use xemacs; then
+ cd lisp
+ einfo "Configuring gnuplot-mode for xemacs..."
+ EMACS="xemacs" lispdir="/usr/lib/xemacs/site-packages/${PN}" econf || die
+ make DESTDIR=${D} install || {
+ ewarn "Compiling/installing gnuplot-mode for xemacs has failed."
+ ewarn "I need xemacs-base to be installed before I can compile"
+ ewarn "the gnuplot-mode lisp files for xemacs successfully."
+ ewarn "Please try re-emerging me after app-xemacs/xemacs-base"
+ ewarn "has been successfuly emerged."
+ die
+ }
+ cd ..
+ fi
+
+
+ dodoc BUGS ChangeLog FAQ NEWS PATCHLEVEL PGPKEYS PORTING README* TODO VERSION
+
+ if use doc; then
+ # Demo files
+ insinto /usr/share/${PN}/demo
+ doins demo/*
+ # Manual
+ insinto /usr/share/doc/${PF}/manual
+ doins docs/gnuplot.pdf
+ # Tutorial
+ insinto /usr/share/doc/${PF}/tutorial
+ doins tutorial/{tutorial.dvi,tutorial.pdf}
+ # Documentation for making PostScript files
+ insinto /usr/share/doc/${PF}/psdoc
+ doins docs/psdoc/{*.doc,*.tex,*.ps,*.gpi,README}
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ if use svga ; then
+ einfo "In order to enable ordinary users to use SVGA console graphics"
+ einfo "gnuplot needs to be set up as setuid root. Please note that"
+ einfo "this is usually considered to be a security hazard."
+ einfo "As root, manually \"chmod u+s /usr/bin/gnuplot\"."
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}