summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-03-14 14:37:17 +0000
committerUlrich Müller <ulm@gentoo.org>2010-03-14 14:37:17 +0000
commitd944280643aa95ac2185e798cdf918eb8e29bb68 (patch)
tree110f3b3a1ba277d1f5b0e88f118eaf00b84ca5bf /sci-visualization/gnuplot
parentkeyword ~amd64 added (diff)
downloadgentoo-2-d944280643aa95ac2185e798cdf918eb8e29bb68.tar.gz
gentoo-2-d944280643aa95ac2185e798cdf918eb8e29bb68.tar.bz2
gentoo-2-d944280643aa95ac2185e798cdf918eb8e29bb68.zip
Version bump, comprising changes from science overlay.
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'sci-visualization/gnuplot')
-rw-r--r--sci-visualization/gnuplot/ChangeLog9
-rw-r--r--sci-visualization/gnuplot/gnuplot-4.4.0.ebuild212
-rw-r--r--sci-visualization/gnuplot/metadata.xml1
3 files changed, 221 insertions, 1 deletions
diff --git a/sci-visualization/gnuplot/ChangeLog b/sci-visualization/gnuplot/ChangeLog
index 74a8ae00f6f6..9bb13eded3f2 100644
--- a/sci-visualization/gnuplot/ChangeLog
+++ b/sci-visualization/gnuplot/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-visualization/gnuplot
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gnuplot/ChangeLog,v 1.135 2010/03/07 20:02:31 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gnuplot/ChangeLog,v 1.136 2010/03/14 14:37:17 ulm Exp $
+
+*gnuplot-4.4.0 (14 Mar 2010)
+
+ 14 Mar 2010; Ulrich Mueller <ulm@gentoo.org> +gnuplot-4.4.0.ebuild,
+ metadata.xml:
+ Version bump. This comprises changes from science overlay, thanks to
+ Christoph Junghans <kleiner_otti@gmx.de>. New thin-splines local USE flag.
07 Mar 2010; Ulrich Mueller <ulm@gentoo.org> gnuplot-4.2.6-r1.ebuild:
Only build-time dependencies are needed with USE=doc.
diff --git a/sci-visualization/gnuplot/gnuplot-4.4.0.ebuild b/sci-visualization/gnuplot/gnuplot-4.4.0.ebuild
new file mode 100644
index 000000000000..ac9586f79cd0
--- /dev/null
+++ b/sci-visualization/gnuplot/gnuplot-4.4.0.ebuild
@@ -0,0 +1,212 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gnuplot/gnuplot-4.4.0.ebuild,v 1.1 2010/03/14 14:37:17 ulm Exp $
+
+EAPI=2
+
+inherit elisp-common multilib wxwidgets
+
+MY_P="${P/_/-}"
+DESCRIPTION="Command-line driven interactive plotting program"
+HOMEPAGE="http://www.gnuplot.info/"
+SRC_URI="mirror://sourceforge/gnuplot/${MY_P}.tar.gz"
+
+LICENSE="gnuplot GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd"
+IUSE="cairo doc emacs +gd ggi latex lua pdf plotutils readline svga thin-splines wxwidgets X xemacs"
+RESTRICT="wxwidgets? ( test )"
+
+RDEPEND="!app-emacs/gnuplot-mode
+ cairo? ( x11-libs/cairo
+ x11-libs/pango
+ >=x11-libs/gtk+-2.8 )
+ emacs? ( virtual/emacs )
+ gd? ( media-libs/gd[png] )
+ ggi? ( media-libs/libggi )
+ latex? ( virtual/latex-base
+ lua? ( dev-tex/pgf
+ >=dev-texlive/texlive-latexrecommended-2008-r2 ) )
+ lua? ( dev-lang/lua )
+ pdf? ( media-libs/pdflib )
+ plotutils? ( media-libs/plotutils )
+ readline? ( sys-libs/readline )
+ svga? ( media-libs/svgalib )
+ wxwidgets? ( x11-libs/wxGTK:2.8[X]
+ x11-libs/cairo
+ x11-libs/pango
+ >=x11-libs/gtk+-2.8 )
+ X? ( x11-libs/libXaw )
+ xemacs? ( app-editors/xemacs
+ app-xemacs/xemacs-base
+ app-xemacs/texinfo )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( virtual/latex-base
+ app-text/ghostscript-gpl )"
+
+S="${WORKDIR}/${MY_P}"
+GP_VERSION="${PV%.*}"
+E_SITEFILE="50${PN}-gentoo.el"
+TEXMF="/usr/share/texmf-site"
+
+src_prepare() {
+ # Add special version identification as required by provision 2
+ # of the gnuplot license
+ sed -i -e "1s/.*/& (Gentoo revision ${PR})/" PATCHLEVEL || die
+}
+
+src_configure() {
+ if ! use latex; then
+ sed -i -e '/SUBDIRS/s/LaTeX//' share/Makefile.in || die
+ fi
+
+ if use wxwidgets; then
+ WX_GTK_VER="2.8"
+ need-wxwidgets unicode
+ fi
+
+ local myconf
+ myconf="${myconf} --without-lisp-files"
+ myconf="${myconf} --with-texdir=${TEXMF}/tex/latex/${PN}"
+ myconf="${myconf} $(use_with cairo)"
+ myconf="${myconf} $(use_with doc tutorial)"
+ myconf="${myconf} $(use_with gd)"
+ myconf="${myconf} $(use_with ggi ggi /usr/$(get_libdir))"
+ myconf="${myconf} $(use_with ggi xmi /usr/$(get_libdir))"
+ myconf="${myconf} $(use_with lua)"
+ myconf="${myconf} $(use_with pdf pdf /usr/$(get_libdir))"
+ myconf="${myconf} $(use_with plotutils plot /usr/$(get_libdir))"
+ myconf="${myconf} $(use_with svga linux-vga)"
+ myconf="${myconf} $(use_enable thin-splines)"
+ myconf="${myconf} $(use_enable wxwidgets)"
+ myconf="${myconf} $(use_with X x)"
+ use readline \
+ && myconf="${myconf} --with-readline=gnu" \
+ || myconf="${myconf} --with-readline=builtin"
+
+ econf ${myconf} DIST_CONTACT="http://bugs.gentoo.org/"
+
+ if use xemacs; then
+ einfo "Configuring gnuplot-mode for XEmacs ..."
+ use emacs && cp -Rp lisp lisp-xemacs || ln -s lisp lisp-xemacs
+ cd "${S}/lisp-xemacs"
+ econf --with-lispdir="/usr/lib/xemacs/site-packages/${PN}" EMACS=xemacs
+ fi
+
+ if use emacs; then
+ einfo "Configuring gnuplot-mode for GNU Emacs ..."
+ cd "${S}/lisp"
+ econf --with-lispdir="${SITELISP}/${PN}" EMACS=emacs
+ fi
+}
+
+src_compile() {
+ # Prevent access violations, see bug 201871
+ VARTEXFONTS="${T}/fonts"
+
+ # This is a hack to avoid sandbox violations when using the Linux console.
+ # Creating the DVI and PDF tutorials require /dev/svga to build the
+ # example plots.
+ addwrite /dev/svga:/dev/mouse:/dev/tts/0
+
+ emake || die
+
+ if use xemacs; then
+ cd "${S}/lisp-xemacs"
+ emake || die
+ fi
+
+ if use emacs; then
+ cd "${S}/lisp"
+ emake || die
+ fi
+
+ if use doc; then
+ # Avoid sandbox violation in epstopdf/ghostscript
+ addpredict /var/cache/fontconfig
+ cd "${S}/docs"
+ emake pdf || die
+ cd "${S}/tutorial"
+ emake pdf || die
+
+ if use emacs || use xemacs; then
+ cd "${S}/lisp"
+ emake pdf || die
+ fi
+ fi
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die
+
+ if use xemacs; then
+ cd "${S}/lisp-xemacs"
+ emake DESTDIR="${D}" install || die
+ fi
+
+ if use emacs; then
+ cd "${S}/lisp"
+ emake DESTDIR="${D}" install || die
+ # info-look* is included with >=emacs-21
+ rm -f "${D}${SITELISP}/${PN}"/info-look*
+
+ # Gentoo emacs site-lisp configuration
+ echo "(add-to-list 'load-path \"@SITELISP@\")" > ${E_SITEFILE}
+ sed '/^;; move/,+3 d' dotemacs >> ${E_SITEFILE} || die
+ elisp-site-file-install ${E_SITEFILE} || die
+ fi
+
+ cd "${S}"
+ dodoc BUGS ChangeLog NEWS PGPKEYS PORTING README* TODO
+ newdoc term/PostScript/README README-ps
+ newdoc term/js/README README-js
+ use lua && newdoc term/lua/README README-lua
+
+ if use doc; then
+ # Demo files
+ insinto /usr/share/${PN}/${GP_VERSION}
+ doins -r demo || die
+ rm -f "${D}"/usr/share/${PN}/${GP_VERSION}/demo/Makefile*
+ rm -f "${D}"/usr/share/${PN}/${GP_VERSION}/demo/binary*
+ # Manual
+ dodoc docs/gnuplot.pdf
+ # Tutorial
+ dodoc tutorial/{tutorial.dvi,tutorial.pdf}
+ # FAQ
+ dodoc FAQ.pdf
+ # Documentation for making PostScript files
+ docinto psdoc
+ dodoc docs/psdoc/{*.doc,*.tex,*.ps,*.gpi,README}
+ fi
+
+ if use emacs || use xemacs; then
+ docinto emacs
+ dodoc lisp/ChangeLog lisp/README
+ use doc && dodoc lisp/gpelcard.pdf
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ use latex && texmf-update
+
+ if use svga; then
+ einfo "In order to enable ordinary users to use SVGA console graphics"
+ einfo "gnuplot needs to be set up as setuid root. Please note that"
+ einfo "this is usually considered to be a security hazard."
+ einfo "As root, manually \"chmod u+s /usr/bin/gnuplot\"."
+ fi
+ if use gd; then
+ echo
+ einfo "For font support in png/jpeg/gif output, you may have to"
+ einfo "set the GDFONTPATH and GNUPLOT_DEFAULT_GDFONT environment"
+ einfo "variables. See the FAQ file in /usr/share/doc/${PF}/"
+ einfo "for more information."
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+ use latex && texmf-update
+}
diff --git a/sci-visualization/gnuplot/metadata.xml b/sci-visualization/gnuplot/metadata.xml
index 74771480e1cf..c1d62c6e2898 100644
--- a/sci-visualization/gnuplot/metadata.xml
+++ b/sci-visualization/gnuplot/metadata.xml
@@ -8,5 +8,6 @@
<use>
<flag name='gd'>Add support for <pkg>media-libs/gd</pkg>.
Needed for GIF, JPEG, and PNG image output.</flag>
+ <flag name='thin-splines'>Enable thin plate splines</flag>
</use>
</pkgmetadata>