summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-12-09 12:28:36 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-12-09 12:28:36 +0000
commitd4647c1feaf783179ae58de5ce07686ad2e634c9 (patch)
tree0acdafac1247a400ea0b0a35334f44453936b787 /sci-physics
parentVersion bump (diff)
downloadgentoo-2-d4647c1feaf783179ae58de5ce07686ad2e634c9.tar.gz
gentoo-2-d4647c1feaf783179ae58de5ce07686ad2e634c9.tar.bz2
gentoo-2-d4647c1feaf783179ae58de5ce07686ad2e634c9.zip
Added LDFLAGS propagation
(Portage version: 2.2_rc17/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/xfoil/ChangeLog5
-rw-r--r--sci-physics/xfoil/xfoil-6.97.ebuild7
2 files changed, 8 insertions, 4 deletions
diff --git a/sci-physics/xfoil/ChangeLog b/sci-physics/xfoil/ChangeLog
index 98502878c57f..87ad913f1016 100644
--- a/sci-physics/xfoil/ChangeLog
+++ b/sci-physics/xfoil/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-physics/xfoil
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/xfoil/ChangeLog,v 1.10 2008/11/24 15:47:11 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/xfoil/ChangeLog,v 1.11 2008/12/09 12:28:36 bicatali Exp $
+
+ 09 Dec 2008; Sébastien Fabbro <bicatali@gentoo.org> xfoil-6.97.ebuild:
+ Added LDFLAGS propagation
24 Nov 2008; Sébastien Fabbro <bicatali@gentoo.org>
files/xfoil-6.97-overflow.patch, -xfoil-6.96.ebuild:
diff --git a/sci-physics/xfoil/xfoil-6.97.ebuild b/sci-physics/xfoil/xfoil-6.97.ebuild
index 075a209a13e6..b8696fe60de6 100644
--- a/sci-physics/xfoil/xfoil-6.97.ebuild
+++ b/sci-physics/xfoil/xfoil-6.97.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/xfoil/xfoil-6.97.ebuild,v 1.2 2008/08/23 11:43:27 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/xfoil/xfoil-6.97.ebuild,v 1.3 2008/12/09 12:28:36 bicatali Exp $
inherit eutils fortran
@@ -28,7 +28,7 @@ src_unpack() {
-e '/^FFLAGS/d' \
-e '/^CFLAGS/d' \
-e 's/^\(FFLOPT .*\)/FFLOPT = $(FFLAGS)/g' \
- bin/Makefile plotlib/Makefile plotlib/config.make orrs/bin/Makefile \
+ {bin,plotlib,orrs/bin}/Makefile plotlib/config.make \
|| die "sed for flags and compilers failed"
# fix bug #147033
@@ -43,7 +43,7 @@ src_unpack() {
src_compile() {
export FC="${FORTRANC}" F77="${FORTRANC}"
cd "${S}"/orrs/bin
- emake FLG="${FFLAGS}" FTNLIB="" OS || die "failed to build orrs"
+ emake FLG="${FFLAGS}" FTNLIB="${LDFLAGS}" OS || die "failed to build orrs"
cd "${S}"/orrs
bin/osgen osmaps_ns.lst
cd "${S}"/plotlib
@@ -53,6 +53,7 @@ src_compile() {
emake \
PLTOBJ="../plotlib/libPlt.a" \
CFLAGS="${CFLAGS} -DUNDERSCORE" \
+ FTNLIB="${LDFLAGS}" \
${i} || die "failed to build ${i}"
done
}