summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-01-22 02:28:43 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-01-22 02:28:43 +0000
commit58997ded796c47522159ae0027cc7dde412a8866 (patch)
tree29051dc2ebbb3f0f19ec2cbcefffb4c5eef27eb9 /sci-physics
parentRemoved cspase (diff)
downloadgentoo-2-58997ded796c47522159ae0027cc7dde412a8866.tar.gz
gentoo-2-58997ded796c47522159ae0027cc7dde412a8866.tar.bz2
gentoo-2-58997ded796c47522159ae0027cc7dde412a8866.zip
Version bump, switched to cmake. Fixed Qt drivers bug #263450, bug #347279. Removed G4WORKDIR bug #345855.
(Portage version: 2.1.9.34/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/geant/ChangeLog14
-rw-r--r--sci-physics/geant/files/geant-4.9.3-zlib.patch21
-rw-r--r--sci-physics/geant/files/geant-4.9.4-datadir.patch43
-rw-r--r--sci-physics/geant/files/geant-4.9.4-libdir.patch35
-rw-r--r--sci-physics/geant/files/geant-4.9.4-no-benchmarks.patch10
-rw-r--r--sci-physics/geant/files/geant-4.9.4-no-examples.patch15
-rw-r--r--sci-physics/geant/files/geant-4.9.4-zlib.patch11
-rw-r--r--sci-physics/geant/geant-4.9.2_p02.ebuild4
-rw-r--r--sci-physics/geant/geant-4.9.3_p02-r1.ebuild37
-rw-r--r--sci-physics/geant/geant-4.9.4.ebuild87
-rw-r--r--sci-physics/geant/metadata.xml1
11 files changed, 252 insertions, 26 deletions
diff --git a/sci-physics/geant/ChangeLog b/sci-physics/geant/ChangeLog
index 171ee3563dba..bb5a868960d6 100644
--- a/sci-physics/geant/ChangeLog
+++ b/sci-physics/geant/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sci-physics/geant
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/ChangeLog,v 1.43 2010/11/07 21:06:38 xarthisius Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/ChangeLog,v 1.44 2011/01/22 02:28:43 bicatali Exp $
+
+*geant-4.9.4 (22 Jan 2011)
+
+ 22 Jan 2011; Sébastien Fabbro <bicatali@gentoo.org>
+ geant-4.9.3_p02-r1.ebuild, files/geant-4.9.3-zlib.patch, +geant-4.9.4.ebuild,
+ +files/geant-4.9.4-datadir.patch, +files/geant-4.9.4-libdir.patch,
+ +files/geant-4.9.4-no-benchmarks.patch, +files/geant-4.9.4-no-examples.patch,
+ +files/geant-4.9.4-zlib.patch, metadata.xml:
+ Version bump, switched to cmake. Fixed Qt drivers bug #263450, bug #347279.
+ Removed G4WORKDIR bug #345855.
*geant-4.9.3_p02-r1 (07 Nov 2010)
diff --git a/sci-physics/geant/files/geant-4.9.3-zlib.patch b/sci-physics/geant/files/geant-4.9.3-zlib.patch
index 516a4840ae73..f047abdb31cd 100644
--- a/sci-physics/geant/files/geant-4.9.3-zlib.patch
+++ b/sci-physics/geant/files/geant-4.9.3-zlib.patch
@@ -1,7 +1,5 @@
-diff --git a/config/binmake.gmk b/config/binmake.gmk
-index 75bbaf2..c31ed3d 100644
---- a/config/binmake.gmk
-+++ b/config/binmake.gmk
+--- config/binmake.gmk.orig
++++ config/binmake.gmk
@@ -234,7 +234,7 @@ ifdef GLOBALLIBS
-lG4intercoms \
-lG4global
@@ -12,3 +10,18 @@ index 75bbaf2..c31ed3d 100644
endif
+--- config/architecture.gmk.orig 2011-01-16 00:22:05.976079082 +0000
++++ config/architecture.gmk 2011-01-16 00:23:18.346082379 +0000
+@@ -214,8 +214,10 @@
+ else
+ LDFLAGS += -L$(CLHEP_LIB_DIR)
+ LOADLIBS := -l$(CLHEP_LIB) -lm
+- ifndef G4LIB_USE_ZLIB
+- LOADLIBS += -lz
++ ifdef G4LIB_USE_ZLIB
++ ifndef G4LIB_BUILD_ZLIB
++ LOADLIBS += -lz
++ endif
+ endif
+ endif
+
diff --git a/sci-physics/geant/files/geant-4.9.4-datadir.patch b/sci-physics/geant/files/geant-4.9.4-datadir.patch
new file mode 100644
index 000000000000..c691d90e8ce4
--- /dev/null
+++ b/sci-physics/geant/files/geant-4.9.4-datadir.patch
@@ -0,0 +1,43 @@
+--- cmake/Modules/Geant4ToolchainBackwardCompatibility.cmake.orig 2011-01-22 00:49:11.096082056 +0000
++++ cmake/Modules/Geant4ToolchainBackwardCompatibility.cmake 2011-01-22 00:53:04.746078920 +0000
+@@ -74,9 +74,9 @@
+ # Construct backward compatible variables
+ #
+ set(G4SYSTEM "${GEANT4_SYSTEM}-${GEANT4_COMPILER}")
+-set(G4INSTALL ${GEANT4_DATADIR}/geant4-${geant4_VERSION})
++set(G4INSTALL ${GEANT4_DATADIR}/geant4)
+ set(G4INCLUDE ${GEANT4_INCLUDEDIR}/geant4)
+-set(G4LIB ${GEANT4_LIBDIR}/geant4-${geant4_VERSION})
++set(G4LIB ${GEANT4_LIBDIR}/geant4)
+
+ message(STATUS "Geant4 backwards compatible variable G4SYSTEM : ${G4SYSTEM}")
+ message(STATUS "Geant4 backwards compatible variable G4INSTALL: ${G4INSTALL}")
+@@ -125,7 +125,7 @@
+ # Install targets
+ # toolchain
+ install(DIRECTORY config
+- DESTINATION ${GEANT4_DATAROOTDIR}/geant4-${geant4_VERSION}
++ DESTINATION ${GEANT4_DATAROOTDIR}/geant4
+ FILES_MATCHING PATTERN "*.gmk"
+ PATTERN "CVS" EXCLUDE
+ PATTERN "scripts/" EXCLUDE)
+@@ -134,16 +134,16 @@
+ install(FILES
+ ${CMAKE_BINARY_DIR}/outputs/runtime/geant4-${geant4_VERSION}.sh
+ ${CMAKE_BINARY_DIR}/outputs/runtime/geant4-${geant4_VERSION}.csh
+- DESTINATION ${GEANT4_DATAROOTDIR}/geant4-${geant4_VERSION}/config
++ DESTINATION ${GEANT4_DATAROOTDIR}/geant4/config
+ PERMISSIONS
+ OWNER_READ OWNER_WRITE OWNER_EXECUTE
+ GROUP_READ GROUP_EXECUTE
+ WORLD_READ WORLD_EXECUTE)
+
+ # compatibility softlink to library directory
+- install(CODE "execute_process(COMMAND \${CMAKE_COMMAND} -E make_directory \$ENV{DESTDIR}${GEANT4_LIBDIR}/geant4-${geant4_VERSION})")
++ install(CODE "execute_process(COMMAND \${CMAKE_COMMAND} -E make_directory \$ENV{DESTDIR}${GEANT4_LIBDIR}/geant4)")
+
+- install(CODE "execute_process(COMMAND \${CMAKE_COMMAND} -E create_symlink .. ${GEANT4_SYSTEM}-${GEANT4_COMPILER} WORKING_DIRECTORY \$ENV{DESTDIR}${GEANT4_LIBDIR}/geant4-${geant4_VERSION})")
++ install(CODE "execute_process(COMMAND \${CMAKE_COMMAND} -E create_symlink .. ${GEANT4_SYSTEM}-${GEANT4_COMPILER} WORKING_DIRECTORY \$ENV{DESTDIR}${GEANT4_LIBDIR}/geant4)")
+
+ endif()
+
diff --git a/sci-physics/geant/files/geant-4.9.4-libdir.patch b/sci-physics/geant/files/geant-4.9.4-libdir.patch
new file mode 100644
index 000000000000..8934f73acfe9
--- /dev/null
+++ b/sci-physics/geant/files/geant-4.9.4-libdir.patch
@@ -0,0 +1,35 @@
+--- CMakeLists.txt.orig 2011-01-17 06:25:14.536078940 +0000
++++ CMakeLists.txt 2011-01-21 23:50:53.406082074 +0000
+@@ -195,7 +195,7 @@
+ set(GEANT4_PREFIX ${CMAKE_INSTALL_PREFIX})
+ set(GEANT4_EXEC_PREFIX ${GEANT4_PREFIX})
+ set(GEANT4_BINDIR ${GEANT4_EXEC_PREFIX}/bin)
+-set(GEANT4_LIBDIR ${GEANT4_PREFIX}/lib)
++set(GEANT4_LIBDIR ${GEANT4_PREFIX}/lib${LIB_SUFFIX})
+ set(GEANT4_DATAROOTDIR ${GEANT4_PREFIX}/share)
+ set(GEANT4_DATADIR ${GEANT4_DATAROOTDIR})
+ set(GEANT4_INCLUDEDIR ${GEANT4_PREFIX}/include)
+--- cmake/Modules/Geant4MacroLibraryTargets.cmake.orig 2011-01-21 23:36:09.356079013 +0000
++++ cmake/Modules/Geant4MacroLibraryTargets.cmake 2011-01-21 23:49:49.826082339 +0000
+@@ -35,8 +35,8 @@
+ # NEEDS WORK TO REMOVE HARDCODED LIB/BIN DIR
+ install(TARGETS ${G4LIBTARGET_NAME}
+ RUNTIME DESTINATION bin
+- LIBRARY DESTINATION lib
+- ARCHIVE DESTINATION lib)
++ LIBRARY DESTINATION lib${LIB_SUFFIX}
++ ARCHIVE DESTINATION lib${LIB_SUFFIX})
+ endif()
+
+ #
+@@ -59,8 +59,8 @@
+
+ install(TARGETS ${G4LIBTARGET_NAME}-static
+ RUNTIME DESTINATION bin
+- LIBRARY DESTINATION lib
+- ARCHIVE DESTINATION lib)
++ LIBRARY DESTINATION lib${LIB_SUFFIX}
++ ARCHIVE DESTINATION lib${LIB_SUFFIX})
+ endif()
+ ENDMACRO()
+
diff --git a/sci-physics/geant/files/geant-4.9.4-no-benchmarks.patch b/sci-physics/geant/files/geant-4.9.4-no-benchmarks.patch
new file mode 100644
index 000000000000..8c9d47707ac4
--- /dev/null
+++ b/sci-physics/geant/files/geant-4.9.4-no-benchmarks.patch
@@ -0,0 +1,10 @@
+--- source/geometry/CMakeLists.txt.orig 2011-01-17 05:09:38.046080303 +0000
++++ source/geometry/CMakeLists.txt 2011-01-17 05:09:59.636215548 +0000
+@@ -12,7 +12,6 @@
+ #
+ #------------------------------------------------------------------------------
+
+-add_subdirectory(benchmarks)
+ add_subdirectory(biasing)
+ add_subdirectory(divisions)
+ add_subdirectory(magneticfield)
diff --git a/sci-physics/geant/files/geant-4.9.4-no-examples.patch b/sci-physics/geant/files/geant-4.9.4-no-examples.patch
new file mode 100644
index 000000000000..6db7b3f9017d
--- /dev/null
+++ b/sci-physics/geant/files/geant-4.9.4-no-examples.patch
@@ -0,0 +1,15 @@
+--- CMakeLists.txt.orig 2011-01-22 01:47:07.000000000 +0000
++++ CMakeLists.txt 2011-01-22 02:00:58.676084146 +0000
+@@ -209,9 +209,9 @@
+ # Install any extra files needed such as documentation and legacy Makefiles
+ #
+ # User example code
+-install(DIRECTORY examples
+- DESTINATION ${GEANT4_DATAROOTDIR}/geant4-${geant4_VERSION}
+- PATTERN "CVS" EXCLUDE)
++#install(DIRECTORY examples
++# DESTINATION ${GEANT4_DATAROOTDIR}/geant4-${geant4_VERSION}
++# PATTERN "CVS" EXCLUDE)
+
+
+ #
diff --git a/sci-physics/geant/files/geant-4.9.4-zlib.patch b/sci-physics/geant/files/geant-4.9.4-zlib.patch
new file mode 100644
index 000000000000..faa850e214ae
--- /dev/null
+++ b/sci-physics/geant/files/geant-4.9.4-zlib.patch
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2011-01-17 06:25:14.536078940 +0000
++++ CMakeLists.txt 2011-01-17 06:25:26.166078780 +0000
+@@ -154,7 +154,7 @@
+ #------------------------------------------------------------------------------
+ # Optional use of system zlib library
+ #
+-#option(GEANT4_USE_SYSTEM_ZLIB "Use the system's zlib library" OFF)
++option(GEANT4_USE_SYSTEM_ZLIB "Use the system's zlib library" OFF)
+ if(GEANT4_USE_SYSTEM_ZLIB)
+ # This needs more work - use ITK's way of doing it as an example.
+ find_package(ZLIB)
diff --git a/sci-physics/geant/geant-4.9.2_p02.ebuild b/sci-physics/geant/geant-4.9.2_p02.ebuild
index 95b922091a7b..7e40b6bd237f 100644
--- a/sci-physics/geant/geant-4.9.2_p02.ebuild
+++ b/sci-physics/geant/geant-4.9.2_p02.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/geant-4.9.2_p02.ebuild,v 1.9 2010/10/10 21:54:51 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/geant-4.9.2_p02.ebuild,v 1.10 2011/01/22 02:28:43 bicatali Exp $
EAPI=2
diff --git a/sci-physics/geant/geant-4.9.3_p02-r1.ebuild b/sci-physics/geant/geant-4.9.3_p02-r1.ebuild
index c668f33507c2..c9e884933ed5 100644
--- a/sci-physics/geant/geant-4.9.3_p02-r1.ebuild
+++ b/sci-physics/geant/geant-4.9.3_p02-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/geant-4.9.3_p02-r1.ebuild,v 1.1 2010/11/07 21:06:38 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/geant-4.9.3_p02-r1.ebuild,v 1.2 2011/01/22 02:28:43 bicatali Exp $
-EAPI=2
+EAPI=3
inherit eutils versionator toolchain-funcs
@@ -95,15 +95,15 @@ src_prepare() {
}
src_configure() {
- export GEANT4_DIR="/usr/share/${PN}${PV1}"
+ export GEANT4_DIR="${EPREFIX}/usr/share/${PN}${PV1}"
# where to put compiled libraries;
# we set env var G4LIB in src_install()
# to avoid confusing make
- export GEANT4_LIBDIR=/usr/$(get_libdir)/${PN}${PV1}
+ export GEANT4_LIBDIR="${EPREFIX}/usr/$(get_libdir)/${PN}${PV1}"
export G4INSTALL="${S}"
export G4WORKDIR="${S}"
- export G4INCLUDE="${D}/usr/include/${PN}"
- export CLHEP_BASE_DIR=/usr
+ export G4INCLUDE="${ED}/usr/include/${PN}"
+ export CLHEP_BASE_DIR="${EPREFIX}/usr"
# parse USE; just set flags of drivers to build, G4*_USE_* vars are set
# later automatically for G4*_BUILD_*_DRIVER
@@ -114,11 +114,14 @@ src_configure() {
use athena && export G4UI_BUILD_XAW_SESSION=y
if use qt4; then
export G4UI_BUILD_QT_SESSION=y
- export QTLIBS="-L/usr/$(get_libdir)/qt4 -lQtCore -lQtGui"
- export QTFLAGS="-I/usr/include/qt4 -I/usr/include/qt4/Qt"
- use opengl && \
+ export G4UI_USE_QT=1
+ export QTLIBS="-L${EPREFIX}/usr/$(get_libdir)/qt4 -lQtCore -lQtGui"
+ export QTFLAGS="-I${EPREFIX}/usr/include/qt4 -I${EPREFIX}/usr/include/qt4/Qt"
+ if use opengl; then
export GLQTLIBS="${QTLIBS} -lQtOpenGL"
- #export QTFLAGS="${QTFLAGS} -I/usr/include/qt4/QtOpenGL"
+ export G4VIS_USE_OPENGLQT=1
+ export G4VIS_BUILD_OPENGLQT_DRIVER=y
+ fi
fi
use dawn && export G4VIS_BUILD_DAWN_DRIVER=y
use raytracerx && export G4VIS_BUILD_RAYTRACERX_DRIVER=y
@@ -167,8 +170,7 @@ g4_create_env_script() {
# from make during the compile
export G4INSTALL=${GEANT4_DIR}
export G4LIB=${GEANT4_LIBDIR}
- export G4INCLUDE=${G4INCLUDE/${D}/}
- export G4WORKDIR=\${HOME}/${PN}${PV1}
+ export G4INCLUDE=${G4INCLUDE/${ED}/}
local g4env=99${PN}${PV1}
cat <<-EOF > ${g4env}
@@ -188,11 +190,12 @@ g4_create_env_script() {
G4ABLADATA G4NEUTRONHPCROSSSECTIONS G4REALSURFACEDATA
fi
- # read env variables defined upto now
+ # read env variables defined up to now
printenv | grep ^G4 | uniq >> ${g4env}
# define env vars for capabilities we can build into user projects
printenv | uniq | \
sed -n -e '/^G4/s:BUILD\(.*\)_DRIVER:USE\1:gp' >> ${g4env}
+ sed -i -e '/G4WORKDIR/d' ${g4env}
doenvd ${g4env} || die "Installing environment scripts failed "
}
@@ -246,9 +249,7 @@ src_install() {
}
pkg_postinst() {
- elog "Geant4 projects are by default build in \$HOME/geant4."
- elog "If you want to change, set \$G4WORKDIR to another directory."
-
- elog "To use Aida you have to explicitly set G4ANALYSIS_USE=y for"
+ elog "Users need to define the G4WORKDIR (\$HOME/geant4 is normally used)."
+ elog "To use AIDA you have to explicitly set G4ANALYSIS_USE=y in"
elog "your environment."
}
diff --git a/sci-physics/geant/geant-4.9.4.ebuild b/sci-physics/geant/geant-4.9.4.ebuild
new file mode 100644
index 000000000000..e42d2cff05a8
--- /dev/null
+++ b/sci-physics/geant/geant-4.9.4.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/geant-4.9.4.ebuild,v 1.1 2011/01/22 02:28:43 bicatali Exp $
+
+EAPI=3
+
+inherit cmake-utils versionator eutils
+
+PV1=$(get_version_component_range 1 ${PV})
+PV2=$(get_version_component_range 2 ${PV})
+PV3=$(get_version_component_range 3 ${PV})
+
+MYP=${PN}$(replace_version_separator 3 .)
+
+DESCRIPTION="Toolkit for simulation of passage of particles through matter"
+HOMEPAGE="http://geant4.cern.ch/"
+
+SRC_COM="http://geant4.cern.ch/support/source"
+SRC_URI="${SRC_COM}/${MYP}.tar.gz"
+GEANT4_DATA="G4NDL.3.14
+ G4EMLOW.6.19
+ G4RadioactiveDecay.3.3
+ G4NEUTRONXS.1.0
+ G4PII.1.2
+ G4PhotonEvaporation.2.1
+ G4ABLA.3.0
+ RealSurface.1.0"
+for d in ${GEANT4_DATA}; do
+ SRC_URI="${SRC_URI} data? ( ${SRC_COM}/${d}.tar.gz )"
+done
+
+LICENSE="geant4"
+SLOT="4"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86"
+IUSE="+data dawn examples gdml geant3 granular qt4 static-libs vrml zlib"
+
+RDEPEND=">=sci-physics/clhep-2.1
+ qt4? ( x11-libs/qt-gui:4 x11-libs/qt-opengl:4 )
+ gdml? ( dev-libs/xerces-c )
+ geant3? ( sci-physics/geant:3 )
+ dawn? ( media-gfx/dawn )
+ zlib? ( sys-libs/zlib )"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MYP}"
+
+PATCHES=( "${FILESDIR}"/${P}-{no-benchmarks,zlib,libdir,datadir,no-examples}.patch )
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_enable dawn GEANT4_USE_NETWORKDAWN)
+ $(cmake-utils_use_enable gdml GEANT4_USE_GDML)
+ $(cmake-utils_use_enable geant3 GEANT4_USE_GEANT3TOGEANT4)
+ $(cmake-utils_use_enable granular GEANT4_BUILD_GRANULAR_BUILD)
+ $(cmake-utils_use_enable dawn GEANT4_USE_NETWORKVRML)
+ $(cmake-utils_use_enable qt4 GEANT4_USE_QT)
+ $(cmake-utils_use_enable zlib GEANT4_USE_SYSTEM_ZLIB)
+ $(cmake-utils_use_build static-libs STATIC_LIBS)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use data; then
+ einfo "Installing Geant4 data"
+ insinto /usr/share/geant4/data
+ pushd "${WORKDIR}" > /dev/null
+ for d in ${GEANT4_DATA}; do
+ local p=${d/.}
+ doins -r *${p/G4} || die "installing data ${d} failed"
+ done
+ popd > /dev/null
+ fi
+
+ insinto /usr/share/doc/${PF}
+ local mypv="${PV1}.${PV2}.${PV3}"
+ doins ReleaseNotes/ReleaseNotes${mypv}.html
+ [[ -e ReleaseNotes/Patch${mypv}-1.txt ]] && \
+ dodoc ReleaseNotes/Patch${mypv}-*.txt
+ use examples && doins -r examples
+}
+
+pkg_postinst() {
+ elog "Users need to define the G4WORKDIR (\$HOME/geant4 is normally used)."
+}
diff --git a/sci-physics/geant/metadata.xml b/sci-physics/geant/metadata.xml
index e546f4c90854..bd76f546c4b1 100644
--- a/sci-physics/geant/metadata.xml
+++ b/sci-physics/geant/metadata.xml
@@ -21,6 +21,7 @@
<flag name='geant3'>Add compatibility for geant321 to geant4</flag>
<flag name='global'>Produce a huge global library instead of small
ones</flag>
+ <flag name='granular'>Produce many small libraries instead of global ones</flag>
<flag name='aida'>Add support for Abstract Interfaces for Data Analysis </flag>
<flag name='openinventor'>Add support for <pkg>media-libs/openinventor</pkg>
SGI toolkit</flag>