summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-11-07 14:12:52 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-11-07 14:12:52 +0000
commitd79f03f58d7cc7c3f27022dc0c72e910ecdd675e (patch)
tree37f328c8eb7b07a7223e4a787a8479a8bd4bbe7b /sci-physics/mpb
parentStable on sparc wrt #154055 (diff)
downloadgentoo-2-d79f03f58d7cc7c3f27022dc0c72e910ecdd675e.tar.gz
gentoo-2-d79f03f58d7cc7c3f27022dc0c72e910ecdd675e.tar.bz2
gentoo-2-d79f03f58d7cc7c3f27022dc0c72e910ecdd675e.zip
Fixed compile problems with gcc4 and added dependency on guile.
(Portage version: 2.1.2_rc1-r3)
Diffstat (limited to 'sci-physics/mpb')
-rw-r--r--sci-physics/mpb/ChangeLog6
-rw-r--r--sci-physics/mpb/files/mpb-1.4.2-gcc4.patch21
-rw-r--r--sci-physics/mpb/mpb-1.4.2.ebuild10
3 files changed, 33 insertions, 4 deletions
diff --git a/sci-physics/mpb/ChangeLog b/sci-physics/mpb/ChangeLog
index a137024b4cad..49dd071a076a 100644
--- a/sci-physics/mpb/ChangeLog
+++ b/sci-physics/mpb/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-physics/mpb
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/mpb/ChangeLog,v 1.4 2006/11/07 13:27:40 pbienst Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/mpb/ChangeLog,v 1.5 2006/11/07 14:12:52 markusle Exp $
+
+ 07 Nov 2006; Markus Dittrich <markusle@gentoo.org>
+ +files/mpb-1.4.2-gcc4.patch, mpb-1.4.2.ebuild:
+ Fixed compile problems with gcc4 and added dependency on guile.
07 Nov 2006; <pbienst@gentoo.org> mpb-1.4.2.ebuild:
Fix dependencies.
diff --git a/sci-physics/mpb/files/mpb-1.4.2-gcc4.patch b/sci-physics/mpb/files/mpb-1.4.2-gcc4.patch
new file mode 100644
index 000000000000..62536ac202db
--- /dev/null
+++ b/sci-physics/mpb/files/mpb-1.4.2-gcc4.patch
@@ -0,0 +1,21 @@
+diff -Naur mpb-1.4.2/configure mpb-1.4.2-new/configure
+--- mpb-1.4.2/configure 2003-03-03 21:39:25.000000000 -0500
++++ mpb-1.4.2-new/configure 2006-11-07 08:19:13.000000000 -0500
+@@ -1343,7 +1343,7 @@
+ ac_link='$F77 -o conftest$ac_exeext $FFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
+ ac_compiler_gnu=$ac_cv_f77_compiler_gnu
+ if test -n "$ac_tool_prefix"; then
+- for ac_prog in g77 f77 xlf frt pgf77 fl32 af77 fort77 f90 xlf90 pgf90 epcf90 f95 fort xlf95 lf95 g95
++ for ac_prog in g77 f77 xlf frt pgf77 fl32 af77 fort77 f90 xlf90 pgf90 epcf90 f95 fort xlf95 lf95 g95 gfortran
+ do
+ # Extract the first word of "$ac_tool_prefix$ac_prog", so it can be a program name with args.
+ set dummy $ac_tool_prefix$ac_prog; ac_word=$2
+@@ -1385,7 +1385,7 @@
+ fi
+ if test -z "$F77"; then
+ ac_ct_F77=$F77
+- for ac_prog in g77 f77 xlf frt pgf77 fl32 af77 fort77 f90 xlf90 pgf90 epcf90 f95 fort xlf95 lf95 g95
++ for ac_prog in g77 f77 xlf frt pgf77 fl32 af77 fort77 f90 xlf90 pgf90 epcf90 f95 fort xlf95 lf95 g95 gfortran
+ do
+ # Extract the first word of "$ac_prog", so it can be a program name with args.
+ set dummy $ac_prog; ac_word=$2
diff --git a/sci-physics/mpb/mpb-1.4.2.ebuild b/sci-physics/mpb/mpb-1.4.2.ebuild
index 2dcb2301e126..9bfcbe80fe0f 100644
--- a/sci-physics/mpb/mpb-1.4.2.ebuild
+++ b/sci-physics/mpb/mpb-1.4.2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/mpb/mpb-1.4.2.ebuild,v 1.2 2006/11/07 13:27:40 pbienst Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/mpb/mpb-1.4.2.ebuild,v 1.3 2006/11/07 14:12:52 markusle Exp $
+
+inherit fortran
DESCRIPTION="Program for computing the band structures and electromagnetic modes of periodic dielectric structures"
SRC_URI="http://ab-initio.mit.edu/mpb/${P}.tar.gz"
@@ -12,6 +14,7 @@ KEYWORDS="~x86"
SLOT="0"
DEPEND="virtual/lapack
+ dev-util/guile
sci-libs/libctl
sci-libs/hdf5
~sci-libs/fftw-2.1.5
@@ -21,8 +24,9 @@ RDEPEND="~sci-libs/fftw-2.1.5"
src_unpack() {
unpack ${A}
- # Create directories to compile the versions with inversion symmetry
- # and with hermitian eps.
+ epatch "${FILESDIR}"/${P}-gcc4.patch
+ # Create directories to compile the versions with inversion
+ # symmetry and with hermitian eps.
cp -r ${S} ${S}_inv
cp -r ${S} ${S}_herm