summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Bienstman <pbienst@gentoo.org>2007-03-23 14:22:46 +0000
committerPeter Bienstman <pbienst@gentoo.org>2007-03-23 14:22:46 +0000
commit0b189853701c058c6f4e719b43a84a271f5e8998 (patch)
tree802b9bc1a2c68d426e2543cffceb4a674e803873 /sci-physics/camfr
parentFix aliasing QA, #171415. (diff)
downloadgentoo-2-0b189853701c058c6f4e719b43a84a271f5e8998.tar.gz
gentoo-2-0b189853701c058c6f4e719b43a84a271f5e8998.tar.bz2
gentoo-2-0b189853701c058c6f4e719b43a84a271f5e8998.zip
Fix boost patch.
(Portage version: 2.1.2.2)
Diffstat (limited to 'sci-physics/camfr')
-rw-r--r--sci-physics/camfr/ChangeLog5
-rw-r--r--sci-physics/camfr/camfr-1.2.ebuild4
-rw-r--r--sci-physics/camfr/files/machine_cfg.py4
3 files changed, 8 insertions, 5 deletions
diff --git a/sci-physics/camfr/ChangeLog b/sci-physics/camfr/ChangeLog
index 55a300b0a2c5..67c5d321eb52 100644
--- a/sci-physics/camfr/ChangeLog
+++ b/sci-physics/camfr/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-physics/camfr
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/camfr/ChangeLog,v 1.4 2007/01/02 15:14:45 pbienst Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/camfr/ChangeLog,v 1.5 2007/03/23 14:22:46 pbienst Exp $
+
+ 23 Mar 2007; <pbienst@gentoo.org> ChangeLog:
+ Fix boost patch.
02 Jan 2007; <pbienst@gentoo.org> camfr-1.2.ebuild:
Remove unused use flag.
diff --git a/sci-physics/camfr/camfr-1.2.ebuild b/sci-physics/camfr/camfr-1.2.ebuild
index 4292839ef19a..27a42e01139e 100644
--- a/sci-physics/camfr/camfr-1.2.ebuild
+++ b/sci-physics/camfr/camfr-1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/camfr/camfr-1.2.ebuild,v 1.2 2007/01/02 15:14:45 pbienst Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/camfr/camfr-1.2.ebuild,v 1.3 2007/03/23 14:22:46 pbienst Exp $
inherit eutils distutils fortran
@@ -34,7 +34,7 @@ src_unpack() {
unpack ${P}.tgz
cp ${FILESDIR}/machine_cfg.py ${S}/machine_cfg.py
cp ${FILESDIR}/SConstruct ${S}
- cp ${FILESDIR}/camfr_wrap.cpp ${S}/camfr
+ epatch ${FILESDIR}/throw_patch.diff
echo '1;' >> ${S}/docs/texi2html.init
}
diff --git a/sci-physics/camfr/files/machine_cfg.py b/sci-physics/camfr/files/machine_cfg.py
index 698f9e8eaed2..2d62abfb0eee 100644
--- a/sci-physics/camfr/files/machine_cfg.py
+++ b/sci-physics/camfr/files/machine_cfg.py
@@ -14,7 +14,7 @@ w.close()
cc = "gcc"
cxx = "g++"
-f77 = "g77"
+f77 = "gfortran -fPIC"
link = cxx
link_flags = ""
@@ -45,7 +45,7 @@ library_dirs = [""]
# Library names.
-libs = ["boost_python", "blitz", "lapack", "blas", "g2c"]
+libs = ["boost_python", "blitz", "lapack", "blas", "gfortran"]
# Command to strip library of excess symbols: