summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Bienstman <pbienst@gentoo.org>2005-10-31 08:26:30 +0000
committerPeter Bienstman <pbienst@gentoo.org>2005-10-31 08:26:30 +0000
commite8a03a842a4e1680fad86d2227606859cd92a31e (patch)
tree52df2d090566ebd336fa9eb011abec68b0dca155 /sci-misc
parentold (diff)
downloadgentoo-2-e8a03a842a4e1680fad86d2227606859cd92a31e.tar.gz
gentoo-2-e8a03a842a4e1680fad86d2227606859cd92a31e.tar.bz2
gentoo-2-e8a03a842a4e1680fad86d2227606859cd92a31e.zip
Use fortran eclass.
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/camfr/ChangeLog5
-rw-r--r--sci-misc/camfr/camfr-1.2.ebuild12
2 files changed, 7 insertions, 10 deletions
diff --git a/sci-misc/camfr/ChangeLog b/sci-misc/camfr/ChangeLog
index 7bdb61514141..4653b9d0f776 100644
--- a/sci-misc/camfr/ChangeLog
+++ b/sci-misc/camfr/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-misc/camfr
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/camfr/ChangeLog,v 1.1 2005/04/05 07:52:12 pbienst Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/camfr/ChangeLog,v 1.2 2005/10/31 08:26:30 pbienst Exp $
+
+ 31 Oct 2005; Peter Bienstman <pbienst@gentoo.org> camfr-1.2.ebuild:
+ Use fortran eclass.
05 Apr 2005; Peter Bienstman <pbienst@gentoo.org> :
Initial import. Closes bug 36560.
diff --git a/sci-misc/camfr/camfr-1.2.ebuild b/sci-misc/camfr/camfr-1.2.ebuild
index 51ede579e9fc..82adbff59939 100644
--- a/sci-misc/camfr/camfr-1.2.ebuild
+++ b/sci-misc/camfr/camfr-1.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/camfr/camfr-1.2.ebuild,v 1.1 2005/04/05 07:52:12 pbienst Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/camfr/camfr-1.2.ebuild,v 1.2 2005/10/31 08:26:30 pbienst Exp $
-inherit eutils distutils
+inherit eutils distutils fortran
S=${WORKDIR}/camfr_${PV}
IUSE="ifc"
@@ -22,15 +22,9 @@ DEPEND="dev-lang/python
virtual/tetex
app-text/ghostscript
>=app-text/texi2html-1.64"
+FORTAN="g77"
src_unpack() {
- use ifc || if [ -z `which g77` ]; then
- #if ifc is defined then the dep was already checked
- eerror "No fortran compiler found on the system!"
- eerror "Please add fortran to your USE flags and reemerge gcc!"
- die
- fi
-
python -c "import ImageTk" 2>/dev/null
if [ $? -ne 0 ]; then
eerror "Python and imaging don't have Tk support enabled."