summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-05-22 09:22:59 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-05-22 09:22:59 +0000
commitda42f3c998c02dbd79813f5c6a8efc75c249d059 (patch)
tree24434533de385abc2a765281d060d61ad0325530 /sci-misc
parentAdd perl-5.14.0 as provider. Change version scheme. Force stable keywords (diff)
downloadgentoo-2-da42f3c998c02dbd79813f5c6a8efc75c249d059.tar.gz
gentoo-2-da42f3c998c02dbd79813f5c6a8efc75c249d059.tar.bz2
gentoo-2-da42f3c998c02dbd79813f5c6a8efc75c249d059.zip
Version bump to boinc 6.12.26. Drop older. Update tarballs to be lzma compressed.
(Portage version: 2.2.0_alpha34/cvs/Linux x86_64)
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/boinc/ChangeLog10
-rw-r--r--sci-misc/boinc/boinc-6.12.26.ebuild (renamed from sci-misc/boinc/boinc-6.10.58-r1.ebuild)34
-rw-r--r--sci-misc/boinc/files/6.12.26-fix_subdirs.patch26
-rw-r--r--sci-misc/boinc/files/6.12.26-libnotify-0.7.patch21
-rw-r--r--sci-misc/boinc/files/generate_tarball.sh6
5 files changed, 80 insertions, 17 deletions
diff --git a/sci-misc/boinc/ChangeLog b/sci-misc/boinc/ChangeLog
index 9618f743fb4d..00374e5fa6a5 100644
--- a/sci-misc/boinc/ChangeLog
+++ b/sci-misc/boinc/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-misc/boinc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.95 2011/05/21 19:34:02 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.96 2011/05/22 09:22:59 scarabeus Exp $
+
+*boinc-6.12.26 (22 May 2011)
+
+ 22 May 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ +files/6.12.26-fix_subdirs.patch, +files/6.12.26-libnotify-0.7.patch,
+ -boinc-6.10.58-r1.ebuild, +boinc-6.12.26.ebuild, files/generate_tarball.sh:
+ Version bump to boinc 6.12.26. Drop older. Update tarballs to be lzma
+ compressed.
21 May 2011; Tomáš Chvátal <scarabeus@gentoo.org> files/boinc.conf,
files/boinc.init:
diff --git a/sci-misc/boinc/boinc-6.10.58-r1.ebuild b/sci-misc/boinc/boinc-6.12.26.ebuild
index 0f5bd631f25f..b1da70fd3037 100644
--- a/sci-misc/boinc/boinc-6.10.58-r1.ebuild
+++ b/sci-misc/boinc/boinc-6.12.26.ebuild
@@ -1,19 +1,19 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-6.10.58-r1.ebuild,v 1.3 2010/11/08 17:52:35 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-6.12.26.ebuild,v 1.1 2011/05/22 09:22:59 scarabeus Exp $
-EAPI="2"
+EAPI=4
inherit flag-o-matic depend.apache eutils wxwidgets autotools autotools-utils
DESCRIPTION="The Berkeley Open Infrastructure for Network Computing"
HOMEPAGE="http://boinc.ssl.berkeley.edu/"
-SRC_URI="http://dev.gentooexperimental.org/~scarabeus/${P}.tar.bz2"
+SRC_URI="http://dev.gentooexperimental.org/~scarabeus/${P}.tar.xz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="X +client cuda"
+IUSE="X cuda"
RDEPEND="
!sci-misc/boinc-bin
@@ -30,14 +30,24 @@ RDEPEND="
X? (
dev-db/sqlite:3
media-libs/freeglut
+ sys-libs/glibc:2.2
virtual/jpeg
+ x11-libs/gtk+:2
+ x11-libs/libnotify
x11-libs/wxGTK:2.8[X,opengl]
)
"
DEPEND="${RDEPEND}
sys-devel/gettext
+ app-text/docbook-xml-dtd:4.4
+ app-text/docbook2X
"
+PATCHES=(
+ "${FILESDIR}/${PV}-fix_subdirs.patch"
+ "${FILESDIR}/${PV}-libnotify-0.7.patch"
+)
+
AUTOTOOLS_IN_SOURCE_BUILD=1
src_prepare() {
@@ -55,10 +65,11 @@ src_prepare() {
src_configure() {
local wxconf=""
- local conf=""
# define preferable CFLAGS (recommended by upstream)
append-flags -O3 -funroll-loops -fforce-addr -ffast-math
+ # add gtk includes
+ append-flags "$(pkg-config --cflags gtk+-2.0)"
# look for wxGTK
if use X; then
@@ -69,19 +80,16 @@ src_configure() {
wxconf+=" --without-wxdir"
fi
- conf+=" --disable-server"
- use X || conf+=" --disable-manager"
- use client || conf+=" --disable-client"
-
- # configure
myeconfargs=(
- --disable-dependency-tracking
+ --disable-server
+ --enable-client
+ --enable-dynamic-client-linkage
--disable-static
--enable-unicode
--with-ssl
$(use_with X x)
+ $(use_enable X manager)
${wxconf}
- ${conf}
)
autotools-utils_src_configure
}
diff --git a/sci-misc/boinc/files/6.12.26-fix_subdirs.patch b/sci-misc/boinc/files/6.12.26-fix_subdirs.patch
new file mode 100644
index 000000000000..a0ea5ab0cc60
--- /dev/null
+++ b/sci-misc/boinc/files/6.12.26-fix_subdirs.patch
@@ -0,0 +1,26 @@
+diff -urN boinc-6.12.26.old//configure.ac boinc-6.12.26//configure.ac
+--- boinc-6.12.26.old//configure.ac 2011-05-22 09:40:36.392051762 +0200
++++ boinc-6.12.26//configure.ac 2011-05-22 11:03:28.687889510 +0200
+@@ -887,7 +887,6 @@
+ apps/Makefile
+ clientgui/Makefile
+ clientgui/res/Makefile
+- clientscr/Makefile
+ client/Makefile
+ client/win/boinc_path_config.py:py/boinc_path_config.py.in
+ client/scripts/Makefile
+diff -urN boinc-6.12.26.old//Makefile.am boinc-6.12.26//Makefile.am
+--- boinc-6.12.26.old//Makefile.am 2011-05-22 09:40:36.376051962 +0200
++++ boinc-6.12.26//Makefile.am 2011-05-22 11:03:16.277044666 +0200
+@@ -21,10 +21,7 @@
+ endif
+
+ if ENABLE_MANAGER
+- CLIENTGUI_SUBDIRS = clientgui clientgui/res locale
+- if BUILD_X11_SCREENSAVER
+- CLIENTGUI_SUBDIRS += clientscr
+- endif
++ CLIENTGUI_SUBDIRS = clientgui clientgui/res locale
+ endif
+
+ # ORDER MATTERS below. One must build dependencies FIRST, then things
diff --git a/sci-misc/boinc/files/6.12.26-libnotify-0.7.patch b/sci-misc/boinc/files/6.12.26-libnotify-0.7.patch
new file mode 100644
index 000000000000..da6e729fc6fc
--- /dev/null
+++ b/sci-misc/boinc/files/6.12.26-libnotify-0.7.patch
@@ -0,0 +1,21 @@
+diff -urN boinc-6.12.26.old/clientgui/gtk/taskbarex.cpp boinc-6.12.26/clientgui/gtk/taskbarex.cpp
+--- boinc-6.12.26.old/clientgui/gtk/taskbarex.cpp 2011-05-22 09:40:36.314052737 +0200
++++ boinc-6.12.26/clientgui/gtk/taskbarex.cpp 2011-05-22 11:20:06.838410909 +0200
+@@ -226,12 +226,11 @@
+
+ if (!g_pNotification)
+ {
+- g_pNotification =
+- notify_notification_new_with_status_icon(
+- title.mb_str(),
+- message.mb_str(),
+- desired_icon,
+- g_pStatusIcon
++ g_pNotification =
++ notify_notification_new(
++ title.mb_str(),
++ message.mb_str(),
++ gtk_status_icon_get_icon_name(g_pStatusIcon)
+ );
+
+ g_signal_connect(
diff --git a/sci-misc/boinc/files/generate_tarball.sh b/sci-misc/boinc/files/generate_tarball.sh
index a6cc4d8868ab..6a15be5a937b 100644
--- a/sci-misc/boinc/files/generate_tarball.sh
+++ b/sci-misc/boinc/files/generate_tarball.sh
@@ -1,5 +1,5 @@
#!/usr/bin/env bash
-## $Id: generate_tarball.sh,v 1.1 2010/04/02 09:48:24 scarabeus Exp $
+## $Id: generate_tarball.sh,v 1.2 2011/05/22 09:22:59 scarabeus Exp $
## Modified by scarabeus 2008-10-23
###############################################################################
# functions
@@ -83,8 +83,8 @@ popd > /dev/null
###############################################################################
# create tbz
###############################################################################
-tar cjf "${PACKAGE}".tar.bz2 ${PACKAGE} >> "${LOG}"
-find ./ -maxdepth 1 -type f -name \*.tar.bz2 -print | while read FILE ; do
+tar cJf "${PACKAGE}".tar.xz ${PACKAGE} >> "${LOG}"
+find ./ -maxdepth 1 -type f -name \*.tar.xz -print | while read FILE ; do
echo "FILE: ${FILE}"
echo " SIZE: $(`which du` -h ${FILE} |`which awk` -F' ' '{print $1}')"
echo " MD5SUM: $(`which md5sum` ${FILE} |`which awk` -F' ' '{print $1}')"