summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2007-05-06 12:25:45 +0000
committerMarkus Dittrich <markusle@gentoo.org>2007-05-06 12:25:45 +0000
commitc7932f1a3c64849aa1a219b2c02d5ad89bcb4010 (patch)
treea38fbb6e44b7e472bb662715abab4fdf29fd4bcd /sci-mathematics
parentReplacing einfo with elog (diff)
downloadgentoo-2-c7932f1a3c64849aa1a219b2c02d5ad89bcb4010.tar.gz
gentoo-2-c7932f1a3c64849aa1a219b2c02d5ad89bcb4010.tar.bz2
gentoo-2-c7932f1a3c64849aa1a219b2c02d5ad89bcb4010.zip
Version bump.
(Portage version: 2.1.2.5)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/pari/ChangeLog7
-rw-r--r--sci-mathematics/pari/files/digest-pari-2.3.23
-rw-r--r--sci-mathematics/pari/pari-2.3.2.ebuild98
3 files changed, 107 insertions, 1 deletions
diff --git a/sci-mathematics/pari/ChangeLog b/sci-mathematics/pari/ChangeLog
index 0f705dfdcb08..6c58cb24d026 100644
--- a/sci-mathematics/pari/ChangeLog
+++ b/sci-mathematics/pari/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/pari
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/ChangeLog,v 1.41 2007/02/22 01:33:38 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/ChangeLog,v 1.42 2007/05/06 12:25:45 markusle Exp $
+
+*pari-2.3.2 (06 May 2007)
+
+ 06 May 2007; Markus Dittrich <markusle@gentoo.org> +pari-2.3.2.ebuild:
+ Version bump.
22 Feb 2007; Markus Ullmann <jokey@gentoo.org> ChangeLog:
Redigest for Manifest2
diff --git a/sci-mathematics/pari/files/digest-pari-2.3.2 b/sci-mathematics/pari/files/digest-pari-2.3.2
new file mode 100644
index 000000000000..9b6b3b422cbc
--- /dev/null
+++ b/sci-mathematics/pari/files/digest-pari-2.3.2
@@ -0,0 +1,3 @@
+MD5 54f8b7cb615db6d216f1a31a575c8223 pari-2.3.2.tar.gz 2015734
+RMD160 d2394fd31bfa6efcbfce25081d75234ccb1005be pari-2.3.2.tar.gz 2015734
+SHA256 514799c0722376ba7d163588f091662731bca0a4b3cd2a93d01eb6bec9d1f47a pari-2.3.2.tar.gz 2015734
diff --git a/sci-mathematics/pari/pari-2.3.2.ebuild b/sci-mathematics/pari/pari-2.3.2.ebuild
new file mode 100644
index 000000000000..7dbe79b5079c
--- /dev/null
+++ b/sci-mathematics/pari/pari-2.3.2.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.3.2.ebuild,v 1.1 2007/05/06 12:25:45 markusle Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="pari (or pari-gp) : a software package for computer-aided number theory"
+HOMEPAGE="http://pari.math.u-bordeaux.fr/"
+SRC_URI="http://pari.math.u-bordeaux.fr/pub/pari/unix/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="doc emacs X"
+
+DEPEND="doc? ( virtual/tetex )
+ sys-libs/readline
+ X? ( || ( x11-libs/libX11 virtual/x11 ) )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # disable default building of docs during install
+ sed -e "s:install-doc install-examples:install-examples:" \
+ -i config/Makefile.SH || die "Failed to fix makefile"
+}
+
+src_compile() {
+ # Special handling for sparc
+ local myhost
+ [ "${PROFILE_ARCH}" == "sparc64" ] && myhost="sparc64-linux" \
+ || myhost="$(echo ${CHOST} | cut -f "1 3" -d '-')"
+ einfo "Building for ${myhost}"
+
+ #need to force optimization here, as it breaks without
+ if is-flag -O0; then
+ replace-flags -O0 -O2
+ elif ! is-flag -O?; then
+ append-flags -O2
+ fi
+
+ ./Configure \
+ --host=${myhost} \
+ --prefix=/usr \
+ --datadir=/usr/share/${P} \
+ --libdir=/usr/$(get_libdir) \
+ --mandir=/usr/share/man/man1 || die "./configure failed"
+
+ if use hppa
+ then
+ mymake=DLLD\=/usr/bin/gcc\ DLLDFLAGS\=-shared\ -Wl,-soname=\$\(LIBPARI_SONAME\)\ -lm
+ fi
+
+ # Shared libraries should be PIC on ALL architectures.
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/31
+ # Fixes BUG #49583
+ einfo "Building shared library..."
+ cd Olinux-* || die "Bad directory. File a BUG!"
+ emake ${mymake} CFLAGS="${CFLAGS} -DGCC_INLINE -fPIC" lib-dyn || die "Building shared library failed!"
+
+ einfo "Building executables..."
+ emake ${mymake} CFLAGS="${CFLAGS} -DGCC_INLINE" gp ../gp || die "Building executables failed!"
+
+ if use doc; then
+ cd "${S}"
+ emake docpdf || die "Failed to generate docs"
+ fi
+}
+
+src_test() {
+ cd "${S}"
+ ebegin "Testing pari kernel"
+ make test-kernel > /dev/null
+ eend $?
+}
+
+src_install() {
+ make DESTDIR=${D} LIBDIR=${D}/usr/$(get_libdir) install || \
+ die "Install failed"
+
+ if use emacs; then
+ insinto /usr/share/emacs/site-lisp
+ doins emacs/pari.el
+ fi
+
+ dodoc AUTHORS Announce.2.1 CHANGES README TODO NEW
+ if use doc; then
+ make DESTDIR=${D} LIBDIR=${D}/usr/$(get_libdir) install-doc \
+ || die "Failed to install docs"
+ insinto /usr/share/doc/${PF}
+ doins doc/*.pdf || die "Failed to install pdf docs"
+ fi
+
+ #remove superfluous doc directory
+ rm -fr ${D}/usr/share/${P}/doc || \
+ die "Failed to clean up doc directory"
+}