summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-07-26 17:42:36 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-07-26 17:42:36 +0000
commit4d0c6bfc4bf68458c7d789ffafd68e64e6105ff5 (patch)
treeed95bd41df36fa3ff7953ade9809d428663ffa61 /sci-mathematics
parentAdd EAPI 3 prefix compatibility. (diff)
downloadgentoo-2-4d0c6bfc4bf68458c7d789ffafd68e64e6105ff5.tar.gz
gentoo-2-4d0c6bfc4bf68458c7d789ffafd68e64e6105ff5.tar.bz2
gentoo-2-4d0c6bfc4bf68458c7d789ffafd68e64e6105ff5.zip
Version bump
(Portage version: 2.1.10.7/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/ginac/ChangeLog7
-rw-r--r--sci-mathematics/ginac/ginac-1.6.1.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/sci-mathematics/ginac/ChangeLog b/sci-mathematics/ginac/ChangeLog
index bc22e8aedf02..6a7826662911 100644
--- a/sci-mathematics/ginac/ChangeLog
+++ b/sci-mathematics/ginac/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/ginac
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/ginac/ChangeLog,v 1.52 2011/06/28 20:13:55 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/ginac/ChangeLog,v 1.53 2011/07/26 17:42:36 bicatali Exp $
+
+*ginac-1.6.1 (26 Jul 2011)
+
+ 26 Jul 2011; Sébastien Fabbro <bicatali@gentoo.org> +ginac-1.6.1.ebuild:
+ Version bump
28 Jun 2011; Brent Baude <ranger@gentoo.org> ginac-1.5.8.ebuild:
Marking ginac-1.5.8 ppc for bug 360605
diff --git a/sci-mathematics/ginac/ginac-1.6.1.ebuild b/sci-mathematics/ginac/ginac-1.6.1.ebuild
new file mode 100644
index 000000000000..8dc514dc1d3c
--- /dev/null
+++ b/sci-mathematics/ginac/ginac-1.6.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/ginac/ginac-1.6.1.ebuild,v 1.1 2011/07/26 17:42:36 bicatali Exp $
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="C++ library and tools for symbolic calculations"
+SRC_URI="ftp://ftpthep.physik.uni-mainz.de/pub/GiNaC/${P}.tar.bz2"
+HOMEPAGE="http://www.ginac.de/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc static-libs"
+
+RDEPEND=">=sci-libs/cln-1.2.2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen
+ media-gfx/transfig
+ virtual/texi2dvi
+ || ( dev-texlive/texlive-fontsrecommended
+ app-text/ptex ) )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.5.1-pkgconfig.patch
+}
+
+src_configure() {
+ econf \
+ --disable-rpath \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake
+ if use doc; then
+ export VARTEXFONTS="${T}"/fonts
+ cd "${S}/doc/reference"
+ #pdf generation for reference failed (1.5.1), bug #264774
+ #emake html pdf || die "emake doc reference failed"
+ emake html
+ cd "${S}/doc/tutorial"
+ emake ginac.pdf ginac.html
+ fi
+}
+
+src_install() {
+ default
+ if use doc; then
+ cd doc
+ insinto /usr/share/doc/${PF}
+ newins tutorial/ginac.pdf tutorial.pdf
+ insinto /usr/share/doc/${PF}/html/reference
+ doins -r reference/html_files/*
+ insinto /usr/share/doc/${PF}/html
+ newins tutorial/ginac.html tutorial.html
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.cpp examples/ginac-examples.txt
+ fi
+}