summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-12-10 22:29:26 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-12-10 22:29:26 +0000
commit0a16e99d5f7d9f4553c1a692cb09c0082f290159 (patch)
tree84902808dc699b8bab384bfb7e020e05d54d6023 /sci-mathematics
parentFix LICENSE, see header in MersenneTwister.java, bug 444864. (diff)
downloadgentoo-2-0a16e99d5f7d9f4553c1a692cb09c0082f290159.tar.gz
gentoo-2-0a16e99d5f7d9f4553c1a692cb09c0082f290159.tar.bz2
gentoo-2-0a16e99d5f7d9f4553c1a692cb09c0082f290159.zip
Keyword amd64-linux and x86-linux, cleaning
(Portage version: 2.2.01.21418-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/pspp/ChangeLog7
-rw-r--r--sci-mathematics/pspp/pspp-0.6.2-r1.ebuild26
-rw-r--r--sci-mathematics/pspp/pspp-0.6.2.ebuild88
3 files changed, 19 insertions, 102 deletions
diff --git a/sci-mathematics/pspp/ChangeLog b/sci-mathematics/pspp/ChangeLog
index 40fb9fc82d48..997dbf425698 100644
--- a/sci-mathematics/pspp/ChangeLog
+++ b/sci-mathematics/pspp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/pspp
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pspp/ChangeLog,v 1.20 2012/05/21 06:56:21 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pspp/ChangeLog,v 1.21 2012/12/10 22:29:26 bicatali Exp $
+
+ 10 Dec 2012; Sébastien Fabbro <bicatali@gentoo.org> -pspp-0.6.2.ebuild,
+ pspp-0.6.2-r1.ebuild:
+ Keyword amd64-linux and x86-linux, cleaning
21 May 2012; Samuli Suominen <ssuominen@gentoo.org> pspp-0.6.2-r1.ebuild:
Remove unnecessary gnome-extra/yelp from runtime dependencies;
@@ -97,4 +101,3 @@
+pspp-0.4.0.ebuild:
Initial import of pspp. Thanks to Torsten Kurbad <torsten@tk-webart.de>
for his work. Closes bug #79943.
-
diff --git a/sci-mathematics/pspp/pspp-0.6.2-r1.ebuild b/sci-mathematics/pspp/pspp-0.6.2-r1.ebuild
index ec5d8195fbfc..22c3b97f218d 100644
--- a/sci-mathematics/pspp/pspp-0.6.2-r1.ebuild
+++ b/sci-mathematics/pspp/pspp-0.6.2-r1.ebuild
@@ -1,24 +1,25 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pspp/pspp-0.6.2-r1.ebuild,v 1.5 2012/05/21 06:56:21 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pspp/pspp-0.6.2-r1.ebuild,v 1.6 2012/12/10 22:29:26 bicatali Exp $
EAPI=4
-inherit eutils elisp-common autotools
+inherit eutils elisp-common autotools multilib
DESCRIPTION="Program for statistical analysis of sampled data."
HOMEPAGE="http://www.gnu.org/software/pspp/pspp.html"
SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
SLOT="0"
LICENSE="GPL-3"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc emacs gtk ncurses nls plotutils postgres static-libs"
-RDEPEND="sci-libs/gsl
+RDEPEND="
+ dev-libs/libxml2:2
+ sci-libs/gsl
sys-libs/readline
sys-devel/gettext
- virtual/libiconv
sys-libs/zlib
- dev-libs/libxml2:2
+ virtual/libiconv
emacs? ( virtual/emacs )
gtk? ( x11-libs/gtk+:2 gnome-base/libglade:2.0 )
ncurses? ( sys-libs/ncurses )
@@ -55,19 +56,20 @@ src_configure() {
src_compile() {
emake pkglibdir="${EPREFIX}/usr/$(get_libdir)"
- use doc && emake html && emake pdf
+ use doc && emake html pdf
use emacs && elisp-compile *.el
}
src_install() {
emake pkglibdir="${EPREFIX}/usr/$(get_libdir)" DESTDIR="${D}" install
dodoc AUTHORS ChangeLog NEWS ONEWS README THANKS TODO
- insinto /usr/share/doc/${PF}
- doins -r examples
- if use doc; then
- doins -r doc/pspp.html doc/pspp-dev.html
- doins doc/pspp.pdf doc/pspp-dev.pdf
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
fi
+ use doc && dohtml doc/pspp.html doc/pspp-dev.html && \
+ dodoc doc/pspp{,-dev}.pdf
if use emacs; then
elisp-install ${PN} *.el *.elc
elisp-site-file-install "${FILESDIR}/${SITEFILE}"
diff --git a/sci-mathematics/pspp/pspp-0.6.2.ebuild b/sci-mathematics/pspp/pspp-0.6.2.ebuild
deleted file mode 100644
index 9caf0f179b46..000000000000
--- a/sci-mathematics/pspp/pspp-0.6.2.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pspp/pspp-0.6.2.ebuild,v 1.8 2012/05/04 07:46:50 jdhore Exp $
-
-EAPI=2
-inherit eutils elisp-common autotools
-
-DESCRIPTION="Program for statistical analysis of sampled data."
-HOMEPAGE="http://www.gnu.org/software/pspp/pspp.html"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
-SLOT="0"
-LICENSE="GPL-3"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc emacs gtk ncurses nls plotutils postgres"
-
-RDEPEND="
- sci-libs/gsl
- sys-libs/readline
- sys-devel/gettext
- virtual/libiconv
- sys-libs/zlib
- dev-libs/libxml2:2
- emacs? ( virtual/emacs )
- gtk? ( x11-libs/gtk+:2 gnome-base/libglade:2.0 )
- ncurses? ( sys-libs/ncurses )
- plotutils? ( media-libs/plotutils )
- postgres? ( dev-db/postgresql-server )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( virtual/latex-base )"
-
-SITEFILE=50${PN}-gentoo.el
-
-src_prepare() {
- # this patch is hacky, but should not be needed for 0.7
- epatch "${FILESDIR}"/${PN}-0.6.0-as-needed.patch
- epatch "${FILESDIR}"/${PN}-0.6.2-no-test-pgsql.patch
- eautoreconf
-}
-
-src_configure() {
- econf \
- --disable-rpath \
- $(use_enable nls) \
- $(use_with gtk gui) \
- $(use_with ncurses libncurses) \
- $(use_with plotutils libplot) \
- $(use_with postgres libpq)
-}
-
-src_compile() {
- emake pkglibdir=/usr/$(get_libdir) || die "emake failed"
- if use doc; then
- emake html || die "emake html failed"
- emake pdf || die "emake pdf failed"
- fi
- use emacs && elisp-compile *.el
-}
-
-src_install() {
- emake pkglibdir=/usr/$(get_libdir) DESTDIR="${D}" install || die "emake install failed"
-
- dodoc AUTHORS ChangeLog NEWS ONEWS README THANKS TODO
- insinto /usr/share/doc/${PF}
- doins -r examples || die
-
- if use doc; then
- doins -r doc/pspp.html doc/pspp-dev.html || die
- doins doc/pspp.pdf doc/pspp-dev.pdf || die
- fi
- if use emacs; then
- elisp-install ${PN} *.el *.elc
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- if use gtk; then
- doicon src/ui/gui/${PN}icon.png
- make_desktop_entry psppire psppire ${PN}icon
- fi
-}
-
-pkg_postinst () {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}