summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2011-02-12 19:05:07 +0000
committerRafael Martins <rafaelmartins@gentoo.org>2011-02-12 19:05:07 +0000
commite76b84cd5969148efa3ebb11bf9d2e0a846b80d4 (patch)
tree5b8ba37f12e832a30d92062fe865af324f3387b0 /sci-mathematics/octave
parentsparc stable wrt #350513 (diff)
downloadgentoo-2-e76b84cd5969148efa3ebb11bf9d2e0a846b80d4.tar.gz
gentoo-2-e76b84cd5969148efa3ebb11bf9d2e0a846b80d4.tar.bz2
gentoo-2-e76b84cd5969148efa3ebb11bf9d2e0a846b80d4.zip
Version bump.
(Portage version: 2.2.0_alpha23/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/octave')
-rw-r--r--sci-mathematics/octave/ChangeLog8
-rw-r--r--sci-mathematics/octave/octave-3.4.0.ebuild104
2 files changed, 111 insertions, 1 deletions
diff --git a/sci-mathematics/octave/ChangeLog b/sci-mathematics/octave/ChangeLog
index a1d1c8391cf5..47bd57ee7bef 100644
--- a/sci-mathematics/octave/ChangeLog
+++ b/sci-mathematics/octave/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/octave
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.99 2011/01/19 17:19:25 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.100 2011/02/12 19:05:07 rafaelmartins Exp $
+
+*octave-3.4.0 (12 Feb 2011)
+
+ 12 Feb 2011; Rafael G. Martins <rafaelmartins@gentoo.org>
+ +octave-3.4.0.ebuild:
+ Version bump.
19 Jan 2011; Sébastien Fabbro <bicatali@gentoo.org> octave-3.2.4-r3.ebuild,
+files/octave-3.2.4-fltk-1.3.patch:
diff --git a/sci-mathematics/octave/octave-3.4.0.ebuild b/sci-mathematics/octave/octave-3.4.0.ebuild
new file mode 100644
index 000000000000..9c143267aae2
--- /dev/null
+++ b/sci-mathematics/octave/octave-3.4.0.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.4.0.ebuild,v 1.1 2011/02/12 19:05:07 rafaelmartins Exp $
+
+EAPI="2"
+inherit flag-o-matic xemacs-elisp-common
+
+DESCRIPTION="High-level interactive language for numerical computations"
+LICENSE="GPL-3"
+HOMEPAGE="http://www.octave.org/"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+IUSE="curl doc emacs fftw readline sparse test xemacs zlib"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="dev-libs/libpcre
+ media-gfx/graphicsmagick[cxx]
+ media-libs/ftgl
+ media-libs/qhull
+ sci-libs/qrupdate
+ sci-mathematics/glpk
+ sci-visualization/gnuplot
+ sys-libs/ncurses
+ virtual/lapack
+ virtual/opengl
+ x11-libs/libX11
+ >=x11-libs/fltk-1.3[opengl]
+ curl? ( net-misc/curl )
+ fftw? ( sci-libs/fftw:3.0 )
+ sparse? (
+ sci-libs/camd
+ sci-libs/ccolamd
+ sci-libs/cholmod
+ sci-libs/colamd
+ sci-libs/cxsparse
+ sci-libs/umfpack )
+ xemacs? ( app-editors/xemacs )
+ zlib? ( sys-libs/zlib )
+ !sci-mathematics/octave-forge"
+
+DEPEND="${RDEPEND}
+ virtual/latex-base
+ sys-apps/texinfo
+ || ( dev-texlive/texlive-genericrecommended
+ app-text/ptex )
+ dev-util/gperf
+ dev-util/pkgconfig"
+
+src_configure() {
+ # hdf5 disabled because not really useful (bug #299876)
+ econf \
+ --localstatedir=/var/state/octave \
+ --enable-shared \
+ --without-hdf5 \
+ --with-gplk \
+ --with-opengl \
+ --with-qrupdate \
+ --with-blas="$(pkg-config --libs blas)" \
+ --with-lapack="$(pkg-config --libs lapack)" \
+ $(use_enable readline) \
+ $(use_with curl) \
+ $(use_with fftw fftw3) \
+ $(use_with fftw fftw3f) \
+ $(use_with sparse arpack) \
+ $(use_with sparse umfpack) \
+ $(use_with sparse colamd) \
+ $(use_with sparse ccolamd) \
+ $(use_with sparse cholmod) \
+ $(use_with sparse cxsparse) \
+ $(use_with zlib z)
+}
+
+src_compile() {
+ emake || die "emake failed"
+ if use xemacs; then
+ cd "${S}/emacs"
+ xemacs-elisp-comp *.el
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+
+ if use doc; then
+ einfo "Installing documentation..."
+ insinto /usr/share/doc/${PF}
+ doins $(find doc -name \*.pdf)
+ fi
+
+ if use emacs || use xemacs; then
+ cd emacs
+ exeinto /usr/bin
+ doexe octave-tags || die "Failed to install octave-tags"
+ doman octave-tags.1 || die "Failed to install octave-tags.1"
+ if use xemacs; then
+ xemacs-elisp-install ${PN} *.el *.elc
+ fi
+ cd ..
+ fi
+ use test && dodoc test/fntests.log
+ echo "LDPATH=/usr/$(get_libdir)/octave-${PV}" > 99octave
+ doenvd 99octave || die
+}