summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-01-19 17:19:25 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-01-19 17:19:25 +0000
commit696228c56efcb503a75b8b7dc8213b3c6cd61c21 (patch)
tree817fb23aa201d9850ab8b39d3c89555e82a8a9fa /sci-mathematics/octave
parentFixed tests bug #351545 (diff)
downloadgentoo-2-696228c56efcb503a75b8b7dc8213b3c6cd61c21.tar.gz
gentoo-2-696228c56efcb503a75b8b7dc8213b3c6cd61c21.tar.bz2
gentoo-2-696228c56efcb503a75b8b7dc8213b3c6cd61c21.zip
Added a patch for compatibility with fltk-1.3, thanks to Yury Fedorchenko bug #351963
(Portage version: 2.1.9.33/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/octave')
-rw-r--r--sci-mathematics/octave/ChangeLog9
-rw-r--r--sci-mathematics/octave/files/octave-3.2.4-fltk-1.3.patch32
-rw-r--r--sci-mathematics/octave/octave-3.2.4-r3.ebuild6
3 files changed, 43 insertions, 4 deletions
diff --git a/sci-mathematics/octave/ChangeLog b/sci-mathematics/octave/ChangeLog
index 8f8d18004989..a1d1c8391cf5 100644
--- a/sci-mathematics/octave/ChangeLog
+++ b/sci-mathematics/octave/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/octave
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.98 2010/11/01 17:19:54 bicatali Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.99 2011/01/19 17:19:25 bicatali Exp $
+
+ 19 Jan 2011; Sébastien Fabbro <bicatali@gentoo.org> octave-3.2.4-r3.ebuild,
+ +files/octave-3.2.4-fltk-1.3.patch:
+ Added a patch for compatibility with fltk-1.3, thanks to Yury Fedorchenko bug
+ #351963
01 Nov 2010; Sébastien Fabbro <bicatali@gentoo.org>
octave-3.2.4-r3.ebuild:
diff --git a/sci-mathematics/octave/files/octave-3.2.4-fltk-1.3.patch b/sci-mathematics/octave/files/octave-3.2.4-fltk-1.3.patch
new file mode 100644
index 000000000000..59177a95bc28
--- /dev/null
+++ b/sci-mathematics/octave/files/octave-3.2.4-fltk-1.3.patch
@@ -0,0 +1,32 @@
+diff -urN octave-3.2.4/src/DLD-FUNCTIONS/fltk_backend.cc octave-3.2.4_new/src/DLD-FUNCTIONS/fltk_backend.cc
+--- octave-3.2.4/src/DLD-FUNCTIONS/fltk_backend.cc 2009-05-25 10:05:00.000000000 +0400
++++ octave-3.2.4_new/src/DLD-FUNCTIONS/fltk_backend.cc 2010-06-30 12:23:38.000000000 +0400
+@@ -40,6 +40,14 @@
+ #include <sstream>
+ #include <iostream>
+
++#include "cmd-edit.h"
++#include "defun-dld.h"
++#include "error.h"
++#include "gl-render.h"
++#include "graphics.h"
++#include "parse.h"
++#include "variables.h"
++
+ #include <FL/Fl.H>
+ #include <FL/Fl_Window.H>
+ #include <FL/Fl_Output.H>
+@@ -54,13 +62,6 @@
+ #undef max
+ #endif
+
+-#include "cmd-edit.h"
+-#include "defun-dld.h"
+-#include "error.h"
+-#include "gl-render.h"
+-#include "graphics.h"
+-#include "parse.h"
+-#include "variables.h"
+
+ #define FLTK_BACKEND_NAME "fltk"
+
diff --git a/sci-mathematics/octave/octave-3.2.4-r3.ebuild b/sci-mathematics/octave/octave-3.2.4-r3.ebuild
index 99f0535f0be9..ee1cd459b1c2 100644
--- a/sci-mathematics/octave/octave-3.2.4-r3.ebuild
+++ b/sci-mathematics/octave/octave-3.2.4-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.2.4-r3.ebuild,v 1.2 2010/11/01 17:19:54 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.2.4-r3.ebuild,v 1.3 2011/01/19 17:19:25 bicatali Exp $
EAPI="2"
inherit flag-o-matic xemacs-elisp-common autotools
@@ -60,6 +60,8 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-3.2.4-interp2.patch
epatch "${FILESDIR}"/${PN}-3.2.4-no-helvetica.patch
epatch "${FILESDIR}"/${PN}-3.2.4-normal-marker-size.patch
+ has_version ">=x11-libs/fltk-1.3_rc1" && \
+ epatch "${FILESDIR}"/${PN}-3.2.4-fltk-1.3.patch
eautoreconf
}