summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2012-09-26 14:50:50 +0000
committerAndrey Grozin <grozin@gentoo.org>2012-09-26 14:50:50 +0000
commitededc449d64f10eed5215ddc80b03ee345b655d8 (patch)
treea91d6aafd0a27f588d6a6b0be34407d90388d806 /sci-mathematics/gsl-shell
parentStable for HPPA (bug #393991). (diff)
downloadgentoo-2-ededc449d64f10eed5215ddc80b03ee345b655d8.tar.gz
gentoo-2-ededc449d64f10eed5215ddc80b03ee345b655d8.tar.bz2
gentoo-2-ededc449d64f10eed5215ddc80b03ee345b655d8.zip
Fixing a stupid typo
(Portage version: 2.2.0_alpha133/cvs/Linux i686)
Diffstat (limited to 'sci-mathematics/gsl-shell')
-rw-r--r--sci-mathematics/gsl-shell/ChangeLog5
-rw-r--r--sci-mathematics/gsl-shell/gsl-shell-2.2.0_beta1.ebuild11
2 files changed, 9 insertions, 7 deletions
diff --git a/sci-mathematics/gsl-shell/ChangeLog b/sci-mathematics/gsl-shell/ChangeLog
index 7c2bb35b1373..d72e6f5dc2d5 100644
--- a/sci-mathematics/gsl-shell/ChangeLog
+++ b/sci-mathematics/gsl-shell/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-mathematics/gsl-shell
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gsl-shell/ChangeLog,v 1.4 2012/09/26 12:36:54 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gsl-shell/ChangeLog,v 1.5 2012/09/26 14:50:50 grozin Exp $
+
+ 26 Sep 2012; Andrey Grozin <grozin@gentoo.org> gsl-shell-2.2.0_beta1.ebuild:
+ Fixing a stupid typo
26 Sep 2012; Agostino Sarubbo <ago@gentoo.org> gsl-shell-2.2.0_beta1.ebuild:
add ~amd64, wrt to bug #435746
diff --git a/sci-mathematics/gsl-shell/gsl-shell-2.2.0_beta1.ebuild b/sci-mathematics/gsl-shell/gsl-shell-2.2.0_beta1.ebuild
index d9b79704d61c..5c950e666049 100644
--- a/sci-mathematics/gsl-shell/gsl-shell-2.2.0_beta1.ebuild
+++ b/sci-mathematics/gsl-shell/gsl-shell-2.2.0_beta1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gsl-shell/gsl-shell-2.2.0_beta1.ebuild,v 1.4 2012/09/26 12:36:54 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gsl-shell/gsl-shell-2.2.0_beta1.ebuild,v 1.5 2012/09/26 14:50:50 grozin Exp $
EAPI=4
inherit eutils versionator
@@ -11,7 +11,7 @@ MY_P=$(version_format_string '${PN}-$1.$2.$3-$4')
SRC_URI="http://download.savannah.gnu.org/releases/${PN}/${MY_P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~x86"
IUSE="doc fox"
DEPEND=">=sci-libs/gsl-1.14
@@ -37,13 +37,12 @@ src_compile() {
if use fox; then
local FOX_INCLUDES=`WANT_FOX=1.6 fox-config --cflags`
local FOX_LIBS=`WANT_FOX=1.6 fox-config --libs`
- emake -j1 GSL_LIBS="-lgsl ${BLAS}" FOX_INCLUDES="${FOX_INCLUDES}" FOX_LIBS="${FOX_LIBS}"
+ emake -j1 CFLAGS="${CFLAGS}" GSL_LIBS="-lgsl ${BLAS}" \
+ FOX_INCLUDES="${FOX_INCLUDES}" FOX_LIBS="${FOX_LIBS}"
else
- emake -j1 GSL_LIBS="-lgsl ${BLAS}"
+ emake -j1 CFLAGS="${CFLAGS}" GSL_LIBS="-lgsl ${BLAS}"
fi
- emake -j1 CFLAGS="${CFLAGS}"
-
if use doc; then
pushd doc/user-manual > /dev/null
emake -j1 html