summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-10-27 15:36:25 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-10-27 15:36:25 +0000
commitca7a0baf76ef5b2f70d708fd3744b8e3f834af60 (patch)
tree792ae678d06227ef2bc8441003bf7426aab85a10 /sci-mathematics/glpk
parentStable on x86 (#244528) (diff)
downloadgentoo-2-ca7a0baf76ef5b2f70d708fd3744b8e3f834af60.tar.gz
gentoo-2-ca7a0baf76ef5b2f70d708fd3744b8e3f834af60.tar.bz2
gentoo-2-ca7a0baf76ef5b2f70d708fd3744b8e3f834af60.zip
Version bump
(Portage version: 2.2_rc11/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'sci-mathematics/glpk')
-rw-r--r--sci-mathematics/glpk/ChangeLog8
-rw-r--r--sci-mathematics/glpk/glpk-4.32.ebuild (renamed from sci-mathematics/glpk/glpk-4.28.ebuild)32
2 files changed, 31 insertions, 9 deletions
diff --git a/sci-mathematics/glpk/ChangeLog b/sci-mathematics/glpk/ChangeLog
index 3fb1f08fc43e..15ae7295f6ab 100644
--- a/sci-mathematics/glpk/ChangeLog
+++ b/sci-mathematics/glpk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/glpk
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/glpk/ChangeLog,v 1.25 2008/07/23 17:35:15 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/glpk/ChangeLog,v 1.26 2008/10/27 15:36:25 bicatali Exp $
+
+*glpk-4.32 (27 Oct 2008)
+
+ 27 Oct 2008; Sébastien Fabbro <bicatali@gentoo.org> -glpk-4.28.ebuild,
+ +glpk-4.32.ebuild:
+ Version bump
23 Jul 2008; Sébastien Fabbro <bicatali@gentoo.org> glpk-4.29.ebuild:
Added dev-db/unixODBC as a possible odbc implementation and changed use
diff --git a/sci-mathematics/glpk/glpk-4.28.ebuild b/sci-mathematics/glpk/glpk-4.32.ebuild
index a5d28b9080a9..a801fc91456e 100644
--- a/sci-mathematics/glpk/glpk-4.28.ebuild
+++ b/sci-mathematics/glpk/glpk-4.32.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/glpk/glpk-4.28.ebuild,v 1.5 2008/05/06 19:31:50 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/glpk/glpk-4.32.ebuild,v 1.1 2008/10/27 15:36:25 bicatali Exp $
+
+inherit flag-o-matic
DESCRIPTION="GNU Linear Programming Kit"
LICENSE="GPL-3"
@@ -8,19 +10,31 @@ HOMEPAGE="http://www.gnu.org/software/glpk/"
SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
SLOT="0"
-IUSE="doc gmp iodbc mysql"
+IUSE="doc examples gmp odbc mysql"
KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-DEPEND="iodbc? ( dev-db/libiodbc )
+RDEPEND="odbc? ( || ( dev-db/libiodbc dev-db/unixODBC ) )
gmp? ( dev-libs/gmp )
mysql? ( virtual/mysql )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
src_compile() {
+ local myconf="--disable-dl"
+ if use mysql || use odbc; then
+ myconf="--enable-dl"
+ fi
+
+ [[ -z $(type -P odbc-config) ]] && \
+ append-cppflags $(pkg-config --cflags libiodbc)
+
econf \
- $(use_enable gmp) \
- $(use_enable iodbc) \
+ --with-zlib \
+ $(use_with gmp) \
+ $(use_enable odbc) \
$(use_enable mysql) \
- || die "econf failed"
+ ${myconf} || die "econf failed"
emake || die "emake failed"
}
@@ -32,8 +46,10 @@ src_install() {
die "failed to install docs"
insinto /usr/share/doc/${PF}
- # 388Kb
- doins -r examples || die "failed to install examples"
+ if use examples; then
+ emake distclean
+ doins -r examples || die "failed to install examples"
+ fi
if use doc; then
cd "${S}"/doc
doins memo/gomory.djvu || die "failed to instal memo"