summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2014-04-05 21:32:03 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2014-04-05 21:32:03 +0000
commit375f8c3000061712b10efba64587e5a5b75d3cb7 (patch)
tree4e584bcefe02c8d61b8a4d0fc62e5b45ff803916 /sci-mathematics/glpk/glpk-4.54.ebuild
parentRemove leechcraft-meta mask that is anyway always shadowed (diff)
downloadgentoo-2-375f8c3000061712b10efba64587e5a5b75d3cb7.tar.gz
gentoo-2-375f8c3000061712b10efba64587e5a5b75d3cb7.tar.bz2
gentoo-2-375f8c3000061712b10efba64587e5a5b75d3cb7.zip
Version bump
(Portage version: 2.2.8-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-mathematics/glpk/glpk-4.54.ebuild')
-rw-r--r--sci-mathematics/glpk/glpk-4.54.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/sci-mathematics/glpk/glpk-4.54.ebuild b/sci-mathematics/glpk/glpk-4.54.ebuild
new file mode 100644
index 000000000000..b1fc60931b0a
--- /dev/null
+++ b/sci-mathematics/glpk/glpk-4.54.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/glpk/glpk-4.54.ebuild,v 1.1 2014/04/05 21:32:03 bicatali Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+
+inherit eutils flag-o-matic toolchain-funcs autotools-utils
+
+DESCRIPTION="GNU Linear Programming Kit"
+LICENSE="GPL-3"
+HOMEPAGE="http://www.gnu.org/software/glpk/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+SLOT="0/36"
+IUSE="doc examples gmp odbc mysql static-libs"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+
+RDEPEND="
+ sci-libs/amd:0=
+ sci-libs/colamd:=
+ sys-libs/zlib:0=
+ gmp? ( dev-libs/gmp:0= )
+ mysql? ( virtual/mysql )
+ odbc? ( || ( dev-db/libiodbc:0= dev-db/unixODBC:0= ) )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.54-debundle-system-libs.patch
+)
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable mysql)
+ $(use_enable odbc)
+ $(use_with gmp)
+ )
+ if use mysql || use odbc; then
+ myeconfargs+=( --enable-dl )
+ else
+ myeconfargs+=( --disable-dl )
+ fi
+ [[ -z $(type -P odbc-config) ]] && \
+ append-cppflags $($(tc-getPKG_CONFIG) --cflags libiodbc)
+
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ use doc && dodoc doc/*.pdf doc/notes/*.pdf doc/*.txt
+}