summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2010-01-24 12:35:28 +0000
committerAndrey Grozin <grozin@gentoo.org>2010-01-24 12:35:28 +0000
commitb44be695dd6936e6951d1f59fb78333ebdee144a (patch)
treedd1e1685a34b5e8adc59204bb7c14144d1b22526 /sci-mathematics/fricas
parent[sci-chemistry/wxmacmolplt] Version bump per bug #292977 (diff)
downloadgentoo-2-b44be695dd6936e6951d1f59fb78333ebdee144a.tar.gz
gentoo-2-b44be695dd6936e6951d1f59fb78333ebdee144a.tar.bz2
gentoo-2-b44be695dd6936e6951d1f59fb78333ebdee144a.zip
Version bump
(Portage version: 2.2_rc61/cvs/Linux i686)
Diffstat (limited to 'sci-mathematics/fricas')
-rw-r--r--sci-mathematics/fricas/ChangeLog7
-rw-r--r--sci-mathematics/fricas/fricas-1.0.9.ebuild97
2 files changed, 103 insertions, 1 deletions
diff --git a/sci-mathematics/fricas/ChangeLog b/sci-mathematics/fricas/ChangeLog
index d57438fa223f..eb31da15dce6 100644
--- a/sci-mathematics/fricas/ChangeLog
+++ b/sci-mathematics/fricas/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/fricas
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fricas/ChangeLog,v 1.4 2010/01/10 11:49:17 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fricas/ChangeLog,v 1.5 2010/01/24 12:35:28 grozin Exp $
+
+*fricas-1.0.9 (24 Jan 2010)
+
+ 24 Jan 2010; Andrey Grozin <grozin@gentoo.org> +fricas-1.0.9.ebuild:
+ Version bump
10 Jan 2010; Andrey Grozin <grozin@gentoo.org> fricas-1.0.8.ebuild:
~amd64 added, closing bug #300132, thanks to Helmut Jarausch
diff --git a/sci-mathematics/fricas/fricas-1.0.9.ebuild b/sci-mathematics/fricas/fricas-1.0.9.ebuild
new file mode 100644
index 000000000000..6b3340280638
--- /dev/null
+++ b/sci-mathematics/fricas/fricas-1.0.9.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fricas/fricas-1.0.9.ebuild,v 1.1 2010/01/24 12:35:28 grozin Exp $
+EAPI=2
+inherit multilib elisp-common
+
+DESCRIPTION="FriCAS is a fork of Axiom computer algebra system"
+HOMEPAGE="http://${PN}.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-full.tar.bz2"
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Supported lisps, number 0 is the default
+LISPS=( sbcl cmucl gcl ecl clisp clozurecl )
+# . means just dev-lisp/${LISP}; foo-x.y.z means >=dev-lisp/foo-x.y.z
+DEPS=( . . . ecls-9 . . )
+# command name: . means just ${LISP}
+COMS=( . lisp . . . ccl )
+
+IUSE="${LISPS[*]} X emacs"
+RDEPEND="X? ( x11-libs/libXpm x11-libs/libICE )
+ emacs? ( virtual/emacs )"
+
+# Generating lisp deps
+n=${#LISPS[*]}
+for ((n--; n > 0; n--)); do
+ LISP=${LISPS[$n]}
+ DEP=${DEPS[$n]}
+ if [ "${DEP}" = "." ]; then
+ DEP="dev-lisp/${LISP}"
+ else
+ DEP=">=dev-lisp/${DEP}"
+ fi
+ RDEPEND="${RDEPEND} ${LISP}? ( ${DEP} ) !${LISP}? ("
+done
+RDEPEND="${RDEPEND} dev-lisp/${LISPS[0]}"
+n=${#LISPS[*]}
+for ((n--; n > 0; n--)); do
+ RDEPEND="${RDEPEND} )"
+done
+
+DEPEND="${RDEPEND}"
+
+# necessary for clisp and gcl
+RESTRICT="strip"
+
+src_configure() {
+ local LISP n
+ LISP=sbcl
+ n=${#LISPS[*]}
+ for ((n--; n > 0; n--)); do
+ if use ${LISPS[$n]}; then
+ LISP=${COMS[$n]}
+ if [ "${LISP}" = "." ]; then
+ LISP=${LISPS[$n]}
+ fi
+ fi
+ done
+ einfo "Using lisp: ${LISP}"
+
+ # aldor is not yet in portage
+ econf --disable-aldor --with-lisp=${LISP} $(use_with X x)
+}
+
+src_compile() {
+ # bug #300132
+ emake -j1 || die "emake failed"
+}
+
+src_test() {
+ emake -j1 all-input
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die 'emake install failed'
+ dodoc README FAQ || die "dodoc failed"
+
+ if use emacs; then
+ sed -e "s|(setq load-path (cons (quote \"/usr/$(get_libdir)/fricas/emacs\") load-path)) ||" \
+ -i "${D}"/usr/bin/efricas \
+ || die "sed efricas failed"
+ elisp-install ${PN} "${D}"/usr/$(get_libdir)/${PN}/emacs/*.el
+ elisp-site-file-install "${FILESDIR}"/64${PN}-gentoo.el
+ else
+ rm "${D}"/usr/bin/efricas || die "rm efricas failed"
+ fi
+ rm -r "${D}"/usr/$(get_libdir)/${PN}/emacs || die "rm -r emacs failed"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}