summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-04-01 02:18:07 +0000
committerMark Wright <gienah@gentoo.org>2012-04-01 02:18:07 +0000
commit03fce0c93edcbc1f5464ae1cf2e1da92a73022aa (patch)
treefd69c1f9823a4889781fd8b7fd066864a404aad4 /sci-mathematics/agda
parentMake use of the new hwids ebuild. (diff)
downloadgentoo-2-03fce0c93edcbc1f5464ae1cf2e1da92a73022aa.tar.gz
gentoo-2-03fce0c93edcbc1f5464ae1cf2e1da92a73022aa.tar.bz2
gentoo-2-03fce0c93edcbc1f5464ae1cf2e1da92a73022aa.zip
Fix agda 2.3.0.1 build with haskell-src-exts-1.13.0
(Portage version: 2.1.10.52/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/agda')
-rw-r--r--sci-mathematics/agda/ChangeLog6
-rw-r--r--sci-mathematics/agda/agda-2.3.0.1.ebuild3
-rw-r--r--sci-mathematics/agda/files/agda-2.3.0.1-haskell-src-exts-1.13.patch26
3 files changed, 33 insertions, 2 deletions
diff --git a/sci-mathematics/agda/ChangeLog b/sci-mathematics/agda/ChangeLog
index c5e173b0f6b0..ea8d6eccbf4c 100644
--- a/sci-mathematics/agda/ChangeLog
+++ b/sci-mathematics/agda/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/agda
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/ChangeLog,v 1.12 2012/03/25 13:55:19 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/ChangeLog,v 1.13 2012/04/01 02:18:07 gienah Exp $
+
+ 01 Apr 2012; Mark Wright <gienah@gentoo.org>
+ +files/agda-2.3.0.1-haskell-src-exts-1.13.patch, agda-2.3.0.1.ebuild:
+ Fix agda 2.3.0.1 build with haskell-src-exts-1.13.0
*agda-2.3.0.1 (25 Mar 2012)
diff --git a/sci-mathematics/agda/agda-2.3.0.1.ebuild b/sci-mathematics/agda/agda-2.3.0.1.ebuild
index 9822de9ac0eb..4eb0f589a344 100644
--- a/sci-mathematics/agda/agda-2.3.0.1.ebuild
+++ b/sci-mathematics/agda/agda-2.3.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/agda-2.3.0.1.ebuild,v 1.1 2012/03/25 13:55:19 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/agda-2.3.0.1.ebuild,v 1.2 2012/04/01 02:18:07 gienah Exp $
# ebuild generated by hackport 0.2.14
@@ -43,6 +43,7 @@ S="${WORKDIR}/${MY_P}"
src_prepare() {
epatch "${FILESDIR}"/${P}-emacs.patch
+ epatch "${FILESDIR}"/${PN}-2.3.0.1-haskell-src-exts-1.13.patch
cabal-mksetup
}
diff --git a/sci-mathematics/agda/files/agda-2.3.0.1-haskell-src-exts-1.13.patch b/sci-mathematics/agda/files/agda-2.3.0.1-haskell-src-exts-1.13.patch
new file mode 100644
index 000000000000..06e3c702e864
--- /dev/null
+++ b/sci-mathematics/agda/files/agda-2.3.0.1-haskell-src-exts-1.13.patch
@@ -0,0 +1,26 @@
+--- Agda-2.3.0.1-orig/Agda.cabal 2012-03-12 21:09:34.000000000 +1100
++++ Agda-2.3.0.1/Agda.cabal 2012-04-01 11:54:47.565833931 +1000
+@@ -77,7 +77,7 @@
+ build-depends: epic >= 0.1.13 && < 0.10
+ build-depends: mtl == 2.0.*,
+ QuickCheck >= 2.3 && < 2.5,
+- haskell-src-exts >= 1.9.6 && < 1.12,
++ haskell-src-exts >= 1.9.6 && < 1.14,
+ containers >= 0.1 && < 0.5,
+ pretty >= 1.0 && < 1.2,
+ directory >= 1.0 && < 1.2,
+--- Agda-2.3.0.1-orig/src/full/Agda/Compiler/MAlonzo/Compiler.hs 2012-04-01 11:27:52.058688415 +1000
++++ Agda-2.3.0.1/src/full/Agda/Compiler/MAlonzo/Compiler.hs 2012-04-01 11:30:42.732658634 +1000
+@@ -466,8 +466,11 @@
+ ]
+ where
+ parse = HS.parseWithMode
++#if MIN_VERSION_haskell_src_exts(1,13,0)
++ HS.defaultParseMode{HS.extensions = [HS.ExplicitForAll]}
++#else
+ HS.defaultParseMode{HS.extensions = [HS.ExplicitForall]}
+-
++#endif
+ ok (HS.ParseOk d) = d
+ ok HS.ParseFailed{} = __IMPOSSIBLE__
+