summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-05-17 10:12:29 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-05-17 10:12:29 +0000
commitf68610e9f7b4576cb55af55b26129c0fdda03c81 (patch)
treee626be1ba101679e6763aebb36d9a41a8fa79001 /sci-libs
parentVersion bump (diff)
downloadgentoo-2-f68610e9f7b4576cb55af55b26129c0fdda03c81.tar.gz
gentoo-2-f68610e9f7b4576cb55af55b26129c0fdda03c81.tar.bz2
gentoo-2-f68610e9f7b4576cb55af55b26129c0fdda03c81.zip
Added RESTRICT=strip to prevent debug lib from being stripped.
(Portage version: 2.1.5_rc10)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/itpp/ChangeLog5
-rw-r--r--sci-libs/itpp/itpp-4.0.4.ebuild13
2 files changed, 16 insertions, 2 deletions
diff --git a/sci-libs/itpp/ChangeLog b/sci-libs/itpp/ChangeLog
index a67dd8e17805..4915e97b646f 100644
--- a/sci-libs/itpp/ChangeLog
+++ b/sci-libs/itpp/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/itpp
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.74 2008/05/12 13:28:05 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.75 2008/05/17 10:12:29 markusle Exp $
+
+ 17 May 2008; Markus Dittrich <markusle@gentoo.org> itpp-4.0.4.ebuild:
+ Added RESTRICT="strip" to prevent debug lib from being stripped.
12 May 2008; Markus Dittrich <markusle@gentoo.org> itpp-4.0.3.ebuild,
itpp-4.0.4.ebuild:
diff --git a/sci-libs/itpp/itpp-4.0.4.ebuild b/sci-libs/itpp/itpp-4.0.4.ebuild
index a71e8965e2bb..fd6eaadeea55 100644
--- a/sci-libs/itpp/itpp-4.0.4.ebuild
+++ b/sci-libs/itpp/itpp-4.0.4.ebuild
@@ -1,9 +1,13 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-4.0.4.ebuild,v 1.5 2008/05/12 15:56:37 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-4.0.4.ebuild,v 1.6 2008/05/17 10:12:29 markusle Exp $
inherit fortran flag-o-matic
+# we need this to prevent itpp's specialized debug lib
+# (built with USE="debug" set) from being stripped
+RESTRICT="strip"
+
DESCRIPTION="C++ library of mathematical, signal processing and communication classes and functions"
LICENSE="GPL-2"
HOMEPAGE="http://itpp.sourceforge.net/"
@@ -37,6 +41,13 @@ src_compile() {
# turn off performance critical debug code
append-flags -DNDEBUG
+ # make sure that -g is removed with USE="debug"
+ # since we've turned stripping off and a separate
+ # debug lib is being built
+ if use debug; then
+ filter-flags -g
+ fi
+
local blas_conf="--without-blas"
local lapack_conf="--without-lapack"
if use blas; then