summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2008-12-02 16:23:04 +0000
committerAndrey Grozin <grozin@gentoo.org>2008-12-02 16:23:04 +0000
commitecf75b7904dae3689fbdacb0f9174c2e01ff23c7 (patch)
tree77329d9d16cc46f716e320fd340388a6bf5773a7 /sci-libs
parentVersion bump (diff)
downloadgentoo-2-ecf75b7904dae3689fbdacb0f9174c2e01ff23c7.tar.gz
gentoo-2-ecf75b7904dae3689fbdacb0f9174c2e01ff23c7.tar.bz2
gentoo-2-ecf75b7904dae3689fbdacb0f9174c2e01ff23c7.zip
Initial import, based on ebuild in the science overlay
(Portage version: 2.2_rc16/cvs/Linux 2.6.26-tuxonice i686)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/mathgl/ChangeLog10
-rw-r--r--sci-libs/mathgl/mathgl-1.8.ebuild49
-rw-r--r--sci-libs/mathgl/metadata.xml10
3 files changed, 69 insertions, 0 deletions
diff --git a/sci-libs/mathgl/ChangeLog b/sci-libs/mathgl/ChangeLog
new file mode 100644
index 000000000000..fe34ff2e90db
--- /dev/null
+++ b/sci-libs/mathgl/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-libs/mathgl
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/ChangeLog,v 1.1 2008/12/02 16:23:04 grozin Exp $
+
+*mathgl-1.8 (02 Dec 2008)
+
+ 02 Dec 2008; Andrey Grozin <grozin@gentoo.org> +metadata.xml,
+ +mathgl-1.8.ebuild:
+ Initial import, based on ebuild in the science overlay
+
diff --git a/sci-libs/mathgl/mathgl-1.8.ebuild b/sci-libs/mathgl/mathgl-1.8.ebuild
new file mode 100644
index 000000000000..4b26641eef33
--- /dev/null
+++ b/sci-libs/mathgl/mathgl-1.8.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/mathgl-1.8.ebuild,v 1.1 2008/12/02 16:23:04 grozin Exp $
+EAPI=2
+inherit flag-o-matic
+DESCRIPTION="Math Graphics Library"
+IUSE="doc fltk glut hdf5 jpeg python qt4 wxwindows"
+# octave bindings don't work for me :-(
+HOMEPAGE="http://mathgl.sourceforge.net/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+RDEPEND="sci-libs/gsl
+ media-libs/libpng
+ virtual/glu
+ glut? ( virtual/glut )
+ fltk? ( x11-libs/fltk )
+ jpeg? ( media-libs/jpeg )
+ hdf5? ( sci-libs/hdf5 )
+ qt4? ( x11-libs/qt-gui:4 )
+ wxwindows? ( x11-libs/wxGTK:2.8 )"
+
+DEPEND="${RDEPEND}
+ doc? ( app-text/texi2html virtual/texi2dvi )
+ python? ( dev-lang/swig[python] )"
+
+src_configure() {
+ # fltk example compiles only if we add
+ use fltk && append-cppflags $(fltk-config --cflags)
+ use fltk && append-ldflags $(fltk-config --ldflags)
+
+ econf --docdir="${ROOT}"usr/share/doc/${P} \
+ $(use_enable glut) \
+ $(use_enable qt4 qt) \
+ $(use_enable wxwindows wx) \
+ $(use_enable fltk) \
+ $(use_enable jpeg) \
+ $(use_enable hdf5) \
+ $(use_enable python) \
+ $(use_enable doc docs)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README AUTHORS || die "dodoc failed"
+}
diff --git a/sci-libs/mathgl/metadata.xml b/sci-libs/mathgl/metadata.xml
new file mode 100644
index 000000000000..858ebd719418
--- /dev/null
+++ b/sci-libs/mathgl/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
+ </maintainer>
+ <longdescription>Math Graphics Library</longdescription>
+</pkgmetadata>