summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-04-26 15:18:06 +0000
committerJustin Lecher <jlec@gentoo.org>2012-04-26 15:18:06 +0000
commitd7e41760359e453719a7576d34afe68d9c3422bb (patch)
tree5c32031dceab79bb0fb2acb6a2ce86bb4fa6a862 /sci-libs
parentkeyword ~amd64-fbsd (diff)
downloadgentoo-2-d7e41760359e453719a7576d34afe68d9c3422bb.tar.gz
gentoo-2-d7e41760359e453719a7576d34afe68d9c3422bb.tar.bz2
gentoo-2-d7e41760359e453719a7576d34afe68d9c3422bb.zip
sci-libs/qrupdate: Version Bump
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/qrupdate/ChangeLog10
-rw-r--r--sci-libs/qrupdate/metadata.xml4
-rw-r--r--sci-libs/qrupdate/qrupdate-1.1.2.ebuild46
3 files changed, 56 insertions, 4 deletions
diff --git a/sci-libs/qrupdate/ChangeLog b/sci-libs/qrupdate/ChangeLog
index 03d3bbaefd18..701d85e9e2f2 100644
--- a/sci-libs/qrupdate/ChangeLog
+++ b/sci-libs/qrupdate/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/qrupdate
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/qrupdate/ChangeLog,v 1.23 2011/12/20 17:21:27 bicatali Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/qrupdate/ChangeLog,v 1.24 2012/04/26 15:18:06 jlec Exp $
+
+*qrupdate-1.1.2 (26 Apr 2012)
+
+ 26 Apr 2012; Justin Lecher <jlec@gentoo.org> +qrupdate-1.1.2.ebuild,
+ metadata.xml:
+ Version Bump
20 Dec 2011; Sébastien Fabbro <bicatali@gentoo.org> qrupdate-1.1.0.ebuild:
Fixed soname linking
diff --git a/sci-libs/qrupdate/metadata.xml b/sci-libs/qrupdate/metadata.xml
index a8bc30434eab..76975a2a58e9 100644
--- a/sci-libs/qrupdate/metadata.xml
+++ b/sci-libs/qrupdate/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-<longdescription lang="en">
+ <herd>sci</herd>
+ <longdescription lang="en">
qrupdate is a library for fast updating of qr and cholesky decompositions.
</longdescription>
</pkgmetadata>
diff --git a/sci-libs/qrupdate/qrupdate-1.1.2.ebuild b/sci-libs/qrupdate/qrupdate-1.1.2.ebuild
new file mode 100644
index 000000000000..f63bbc285a4c
--- /dev/null
+++ b/sci-libs/qrupdate/qrupdate-1.1.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/qrupdate/qrupdate-1.1.2.ebuild,v 1.1 2012/04/26 15:18:06 jlec Exp $
+
+EAPI=4
+
+inherit eutils fortran-2 versionator toolchain-funcs
+
+DESCRIPTION="Library for updating of QR and Cholesky decompositions"
+HOMEPAGE="http://sourceforge.net/projects/qrupdate"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos ~amd64-linux"
+IUSE="static-libs"
+
+RDEPEND="
+ virtual/fortran
+ virtual/lapack"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.1.1-Makefiles.patch
+ sed -i Makeconf \
+ -e "s:gfortran:$(tc-getFC):g" \
+ -e "s:FFLAGS=.*:FFLAGS=${FFLAGS}:" \
+ -e "s:BLAS=.*:BLAS=$(pkg-config --libs blas):" \
+ -e "s:LAPACK=.*:LAPACK=$(pkg-config --libs lapack):" \
+ -e "/^LIBDIR=/a\PREFIX=${EPREFIX}/usr" \
+ -e "s:LIBDIR=lib:LIBDIR=$(get_libdir):" \
+ || die "Failed to set up Makeconf"
+}
+
+src_compile() {
+ emake solib
+ use static-libs && emake lib
+}
+
+src_install() {
+ emake DESTDIR="${D}" install-shlib
+ dosym libqrupdate.so.$(get_major_version) /usr/$(get_libdir)/libqrupdate.so
+ use static-libs && emake DESTDIR="${D}" install-staticlib
+ dodoc README ChangeLog
+}