summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2007-09-18 09:56:27 +0000
committerDenis Dupeyron <calchan@gentoo.org>2007-09-18 09:56:27 +0000
commitc9359802a3d340a2b24d205aeaf1d27052a0ec85 (patch)
tree8a0e06d9432e476e7d8cb85665614a52ec8b7c8d /sci-libs
parentset WANT_AUTOCONF to none (#192863) (diff)
downloadgentoo-2-c9359802a3d340a2b24d205aeaf1d27052a0ec85.tar.gz
gentoo-2-c9359802a3d340a2b24d205aeaf1d27052a0ec85.tar.bz2
gentoo-2-c9359802a3d340a2b24d205aeaf1d27052a0ec85.zip
Version bump, thanks to Stefan Salewski (bug #192367).
(Portage version: 2.1.3.9)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libgeda/ChangeLog7
-rw-r--r--sci-libs/libgeda/files/digest-libgeda-1.2.03
-rw-r--r--sci-libs/libgeda/libgeda-1.2.0.ebuild54
3 files changed, 63 insertions, 1 deletions
diff --git a/sci-libs/libgeda/ChangeLog b/sci-libs/libgeda/ChangeLog
index 9346b5276edb..ff05bfecd71b 100644
--- a/sci-libs/libgeda/ChangeLog
+++ b/sci-libs/libgeda/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/libgeda
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libgeda/ChangeLog,v 1.37 2007/07/19 09:32:38 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libgeda/ChangeLog,v 1.38 2007/09/18 09:56:27 calchan Exp $
+
+*libgeda-1.2.0 (18 Sep 2007)
+
+ 18 Sep 2007; Denis Dupeyron <calchan@gentoo.org> +libgeda-1.2.0.ebuild:
+ Version bump, thanks to Stefan Salewski (bug #192367).
*libgeda-1.1.1 (19 Jul 2007)
diff --git a/sci-libs/libgeda/files/digest-libgeda-1.2.0 b/sci-libs/libgeda/files/digest-libgeda-1.2.0
new file mode 100644
index 000000000000..919d40d201ec
--- /dev/null
+++ b/sci-libs/libgeda/files/digest-libgeda-1.2.0
@@ -0,0 +1,3 @@
+MD5 43f2b2daabee59ffeae84fe13c10c51d libgeda-1.2.0.tar.gz 656313
+RMD160 0e33b20398587aec9e365e20a9fb38ec2aefb360 libgeda-1.2.0.tar.gz 656313
+SHA256 158c1fe42bbbeda95e79712e45318d5844c908b0a0d58eb53f6e1995ff336c33 libgeda-1.2.0.tar.gz 656313
diff --git a/sci-libs/libgeda/libgeda-1.2.0.ebuild b/sci-libs/libgeda/libgeda-1.2.0.ebuild
new file mode 100644
index 000000000000..13fec1231c7e
--- /dev/null
+++ b/sci-libs/libgeda/libgeda-1.2.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libgeda/libgeda-1.2.0.ebuild,v 1.1 2007/09/18 09:56:27 calchan Exp $
+
+inherit eutils
+
+SUBDIR="v1.2"
+HOMEPAGE="http://www.geda.seul.org"
+DESCRIPTION="libgeda - this library provides functions needed for the gEDA core suite"
+SRC_URI="http://www.geda.seul.org/release/${SUBDIR}/${PV}/libgeda-${PV}.tar.gz"
+
+IUSE="gd"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+SLOT="0"
+
+DEPEND=">=x11-libs/gtk+-2.4
+ >=dev-scheme/guile-1.6.3
+ >=dev-libs/libstroke-0.5.1
+ gd? ( >=media-libs/gd-2 )"
+
+pkg_setup() {
+ if has_version ">=dev-scheme/guile-1.8" ; then
+ built_with_use "dev-scheme/guile" deprecated \
+ || die "You need either <dev-scheme/guile-1.8, or >=dev-scheme/guile-1.8 with USE=deprecated"
+ fi
+ if use gd ; then
+ built_with_use media-libs/gd png || die "media-libs/gd must be compiled with USE=png"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ # Skip the share sub-directory, we'll install prolog.ps manually
+ sed -i \
+ -e "s:SUBDIRS = src include scripts docs share:SUBDIRS = src include scripts docs:" \
+ ${S}/Makefile.in \
+ || die "Patch failed"
+}
+
+src_compile() {
+ econf --disable-dependency-tracking $(use_enable gd) || die "Configuration failed"
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "Installation failed"
+
+ insinto /usr/share/gEDA
+ doins share/prolog.ps
+
+ dodoc AUTHORS BUGS ChangeLog README
+}