summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-08-10 22:04:02 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-08-10 22:04:02 +0000
commitb867c324f385d3f850f33ec16ca3df62924f57cf (patch)
tree4606dfa48d3fc88d50c73914bfe7ef446c38aa21 /sci-libs
parentStable on amd64 wrt bug #331717 (diff)
downloadgentoo-2-b867c324f385d3f850f33ec16ca3df62924f57cf.tar.gz
gentoo-2-b867c324f385d3f850f33ec16ca3df62924f57cf.tar.bz2
gentoo-2-b867c324f385d3f850f33ec16ca3df62924f57cf.zip
Fixed for guile and multiple python, bug #331347
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/nlopt/ChangeLog5
-rw-r--r--sci-libs/nlopt/nlopt-2.2.ebuild7
2 files changed, 7 insertions, 5 deletions
diff --git a/sci-libs/nlopt/ChangeLog b/sci-libs/nlopt/ChangeLog
index d615dd291a0d..9ca6f11c471e 100644
--- a/sci-libs/nlopt/ChangeLog
+++ b/sci-libs/nlopt/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/nlopt
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/ChangeLog,v 1.4 2010/07/20 19:43:50 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/ChangeLog,v 1.5 2010/08/10 22:04:02 bicatali Exp $
+
+ 10 Aug 2010; Sébastien Fabbro <bicatali@gentoo.org> nlopt-2.2.ebuild:
+ Fixed for guile and multiple python, bug #331347
*nlopt-2.2 (20 Jul 2010)
diff --git a/sci-libs/nlopt/nlopt-2.2.ebuild b/sci-libs/nlopt/nlopt-2.2.ebuild
index 9e30bd7e6f6c..d4fc6a6caab3 100644
--- a/sci-libs/nlopt/nlopt-2.2.ebuild
+++ b/sci-libs/nlopt/nlopt-2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/nlopt-2.2.ebuild,v 1.2 2010/07/20 19:58:31 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/nlopt-2.2.ebuild,v 1.3 2010/08/10 22:04:01 bicatali Exp $
EAPI=3
SUPPORT_PYTHON_ABIS="1"
@@ -45,20 +45,19 @@ src_configure() {
$(use_with guile) \
$(use_with octave) \
$(use_with python)
+ use python && python_copy_sources swig
}
src_compile() {
default
if use python; then
- python_copy_sources swig
compilation() {
emake \
PYTHON_CPPFLAGS="-I$(python_get_includedir)" \
PYTHON_LDFLAGS="$(python_get_library -l)" \
PYTHON_SITE_PKG="$(python_get_sitedir)" \
PYTHON_VERSION="$(python_get_version)" \
- pyexecdir="$(python_get_sitedir)" \
- _nlopt.la
+ pyexecdir="$(python_get_sitedir)"
}
python_execute_function -s --source-dir swig compilation
fi