summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-08-19 14:25:06 +0000
committerJustin Lecher <jlec@gentoo.org>2013-08-19 14:25:06 +0000
commitb3a6ab6956830a37562f3c857d82f7a182d2b1f4 (patch)
tree310e0c3b5306b868ab20195ae8c59725b5676c39 /sci-libs
parentVersion bump. Clean out old versions and related patch files. (diff)
downloadgentoo-2-b3a6ab6956830a37562f3c857d82f7a182d2b1f4.tar.gz
gentoo-2-b3a6ab6956830a37562f3c857d82f7a182d2b1f4.tar.bz2
gentoo-2-b3a6ab6956830a37562f3c857d82f7a182d2b1f4.zip
sci-libs/ccpn-data: Latest patches
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/ccpn-data/ChangeLog7
-rw-r--r--sci-libs/ccpn-data/ccpn-data-2.3.1_p130819.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/sci-libs/ccpn-data/ChangeLog b/sci-libs/ccpn-data/ChangeLog
index 59bf22bd2588..205ccf01e837 100644
--- a/sci-libs/ccpn-data/ChangeLog
+++ b/sci-libs/ccpn-data/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/ccpn-data
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/ccpn-data/ChangeLog,v 1.17 2013/08/08 06:48:11 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/ccpn-data/ChangeLog,v 1.18 2013/08/19 14:25:06 jlec Exp $
+
+*ccpn-data-2.3.1_p130819 (19 Aug 2013)
+
+ 19 Aug 2013; Justin Lecher <jlec@gentoo.org> +ccpn-data-2.3.1_p130819.ebuild:
+ Latest patches
*ccpn-data-2.3.1 (08 Aug 2013)
diff --git a/sci-libs/ccpn-data/ccpn-data-2.3.1_p130819.ebuild b/sci-libs/ccpn-data/ccpn-data-2.3.1_p130819.ebuild
new file mode 100644
index 000000000000..c59a8534bb1b
--- /dev/null
+++ b/sci-libs/ccpn-data/ccpn-data-2.3.1_p130819.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/ccpn-data/ccpn-data-2.3.1_p130819.ebuild,v 1.1 2013/08/19 14:25:06 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit eutils portability python-r1 versionator
+
+PATCHSET="${PV##*_p}"
+MY_PN="${PN/-data}mr"
+MY_PV="$(replace_version_separator 3 _ ${PV%%_p*})r2"
+MY_MAJOR="$(get_version_component_range 1-3)"
+
+DESCRIPTION="The Collaborative Computing Project for NMR - Data"
+HOMEPAGE="http://www.ccpn.ac.uk/ccpn"
+SRC_URI="http://www2.ccpn.ac.uk/download/${MY_PN}/analysis${MY_PV}.tar.gz"
+[[ -n ${PATCHSET} ]] && SRC_URI+=" http://dev.gentoo.org/~jlec/distfiles/ccpn-update-${MY_MAJOR}-${PATCHSET}.patch.xz"
+
+SLOT="0"
+LICENSE="|| ( CCPN LGPL-2.1 )"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ !<sci-chemistry/ccpn-${PVR}"
+DEPEND=""
+
+RESTRICT="binchecks strip"
+
+S="${WORKDIR}"/ccpnmr/ccpnmr2.3
+
+src_prepare() {
+ [[ -n ${PATCHSET} ]] && \
+ epatch "${WORKDIR}"/ccpn-update-${MY_MAJOR}-${PATCHSET}.patch
+}
+
+src_install() {
+ local i pydocs in_path ein_path
+
+ dodir /usr/share/doc/${PF}/html
+ sed \
+ -e "s:../ccpnmr2.1:${EPREFIX}/usr/share/doc/${PF}/html:g" \
+ ../doc/index.html > "${ED}"/usr/share/doc/${PF}/html/index.html || die
+ treecopy $(find python/ -name doc -type d) "${ED}"/usr/share/doc/${PF}/html/
+
+ pydocs="$(find python -name doc -type d)"
+
+ symlinking() {
+ in_path=$(python_get_sitedir)/ccpn
+ ein_path="${in_path#${EPREFIX}}"
+ dosym ../../../../share/doc/${PF}/html ${ein_path}/doc
+ for i in ${pydocs}; do
+ dosym /usr/share/doc/${PF}/html/${i} ${ein_path}/${i}
+ done
+ dosym /usr/share/ccpn/data ${ein_path}/data
+ dosym /usr/share/ccpn/model ${ein_path}/model
+ }
+ python_foreach_impl symlinking
+
+ dohtml -r doc/*
+ insinto /usr/share/ccpn
+ doins -r data model
+}