summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSlawek Lis <slis@gentoo.org>2014-02-23 13:32:05 +0000
committerSlawek Lis <slis@gentoo.org>2014-02-23 13:32:05 +0000
commit883bf5c9b6aea4c9fef913e2781ac22bc5bc704d (patch)
treed42e414d96889ccad317fa046bbc5de5c8b90b23 /sci-libs
parentUpdate ebuild to EAPI 5. Specify LICENSE more precisely. Move site-init file ... (diff)
downloadgentoo-2-883bf5c9b6aea4c9fef913e2781ac22bc5bc704d.tar.gz
gentoo-2-883bf5c9b6aea4c9fef913e2781ac22bc5bc704d.tar.bz2
gentoo-2-883bf5c9b6aea4c9fef913e2781ac22bc5bc704d.zip
version bump, remove old, metadata update
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x55265D89)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/deap/ChangeLog10
-rw-r--r--sci-libs/deap/deap-1.0.0.ebuild20
-rw-r--r--sci-libs/deap/deap-1.0.0_rc1.ebuild24
-rw-r--r--sci-libs/deap/deap-1.0.0_rc2.ebuild24
-rw-r--r--sci-libs/deap/metadata.xml6
5 files changed, 34 insertions, 50 deletions
diff --git a/sci-libs/deap/ChangeLog b/sci-libs/deap/ChangeLog
index 39f5cff38858..b880e49e285a 100644
--- a/sci-libs/deap/ChangeLog
+++ b/sci-libs/deap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/deap
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/deap/ChangeLog,v 1.4 2013/09/05 19:04:44 mgorny Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/deap/ChangeLog,v 1.5 2014/02/23 13:32:05 slis Exp $
+
+*deap-1.0.0 (23 Feb 2014)
+
+ 23 Feb 2014; Sławek Lis <slis@gentoo.org> +deap-1.0.0.ebuild,
+ -deap-1.0.0_rc1.ebuild, -deap-1.0.0_rc2.ebuild, metadata.xml:
+ version bump, remove old, metadata update
05 Sep 2013; Michał Górny <mgorny@gentoo.org> deap-0.9.1.ebuild,
deap-1.0.0_rc1.ebuild, deap-1.0.0_rc2.ebuild:
diff --git a/sci-libs/deap/deap-1.0.0.ebuild b/sci-libs/deap/deap-1.0.0.ebuild
new file mode 100644
index 000000000000..027c1789c592
--- /dev/null
+++ b/sci-libs/deap/deap-1.0.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/deap/deap-1.0.0.ebuild,v 1.1 2014/02/23 13:32:05 slis Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} )
+inherit distutils-r1
+
+DESCRIPTION="Distributed Evolutionary Algorithms in Python"
+HOMEPAGE="http://code.google.com/p/${PN}/ http://pypi.python.org/pypi/deap/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-python/setuptools"
diff --git a/sci-libs/deap/deap-1.0.0_rc1.ebuild b/sci-libs/deap/deap-1.0.0_rc1.ebuild
deleted file mode 100644
index ca078b127dd1..000000000000
--- a/sci-libs/deap/deap-1.0.0_rc1.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/deap/deap-1.0.0_rc1.ebuild,v 1.2 2013/09/05 19:04:44 mgorny Exp $
-
-EAPI="5"
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-
-inherit distutils-r1 versionator
-
-MY_P=${PN}-$(delete_version_separator 3)
-
-DESCRIPTION="Novel evolutionary computation framework"
-HOMEPAGE="https://code.google.com/p/${PN}/"
-SRC_URI="https://deap.googlecode.com/files/${MY_P}.tar.gz"
-
-S="${WORKDIR}/$MY_P"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=""
-DEPEND="dev-python/setuptools"
diff --git a/sci-libs/deap/deap-1.0.0_rc2.ebuild b/sci-libs/deap/deap-1.0.0_rc2.ebuild
deleted file mode 100644
index 627cfd6efc70..000000000000
--- a/sci-libs/deap/deap-1.0.0_rc2.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/deap/deap-1.0.0_rc2.ebuild,v 1.2 2013/09/05 19:04:43 mgorny Exp $
-
-EAPI="5"
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-
-inherit distutils-r1 versionator
-
-MY_P=${PN}-$(delete_version_separator 3)
-
-DESCRIPTION="Novel evolutionary computation framework"
-HOMEPAGE="https://code.google.com/p/${PN}/"
-SRC_URI="https://deap.googlecode.com/files/${MY_P}.tar.gz"
-
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=""
-DEPEND="dev-python/setuptools"
diff --git a/sci-libs/deap/metadata.xml b/sci-libs/deap/metadata.xml
index 1847f17d2266..6a5338f3111a 100644
--- a/sci-libs/deap/metadata.xml
+++ b/sci-libs/deap/metadata.xml
@@ -4,4 +4,10 @@
<maintainer>
<email>slis@gentoo.org</email>
</maintainer>
+ <longdescription>
+ DEAP stands for Distributed Evolutionary Algorithm in Python, it is dedicated to people who
+ wish to learn how to use evolutionary algorithms and to those who wish to
+ rediscover evolutionary algorithms. DEAP is the proof that evolutionary
+ algorithms do **not** need to be neither complex or complicated.
+ </longdescription>
</pkgmetadata>