summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2009-10-18 23:06:27 +0000
committerSteve Arnold <nerdboy@gentoo.org>2009-10-18 23:06:27 +0000
commit6e5975efa05f1a2146517307638850671aa36603 (patch)
tree99850cb03acaaf709a1816643dd0678774981f7f /sci-libs
parentversion bump, bug 289070 (diff)
downloadgentoo-2-6e5975efa05f1a2146517307638850671aa36603.tar.gz
gentoo-2-6e5975efa05f1a2146517307638850671aa36603.tar.bz2
gentoo-2-6e5975efa05f1a2146517307638850671aa36603.zip
Updated Ruby eclass handling; fixes bug 281000.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/gdal/ChangeLog6
-rw-r--r--sci-libs/gdal/gdal-1.6.0-r1.ebuild7
-rw-r--r--sci-libs/gdal/gdal-1.6.1.ebuild7
-rw-r--r--sci-libs/gdal/gdal-1.6.2.ebuild7
4 files changed, 17 insertions, 10 deletions
diff --git a/sci-libs/gdal/ChangeLog b/sci-libs/gdal/ChangeLog
index 9184a2f7edb8..e1c7226b8b59 100644
--- a/sci-libs/gdal/ChangeLog
+++ b/sci-libs/gdal/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/gdal
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.67 2009/10/11 17:32:28 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.68 2009/10/18 23:06:27 nerdboy Exp $
+
+ 18 Oct 2009; Steve Arnold <nerdboy@gentoo.org> gdal-1.6.0-r1.ebuild,
+ gdal-1.6.1.ebuild, gdal-1.6.2.ebuild:
+ Updated Ruby eclass handling; fixes bug 281000.
11 Oct 2009; Raúl Porcel <armin76@gentoo.org> gdal-1.6.1.ebuild:
sparc stable wrt #285489
diff --git a/sci-libs/gdal/gdal-1.6.0-r1.ebuild b/sci-libs/gdal/gdal-1.6.0-r1.ebuild
index d9868a6572d2..3b46372e950a 100644
--- a/sci-libs/gdal/gdal-1.6.0-r1.ebuild
+++ b/sci-libs/gdal/gdal-1.6.0-r1.ebuild
@@ -1,8 +1,11 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.6.0-r1.ebuild,v 1.3 2009/08/03 03:49:06 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.6.0-r1.ebuild,v 1.4 2009/10/18 23:06:27 nerdboy Exp $
WANT_AUTOCONF="2.5"
+RUBY_OPTIONAL="yes"
+USE_RUBY="ruby18"
+
inherit autotools distutils eutils perl-module ruby toolchain-funcs
DESCRIPTION="GDAL is a translator library for raster geospatial data formats (includes OGR support)"
@@ -54,8 +57,6 @@ DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
AT_M4DIR="${S}/m4"
-USE_RUBY="ruby18"
-RUBY_OPTIONAL="yes"
pkg_setup() {
if [ -n "${GDAL_CONFIGURE_OPTS}" ]; then
diff --git a/sci-libs/gdal/gdal-1.6.1.ebuild b/sci-libs/gdal/gdal-1.6.1.ebuild
index 2aca851107f1..69247cf134d0 100644
--- a/sci-libs/gdal/gdal-1.6.1.ebuild
+++ b/sci-libs/gdal/gdal-1.6.1.ebuild
@@ -1,9 +1,12 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.6.1.ebuild,v 1.5 2009/10/11 17:32:28 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.6.1.ebuild,v 1.6 2009/10/18 23:06:27 nerdboy Exp $
EAPI="2"
WANT_AUTOCONF="2.5"
+RUBY_OPTIONAL="yes"
+USE_RUBY="ruby18"
+
inherit autotools distutils eutils perl-module ruby toolchain-funcs
DESCRIPTION="GDAL is a translator library for raster geospatial data formats (includes OGR support)"
@@ -55,8 +58,6 @@ DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
AT_M4DIR="${S}/m4"
-USE_RUBY="ruby18"
-RUBY_OPTIONAL="yes"
pkg_setup() {
if [ -n "${GDAL_CONFIGURE_OPTS}" ]; then
diff --git a/sci-libs/gdal/gdal-1.6.2.ebuild b/sci-libs/gdal/gdal-1.6.2.ebuild
index 091e58d21112..c5ccf355b029 100644
--- a/sci-libs/gdal/gdal-1.6.2.ebuild
+++ b/sci-libs/gdal/gdal-1.6.2.ebuild
@@ -1,9 +1,12 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.6.2.ebuild,v 1.1 2009/09/19 06:18:46 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.6.2.ebuild,v 1.2 2009/10/18 23:06:27 nerdboy Exp $
EAPI="2"
WANT_AUTOCONF="2.5"
+RUBY_OPTIONAL="yes"
+USE_RUBY="ruby18"
+
inherit autotools distutils eutils perl-module ruby toolchain-funcs
DESCRIPTION="GDAL is a translator library for raster geospatial data formats (includes OGR support)"
@@ -55,8 +58,6 @@ DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
AT_M4DIR="${S}/m4"
-USE_RUBY="ruby18"
-RUBY_OPTIONAL="yes"
pkg_setup() {
if [ -n "${GDAL_CONFIGURE_OPTS}" ]; then