summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-10-04 10:35:46 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-10-04 10:35:46 +0000
commit65cce785aa61ff262762169110558852f6a6b4ea (patch)
tree7595b6221ea2921c490dbf8cc0859578161f65e4 /sci-libs
parentVersion bump to newer development snapshot. (diff)
downloadgentoo-2-65cce785aa61ff262762169110558852f6a6b4ea.tar.gz
gentoo-2-65cce785aa61ff262762169110558852f6a6b4ea.tar.bz2
gentoo-2-65cce785aa61ff262762169110558852f6a6b4ea.zip
Version bump to newest development snapshot.
(Portage version: 2.2_rc11/cvs/Linux 2.6.26-SENTINEL-2 i686)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/gerris/ChangeLog8
-rw-r--r--sci-libs/gerris/files/gerris-20080929-as-needed.patch25
-rw-r--r--sci-libs/gerris/gerris-20080929.ebuild52
3 files changed, 84 insertions, 1 deletions
diff --git a/sci-libs/gerris/ChangeLog b/sci-libs/gerris/ChangeLog
index 418c490519bf..a208c15c99aa 100644
--- a/sci-libs/gerris/ChangeLog
+++ b/sci-libs/gerris/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/gerris
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gerris/ChangeLog,v 1.7 2008/08/07 07:01:49 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gerris/ChangeLog,v 1.8 2008/10/04 10:35:46 markusle Exp $
+
+*gerris-20080929 (03 Oct 2008)
+
+ 03 Oct 2008; Markus Dittrich <markusle@gentoo.org>
+ +files/gerris-20080929-as-needed.patch, +gerris-20080929.ebuild:
+ Version bump to newest development snapshot.
07 Aug 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml:
Add USE flag description to metadata wrt GLEP 56.
diff --git a/sci-libs/gerris/files/gerris-20080929-as-needed.patch b/sci-libs/gerris/files/gerris-20080929-as-needed.patch
new file mode 100644
index 000000000000..eca75a32f432
--- /dev/null
+++ b/sci-libs/gerris/files/gerris-20080929-as-needed.patch
@@ -0,0 +1,25 @@
+diff -Naur gerris-snapshot-080929/src/Makefile.am gerris-snapshot-080929.new/src/Makefile.am
+--- gerris-snapshot-080929/src/Makefile.am 2008-09-30 08:47:33.000000000 -0400
++++ gerris-snapshot-080929.new/src/Makefile.am 2008-10-03 18:42:46.000000000 -0400
+@@ -114,18 +114,21 @@
+ -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)\
+ -release $(LT_RELEASE) -export-dynamic
+ libgfs3D_la_SOURCES = $(SRC)
++libgfs3D_la_LIBADD = -lgmodule-2.0
+
+ libgfs2D_la_LDFLAGS = $(NO_UNDEFINED)\
+ -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)\
+ -release $(LT_RELEASE) -export-dynamic
+ libgfs2D_la_SOURCES = $(SRC)
+ libgfs2D_la_CFLAGS = $(AM_CFLAGS) -DFTT_2D=1
++libgfs2D_la_LIBADD = -lgmodule-2.0 -lgts
+
+ libgfs2D3_la_LDFLAGS = $(NO_UNDEFINED)\
+ -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)\
+ -release $(LT_RELEASE) -export-dynamic
+ libgfs2D3_la_SOURCES = $(SRC)
+ libgfs2D3_la_CFLAGS = $(AM_CFLAGS) -DFTT_2D3=1
++libgfs2D3_la_LIBADD = -lgmodule-2.0
+
+ CLEANFILES = $(BUILT_SOURCES)
+
diff --git a/sci-libs/gerris/gerris-20080929.ebuild b/sci-libs/gerris/gerris-20080929.ebuild
new file mode 100644
index 000000000000..fef1abaa8f44
--- /dev/null
+++ b/sci-libs/gerris/gerris-20080929.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gerris/gerris-20080929.ebuild,v 1.1 2008/10/04 10:35:46 markusle Exp $
+
+inherit autotools
+
+DESCRIPTION="The Gerris Flow Solver"
+LICENSE="GPL-2"
+HOMEPAGE="http://gfs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gfs/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="mpi dx"
+
+RDEPEND=">=dev-libs/glib-2.4.0
+ >=sci-libs/gts-20081607
+ sys-apps/gawk
+ dev-lang/python
+ mpi? ( virtual/mpi )
+ dx? ( sci-visualization/opendx )"
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+S="${WORKDIR}"/${PN}-snapshot-080929
+
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+ eautoreconf
+}
+
+
+src_compile() {
+ econf $(use_enable mpi ) \
+ $(use_enable dx) \
+ || die "configure failed"
+
+ emake -j1 || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+
+ insinto /usr/share/doc/${P}/examples
+ rm -f doc/examples/*.pyc || die "Failed to remove python object"
+ doins -r doc/examples/*
+}