summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-02-09 17:50:14 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-02-09 17:50:14 +0000
commit6477d8b319659c6c86b16797b518a61d0dd3aa63 (patch)
tree2e2e1ae73e40eaa7d50603c7d0f70904dbc8ef1b /sci-libs
parentBug #402801: version bump. (diff)
downloadgentoo-2-6477d8b319659c6c86b16797b518a61d0dd3aa63.tar.gz
gentoo-2-6477d8b319659c6c86b16797b518a61d0dd3aa63.tar.bz2
gentoo-2-6477d8b319659c6c86b16797b518a61d0dd3aa63.zip
Fixed directory location for swig generated pfiles, thanks Dustin Polke, bug #402513
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/nlopt/ChangeLog7
-rw-r--r--sci-libs/nlopt/files/nlopt-2.2.4-fix-nlopt_hpp-location.patch47
-rw-r--r--sci-libs/nlopt/nlopt-2.2.4.ebuild4
3 files changed, 56 insertions, 2 deletions
diff --git a/sci-libs/nlopt/ChangeLog b/sci-libs/nlopt/ChangeLog
index ae76816955f6..54a78122a1e2 100644
--- a/sci-libs/nlopt/ChangeLog
+++ b/sci-libs/nlopt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/nlopt
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/ChangeLog,v 1.11 2012/02/07 13:53:02 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/ChangeLog,v 1.12 2012/02/09 17:50:14 bicatali Exp $
+
+ 09 Feb 2012; Sébastien Fabbro <bicatali@gentoo.org> nlopt-2.2.4.ebuild,
+ +files/nlopt-2.2.4-fix-nlopt_hpp-location.patch:
+ Fixed directory location for swig generated pfiles, thanks Dustin Polke, bug
+ #402513
07 Feb 2012; Agostino Sarubbo <ago@gentoo.org> nlopt-2.2.4.ebuild:
Stable for amd64, wrt bug #386953
diff --git a/sci-libs/nlopt/files/nlopt-2.2.4-fix-nlopt_hpp-location.patch b/sci-libs/nlopt/files/nlopt-2.2.4-fix-nlopt_hpp-location.patch
new file mode 100644
index 000000000000..460b4378673a
--- /dev/null
+++ b/sci-libs/nlopt/files/nlopt-2.2.4-fix-nlopt_hpp-location.patch
@@ -0,0 +1,47 @@
+Author: Dustin Polke <DuPol@gmx.de>
+
+Header files are located in top_srcdir not top_builddir.
+--- a/swig/Makefile.am
++++ b/swig/Makefile.am
+@@ -3,7 +3,7 @@ EXTRA_DIST = $(SWIG_SRC) nlopt-guile.i n
+
+ BUILT_SOURCES = nlopt-guile.cpp nlopt-python.cpp nlopt-enum-renames.i nlopt.scm.in
+
+-HDR = $(top_builddir)/api/nlopt.hpp
++HDR = $(top_srcdir)/api/nlopt.hpp
+
+ ##############################################################################
+ # Guile wrapper
+@@ -11,7 +11,7 @@ HDR = $(top_builddir)/api/nlopt.hpp
+ libnlopt@NLOPT_SUFFIX@_guile_la_SOURCES = nlopt-guile.cpp
+ libnlopt@NLOPT_SUFFIX@_guile_la_LIBADD = ../libnlopt@NLOPT_SUFFIX@.la
+ libnlopt@NLOPT_SUFFIX@_guile_la_LDFLAGS = -version-info @SHARED_VERSION_INFO@
+-libnlopt@NLOPT_SUFFIX@_guile_la_CPPFLAGS = $(GUILE_CPPFLAGS) -I$(top_builddir)/api
++libnlopt@NLOPT_SUFFIX@_guile_la_CPPFLAGS = $(GUILE_CPPFLAGS) -I$(top_srcdir)/api
+
+ guiledir = $(GUILE_INSTALL_DIR)
+ if WITH_GUILE
+@@ -25,7 +25,7 @@ endif
+ _nlopt_la_SOURCES = nlopt-python.cpp
+ _nlopt_la_LIBADD = ../libnlopt@NLOPT_SUFFIX@.la
+ _nlopt_la_LDFLAGS = -module -version-info @SHARED_VERSION_INFO@
+-_nlopt_la_CPPFLAGS = $(PYTHON_INCLUDES) -I$(top_builddir)/api
++_nlopt_la_CPPFLAGS = $(PYTHON_INCLUDES) -I$(top_srcdir)/api
+
+ if WITH_PYTHON
+ python_PYTHON = nlopt.py
+@@ -43,12 +43,12 @@ lib_LTLIBRARIES = $(guilelib)
+ if MAINTAINER_MODE
+
+ nlopt-guile.cpp nlopt.scm.in: $(SWIG_SRC) nlopt-guile.i $(HDR)
+- swig -I$(top_builddir)/api -outdir $(builddir) -c++ -guile -scmstub -o $@ nlopt.i
++ swig -I$(top_srcdir)/api -outdir $(builddir) -c++ -guile -scmstub -o $@ nlopt.i
+ rm -f nlopt.scm.in
+ mv nlopt.scm nlopt.scm.in
+
+ nlopt-python.cpp nlopt.py: $(SWIG_SRC) nlopt-python.i numpy.i $(HDR)
+- swig -I$(top_builddir)/api -outdir $(builddir) -c++ -python -o $@ nlopt.i
++ swig -I$(top_srcdir)/api -outdir $(builddir) -c++ -python -o $@ nlopt.i
+
+ nlopt-enum-renames.i: $(top_srcdir)/api/nlopt.h
+ (echo "// AUTOMATICALLY GENERATED -- DO NOT EDIT"; egrep 'NLOPT_[LG][DN]|NLOPT_AUGLAG|NLOPT_G_MLSL|NLOPT_NUM_ALGORITHMS' $(top_srcdir)/api/nlopt.h | sed 's/NLOPT_//g' |tr -d ' ' |tr '/' ',' |tr '=' ',' |cut -d, -f1 |while read name; do echo "%rename(NLOPT_$$name) nlopt::$$name;"; done; egrep 'NLOPT_[A-Z_]* =' $(top_srcdir)/api/nlopt.h | egrep -v 'NLOPT_[LG][DN]|NLOPT_AUGLAG|NLOPT_G_MLSL' | sed 's/NLOPT_//g' |tr -d ' ' |cut -d'=' -f1 | while read name; do echo "%rename(NLOPT_$$name) nlopt::$$name;"; done) > $@
diff --git a/sci-libs/nlopt/nlopt-2.2.4.ebuild b/sci-libs/nlopt/nlopt-2.2.4.ebuild
index 23f4a25882ee..fb92e425b87c 100644
--- a/sci-libs/nlopt/nlopt-2.2.4.ebuild
+++ b/sci-libs/nlopt/nlopt-2.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/nlopt-2.2.4.ebuild,v 1.3 2012/02/07 13:53:02 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/nlopt-2.2.4.ebuild,v 1.4 2012/02/09 17:50:14 bicatali Exp $
EAPI=4
@@ -32,6 +32,8 @@ src_prepare() {
swig/Makefile.in || die
echo '#!/bin/sh' > py-compile
fi
+ epatch "${FILESDIR}"/${P}-fix-nlopt_hpp-location.patch
+ eautoreconf
}
src_configure() {