summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-11-25 15:28:45 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-11-25 15:28:45 +0000
commit447b818f156792935de61ff4bed6eed03353b812 (patch)
tree591f8de4a74f78a8ee3d58ac42f80226cc98dac0 /sci-libs
parentVersion bump, drop old (diff)
downloadgentoo-2-447b818f156792935de61ff4bed6eed03353b812.tar.gz
gentoo-2-447b818f156792935de61ff4bed6eed03353b812.tar.bz2
gentoo-2-447b818f156792935de61ff4bed6eed03353b812.zip
initial import, ebuild by me
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/orocos-bfl/ChangeLog10
-rw-r--r--sci-libs/orocos-bfl/metadata.xml14
-rw-r--r--sci-libs/orocos-bfl/orocos-bfl-0.8.0.ebuild63
3 files changed, 87 insertions, 0 deletions
diff --git a/sci-libs/orocos-bfl/ChangeLog b/sci-libs/orocos-bfl/ChangeLog
new file mode 100644
index 000000000000..5df698730d6c
--- /dev/null
+++ b/sci-libs/orocos-bfl/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-libs/orocos-bfl
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/orocos-bfl/ChangeLog,v 1.1 2014/11/25 15:28:45 aballier Exp $
+
+*orocos-bfl-0.8.0 (25 Nov 2014)
+
+ 25 Nov 2014; Alexis Ballier <aballier@gentoo.org> +orocos-bfl-0.8.0.ebuild,
+ +metadata.xml:
+ initial import, ebuild by me
+
diff --git a/sci-libs/orocos-bfl/metadata.xml b/sci-libs/orocos-bfl/metadata.xml
new file mode 100644
index 000000000000..b187a8cfc9fa
--- /dev/null
+++ b/sci-libs/orocos-bfl/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>aballier@gentoo.org</email>
+<name>Alexis Ballier</name>
+</maintainer>
+<longdescription lang="en">
+ The Bayesian Filtering Library (BFL) provides an application independent framework
+ for inference in Dynamic Bayesian Networks, i.e., recursive information processing
+ and estimation algorithms based on Bayes' rule, such as (Extended) Kalman Filters,
+ Particle Filters (or Sequential Monte Carlo methods), etc.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-libs/orocos-bfl/orocos-bfl-0.8.0.ebuild b/sci-libs/orocos-bfl/orocos-bfl-0.8.0.ebuild
new file mode 100644
index 000000000000..634c57498239
--- /dev/null
+++ b/sci-libs/orocos-bfl/orocos-bfl-0.8.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/orocos-bfl/orocos-bfl-0.8.0.ebuild,v 1.1 2014/11/25 15:28:45 aballier Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Bayesian Filtering Library"
+HOMEPAGE="http://orocos.org/bfl"
+SRC_URI="http://people.mech.kuleuven.be/~tdelaet/bfl_tar/${P}-src.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples static-libs test"
+
+RDEPEND="dev-libs/boost:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen
+ virtual/latex-base
+ )
+ test? ( dev-util/cppunit )"
+
+src_prepare() {
+ sed -e 's:/lib:/${CMAKE_INSTALL_LIBDIR}:' \
+ -i "${S}/"{,src/,src/bindings/rtt/}CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ "-DLIBRARY_TYPE=$(usex static-libs both shared)"
+ "-DBUILD_EXAMPLES=$(usex examples ON OFF)"
+ "-DBUILD_TESTS=$(usex test ON OFF)"
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ if use doc ; then
+ cd "${BUILD_DIR}"
+ doxygen || die
+ cd "${S}/docs" || die
+ pdflatex getting_started_guide || die
+ pdflatex getting_started_guide || die
+ fi
+}
+
+src_test() {
+ cd "${BUILD_DIR}"
+ emake check
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use doc ; then
+ dohtml -r "${BUILD_DIR}/doc/html/"
+ dodoc "${S}/docs/getting_started_guide.pdf"
+ fi
+}