summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-21 21:22:10 +0000
committerJustin Lecher <jlec@gentoo.org>2013-02-21 21:22:10 +0000
commit420b315a30dd316385837fb7629752a8da45b769 (patch)
tree94f518b2a13d6c0cdad496e0368eb95e11d69bb3 /sci-libs
parentimporting older changelog from original overlay (diff)
downloadgentoo-2-420b315a30dd316385837fb7629752a8da45b769.tar.gz
gentoo-2-420b315a30dd316385837fb7629752a8da45b769.tar.bz2
gentoo-2-420b315a30dd316385837fb7629752a8da45b769.zip
sci-libs/taucs: Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/taucs/ChangeLog7
-rw-r--r--sci-libs/taucs/metadata.xml10
-rw-r--r--sci-libs/taucs/taucs-2.2.ebuild12
3 files changed, 16 insertions, 13 deletions
diff --git a/sci-libs/taucs/ChangeLog b/sci-libs/taucs/ChangeLog
index 54675182ade5..fd07c001ca44 100644
--- a/sci-libs/taucs/ChangeLog
+++ b/sci-libs/taucs/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/taucs
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/taucs/ChangeLog,v 1.10 2012/10/16 19:31:53 jlec Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/taucs/ChangeLog,v 1.11 2013/02/21 21:22:10 jlec Exp $
+
+ 21 Feb 2013; Justin Lecher <jlec@gentoo.org> taucs-2.2.ebuild, metadata.xml:
+ Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config
16 Oct 2012; Justin Lecher <jlec@gentoo.org> taucs-2.2.ebuild:
Remove virtual/fortran and always call fortran-2_pkg_setup as intend by the
diff --git a/sci-libs/taucs/metadata.xml b/sci-libs/taucs/metadata.xml
index 28598bd89723..3f2c9bba778e 100644
--- a/sci-libs/taucs/metadata.xml
+++ b/sci-libs/taucs/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
- <longdescription lang="en">
+ <herd>sci</herd>
+ <longdescription lang="en">
TAUCS is a C library of sparse linear solvers.
The current version of the library (1.0) includes the following
functionality:
@@ -23,7 +23,7 @@
* Multilevel-Support-Graph Preconditioners.
* Utility Routines
</longdescription>
- <use>
- <flag name="cilk">Enable multithreading using <pkg>dev-lang/cilk</pkg>)</flag>
- </use>
+ <use>
+ <flag name="cilk">Enable multithreading using <pkg>dev-lang/cilk</pkg>)</flag>
+ </use>
</pkgmetadata>
diff --git a/sci-libs/taucs/taucs-2.2.ebuild b/sci-libs/taucs/taucs-2.2.ebuild
index 68e332c57199..b625c1eb04f7 100644
--- a/sci-libs/taucs/taucs-2.2.ebuild
+++ b/sci-libs/taucs/taucs-2.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/taucs/taucs-2.2.ebuild,v 1.10 2012/10/16 19:31:53 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/taucs/taucs-2.2.ebuild,v 1.11 2013/02/21 21:22:10 jlec Exp $
EAPI=4
@@ -38,12 +38,12 @@ src_configure() {
CFLAGS=${CFLAGS} -fPIC
FFLAGS=${FFLAGS} -fPIC
LDFLAGS=${LDFLAGS} -fPIC
- LIBBLAS=$(pkg-config --libs blas)
- LIBLAPACK=$(pkg-config --libs lapack)
+ LIBBLAS=$($(tc-getPKG_CONFIG) --libs blas)
+ LIBLAPACK=$($(tc-getPKG_CONFIG) --libs lapack)
LIBF77=
EOF
- echo "LIBMETIS=$(pkg-config --libs metis)" >> config/linux_shared.mk
+ echo "LIBMETIS=$($(tc-getPKG_CONFIG) --libs metis)" >> config/linux_shared.mk
# no cat <<EOF because -o has a trailing space
if use cilk; then
echo "CILKC=cilkc" >> config/linux_shared.mk
@@ -67,7 +67,7 @@ src_compile() {
cd lib/linux_shared
$(tc-getFC) ${LDFLAGS} -shared -Wl,-soname=libtaucs.so.1 \
-Wl,--whole-archive libtaucs.a -Wl,--no-whole-archive \
- $(pkg-config --libs blas lapack metis) \
+ $($(tc-getPKG_CONFIG) --libs blas lapack metis) \
-o libtaucs.so.1.0.0 \
|| die "shared lib linking failed"
}