summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-21 21:56:07 +0000
committerJustin Lecher <jlec@gentoo.org>2013-02-21 21:56:07 +0000
commit3c55341b9c8113bc9109afbca51af74fb54b35d4 (patch)
treedd9e5416eca1f55f6239981544d16c2c0ba180aa /sci-libs
parentStable for ppc, wrt bug #458188 (diff)
downloadgentoo-2-3c55341b9c8113bc9109afbca51af74fb54b35d4.tar.gz
gentoo-2-3c55341b9c8113bc9109afbca51af74fb54b35d4.tar.bz2
gentoo-2-3c55341b9c8113bc9109afbca51af74fb54b35d4.zip
sci-libs/cholmod: Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/cholmod/ChangeLog6
-rw-r--r--sci-libs/cholmod/cholmod-1.6.0-r1.ebuild10
-rw-r--r--sci-libs/cholmod/cholmod-1.7.4.ebuild10
-rw-r--r--sci-libs/cholmod/metadata.xml14
4 files changed, 22 insertions, 18 deletions
diff --git a/sci-libs/cholmod/ChangeLog b/sci-libs/cholmod/ChangeLog
index 4448ee128c21..ae0b4084fed0 100644
--- a/sci-libs/cholmod/ChangeLog
+++ b/sci-libs/cholmod/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/cholmod
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cholmod/ChangeLog,v 1.36 2013/01/03 05:26:05 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cholmod/ChangeLog,v 1.37 2013/02/21 21:56:07 jlec Exp $
+
+ 21 Feb 2013; Justin Lecher <jlec@gentoo.org> cholmod-1.6.0-r1.ebuild,
+ cholmod-1.7.4.ebuild, metadata.xml:
+ Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config
03 Jan 2013; Sébastien Fabbro <bicatali@gentoo.org> cholmod-2.0.1.ebuild:
Use generic pkg-config, replace supernodal with easier lapack use flag
diff --git a/sci-libs/cholmod/cholmod-1.6.0-r1.ebuild b/sci-libs/cholmod/cholmod-1.6.0-r1.ebuild
index 2eb6c939ef7a..0f4493fd1777 100644
--- a/sci-libs/cholmod/cholmod-1.6.0-r1.ebuild
+++ b/sci-libs/cholmod/cholmod-1.6.0-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cholmod/cholmod-1.6.0-r1.ebuild,v 1.17 2012/05/04 08:22:50 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cholmod/cholmod-1.6.0-r1.ebuild,v 1.18 2013/02/21 21:56:07 jlec Exp $
-inherit autotools eutils
+inherit autotools eutils toolchain-funcs
MY_PN=CHOLMOD
@@ -64,8 +64,8 @@ src_compile() {
local lapack_libs=no
local blas_libs=no
if use supernodal; then
- blas_libs=$(pkg-config --libs blas)
- lapack_libs=$(pkg-config --libs lapack)
+ blas_libs=$($(tc-getPKG_CONFIG) --libs blas)
+ lapack_libs=$($(tc-getPKG_CONFIG) --libs lapack)
fi
econf \
--with-blas="${blas_libs}" \
diff --git a/sci-libs/cholmod/cholmod-1.7.4.ebuild b/sci-libs/cholmod/cholmod-1.7.4.ebuild
index 35c554b323b3..a88d996c5dce 100644
--- a/sci-libs/cholmod/cholmod-1.7.4.ebuild
+++ b/sci-libs/cholmod/cholmod-1.7.4.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cholmod/cholmod-1.7.4.ebuild,v 1.7 2012/10/15 22:45:52 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cholmod/cholmod-1.7.4.ebuild,v 1.8 2013/02/21 21:56:07 jlec Exp $
EAPI=4
AUTOTOOLS_AUTORECONF=yes
-inherit autotools-utils eutils
+inherit autotools-utils eutils toolchain-funcs
MY_PN=CHOLMOD
PPV=1.7.0
@@ -75,8 +75,8 @@ src_configure() {
local lapack_libs=no
local blas_libs=no
if use supernodal; then
- blas_libs=$(pkg-config --libs blas)
- lapack_libs=$(pkg-config --libs lapack)
+ blas_libs=$($(tc-getPKG_CONFIG) --libs blas)
+ lapack_libs=$($(tc-getPKG_CONFIG) --libs lapack)
fi
local myeconfargs+=(
--with-blas="${blas_libs}"
diff --git a/sci-libs/cholmod/metadata.xml b/sci-libs/cholmod/metadata.xml
index a878809004da..31c352b37583 100644
--- a/sci-libs/cholmod/metadata.xml
+++ b/sci-libs/cholmod/metadata.xml
@@ -1,14 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-<longdescription lang="en">
+ <herd>sci</herd>
+ <longdescription lang="en">
CHOLMOD is a set of ANSI C routines for sparse Cholesky
factorization and update/downdate.
</longdescription>
-<use>
- <flag name="cuda">Use nvidia cuda toolkit for speeding up computations</flag>
- <flag name="metis">Enable the Partition module to cholmod using <pkg>sci-libs/metis</pkg></flag>
- <flag name="supernodal">Enable the Supernodal module (needs <pkg>virtual/lapack</pkg>)</flag>
-</use>
+ <use>
+ <flag name="cuda">Use nvidia cuda toolkit for speeding up computations</flag>
+ <flag name="metis">Enable the Partition module to cholmod using <pkg>sci-libs/metis</pkg></flag>
+ <flag name="supernodal">Enable the Supernodal module (needs <pkg>virtual/lapack</pkg>)</flag>
+ </use>
</pkgmetadata>