summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-12-09 13:50:15 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-12-09 13:50:15 +0000
commit2b7dcac3d6f14a4c41f8fc2928cb9ce3554d8a46 (patch)
treedfc21d79165ecd2def4a3e8a9a547b424726d900 /sci-libs
parentStable on ppc wrt bug 157571 (diff)
downloadgentoo-2-2b7dcac3d6f14a4c41f8fc2928cb9ce3554d8a46.tar.gz
gentoo-2-2b7dcac3d6f14a4c41f8fc2928cb9ce3554d8a46.tar.bz2
gentoo-2-2b7dcac3d6f14a4c41f8fc2928cb9ce3554d8a46.zip
Version bump.
(Portage version: 2.1.2_rc2-r4)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/blas-atlas/ChangeLog8
-rw-r--r--sci-libs/blas-atlas/blas-atlas-3.7.23.ebuild168
-rw-r--r--sci-libs/blas-atlas/files/digest-blas-atlas-3.7.236
3 files changed, 181 insertions, 1 deletions
diff --git a/sci-libs/blas-atlas/ChangeLog b/sci-libs/blas-atlas/ChangeLog
index 40466727174e..fc77a0aa0c8d 100644
--- a/sci-libs/blas-atlas/ChangeLog
+++ b/sci-libs/blas-atlas/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/blas-atlas
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/ChangeLog,v 1.48 2006/11/01 00:53:47 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/ChangeLog,v 1.49 2006/12/09 13:50:15 markusle Exp $
+
+*blas-atlas-3.7.23 (09 Dec 2006)
+
+ 09 Dec 2006; Markus Dittrich <markusle@gentoo.org>
+ +blas-atlas-3.7.23.ebuild:
+ Version bump.
01 Nov 2006; Donnie Berkholz <dberkholz@gentoo.org>; ChangeLog:
Update for my nick change spyderous -> dberkholz.
diff --git a/sci-libs/blas-atlas/blas-atlas-3.7.23.ebuild b/sci-libs/blas-atlas/blas-atlas-3.7.23.ebuild
new file mode 100644
index 000000000000..b812ef2fd4b4
--- /dev/null
+++ b/sci-libs/blas-atlas/blas-atlas-3.7.23.ebuild
@@ -0,0 +1,168 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/blas-atlas-3.7.23.ebuild,v 1.1 2006/12/09 13:50:15 markusle Exp $
+
+inherit eutils toolchain-funcs fortran
+
+DESCRIPTION="Automatically Tuned Linear Algebra Software BLAS implementation"
+HOMEPAGE="http://math-atlas.sourceforge.net/"
+MY_PN=${PN/blas-/}
+SRC_URI="mirror://sourceforge/math-atlas/${MY_PN}${PV}.tar.bz2
+ mirror://gentoo/${MY_PN}-${PV}-shared-libs.patch.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+
+RDEPEND="app-admin/eselect-blas
+ app-admin/eselect-cblas"
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-1.5"
+PROVIDE="virtual/blas"
+
+
+S="${WORKDIR}/ATLAS"
+BLD_DIR="${S}/gentoo-build"
+RPATH="${DESTTREE}/$(get_libdir)/blas"
+FORTRAN="g77 gfortran"
+
+pkg_setup() {
+ fortran_pkg_setup
+ echo
+ ewarn "Please make sure to disable CPU throttling completely"
+ ewarn "during the compile of blas-atlas. Otherwise, all atlas"
+ ewarn "generated timings will be completely random and the"
+ ewarn "performance of the resulting libraries will be degraded"
+ ewarn "considerably."
+ echo
+ ewarn "Also, if you experience failing SANITY tests during"
+ ewarn "atlas' compile please try passing -mfpmath=387; this"
+ ewarn "option might also result in much better performance"
+ ewarn "than using then sse instruction set depending on your"
+ ewarn "CPU."
+ echo
+ epause 10
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch "${DISTDIR}"/${MY_PN}-${PV}-shared-libs.patch.bz2
+ epatch "${FILESDIR}"/${MY_PN}-asm-gentoo.patch
+
+ # make sure shared libs link against proper libraries
+ if [[ ${FORTRANC} == "gfortran" ]]; then
+ libs="${LDFLAGS} -lpthread -lgfortran"
+ else
+ libs="${LDFLAGS} -lpthread -lg2c"
+ fi
+ sed -e "s/SHRD_LNK/${libs}/g" -i Make.top || \
+ die "Failed to add addtional libs to shared object build"
+
+ mkdir ${BLD_DIR} || die "failed to generate build directory"
+ cp "${FILESDIR}"/war ${BLD_DIR} && chmod a+x ${BLD_DIR}/war || \
+ die "failed to install war"
+
+ # force proper 32/64bit libs
+ local archselect
+ if [[ "${ARCH}" == "amd64" || "${ARCH}" == "ppc64" ]]; then
+ archselect="-b 64"
+ else
+ archselect="-b 32"
+ fi
+
+ # set up compiler/flags using atlas' native configure
+ local compdefs
+ compdefs="${compdefs} -C xc '$(tc-getCC)' -F xc '${CFLAGS}'"
+ compdefs="${compdefs} -C ic '$(tc-getCC)' -F ic '${CFLAGS}'"
+ compdefs="${compdefs} -C sk '$(tc-getCC)' -F sk '${CFLAGS}'"
+ compdefs="${compdefs} -C dk '$(tc-getCC)' -F dk '${CFLAGS}'"
+ compdefs="${compdefs} -C sm '$(tc-getCC)' -F sm '${CFLAGS}'"
+ compdefs="${compdefs} -C dm '$(tc-getCC)' -F dm '${CFLAGS}'"
+ compdefs="${compdefs} -C if '${FORTRANC}' -F if '${FFLAGS}'"
+ compdefs="${compdefs} -Si cputhrchk 0 ${archselect}"
+
+ cd ${BLD_DIR} && ../configure ${compdefs} \
+ || die "configure failed"
+}
+
+src_compile() {
+ cd ${BLD_DIR}
+ make || die "make failed"
+
+ make shared-strip RPATH=${RPATH}/atlas || \
+ die "failed to build shared libraries"
+
+ # build shared libraries of threaded libraries if applicable
+ if [ -d gentoo/libptf77blas.a ]; then
+ make ptshared-strip RPATH=${RPATH}/threaded-atlas || \
+ die "failed to build threaded shared libraries"
+ fi
+}
+
+src_install () {
+ dodir "${RPATH}"/atlas
+ cd ${BLD_DIR}/gentoo/libs
+ cp -P libatlas* "${D}/${DESTTREE}/$(get_libdir)" || \
+ die "Failed to install libatlas"
+ cp -P *blas* "${D}/${RPATH}"/atlas || \
+ die "Failed to install blas/cblas"
+
+ eselect blas add $(get_libdir) ${FILESDIR}/eselect.blas atlas
+ eselect cblas add $(get_libdir) ${FILESDIR}/eselect.cblas atlas
+
+ if [ -d ${BLD_DIR}/gentoo/threaded-libs ]
+ then
+ dodir "${RPATH}"/threaded-atlas
+ cd ${BLD_DIR}/gentoo/threaded-libs
+ cp -P * "${D}/${RPATH}"/threaded-atlas || \
+ die "Failed to install threaded atlas"
+
+ eselect blas add $(get_libdir) ${FILESDIR}/eselect.blas-threaded threaded-atlas
+ eselect cblas add $(get_libdir) ${FILESDIR}/eselect.cblas-threaded threaded-atlas
+ fi
+
+ insinto "${DESTTREE}"/include/atlas
+ doins "${S}"/include/cblas.h "${S}"/include/atlas_misc.h \
+ "${S}"/include/atlas_enum.h || \
+ die "failed to install headers"
+
+ # These headers contain the architecture-specific
+ # optimizations determined by ATLAS. The atlas-lapack build
+ # is much shorter if they are available, so save them:
+ doins ${BLD_DIR}/include/*.h || \
+ die "failed to install timing headers"
+
+ #some docs
+ cd "${S}"
+ dodoc README doc/{AtlasCredits.txt,ChangeLog}
+ use doc && dodoc doc/*.ps
+}
+
+pkg_postinst() {
+ local THREADED
+
+ if [ -d "${RPATH}"/threaded-atlas ]
+ then
+ THREADED="threaded-"
+ fi
+ if [[ -z "$(eselect blas show)" ]]; then
+ eselect blas set ${THREADED}atlas
+ fi
+ if [[ -z "$(eselect cblas show)" ]]; then
+ eselect cblas set ${THREADED}atlas
+ fi
+
+ elog
+ elog "Fortran users link using -lblas"
+ elog
+ elog "C users compile against the header ${ROOT}usr/include/atlas/cblas.h and"
+ elog "link using -lcblas"
+ elog
+ elog "If using threaded ATLAS, you may also need to link with -lpthread."
+ elog
+ elog "Configuration now uses eselect rather than blas-config."
+}
diff --git a/sci-libs/blas-atlas/files/digest-blas-atlas-3.7.23 b/sci-libs/blas-atlas/files/digest-blas-atlas-3.7.23
new file mode 100644
index 000000000000..6d649d21a373
--- /dev/null
+++ b/sci-libs/blas-atlas/files/digest-blas-atlas-3.7.23
@@ -0,0 +1,6 @@
+MD5 4d28b9a878db79ba5567c76d225097a1 atlas-3.7.23-shared-libs.patch.bz2 6324
+RMD160 b3fd87430994d09860a6fd1d494934e90c0ecf41 atlas-3.7.23-shared-libs.patch.bz2 6324
+SHA256 895ed8243f23074ad0a343c3aded59468e2f3d6acfa886c840f7f81d32718241 atlas-3.7.23-shared-libs.patch.bz2 6324
+MD5 44c7e7807db212b6d526aa560049f4a1 atlas3.7.23.tar.bz2 1776072
+RMD160 765eb87e714b43c53b399a861f28e8ff27682e32 atlas3.7.23.tar.bz2 1776072
+SHA256 048cf7e2f1ae1a0581642019388b6f72894ca46e797e0548ac2cb7975481e253 atlas3.7.23.tar.bz2 1776072