summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2014-01-15 19:40:37 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2014-01-15 19:40:37 +0000
commit1dab3d0463b8907afcedb6b9f9e763b7ac5ce533 (patch)
tree77cc973be8d6b146cb995f501facfd17f9c85c1b /sci-libs
parentCleanup, as-needed applied upstream (diff)
downloadgentoo-2-1dab3d0463b8907afcedb6b9f9e763b7ac5ce533.tar.gz
gentoo-2-1dab3d0463b8907afcedb6b9f9e763b7ac5ce533.tar.bz2
gentoo-2-1dab3d0463b8907afcedb6b9f9e763b7ac5ce533.zip
Import from science overlay, version bump, removed as-needed (applied upstream)
(Portage version: 2.2.8-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/coinor-couenne/ChangeLog10
-rw-r--r--sci-libs/coinor-couenne/Manifest3
-rw-r--r--sci-libs/coinor-couenne/coinor-couenne-0.4.7.ebuild49
-rw-r--r--sci-libs/coinor-couenne/metadata.xml12
4 files changed, 74 insertions, 0 deletions
diff --git a/sci-libs/coinor-couenne/ChangeLog b/sci-libs/coinor-couenne/ChangeLog
new file mode 100644
index 000000000000..68b7a9194d64
--- /dev/null
+++ b/sci-libs/coinor-couenne/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-libs/coinor-couenne
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/coinor-couenne/ChangeLog,v 1.1 2014/01/15 19:40:37 bicatali Exp $
+
+*coinor-couenne-0.4.7 (15 Jan 2014)
+
+ 15 Jan 2014; Sébastien Fabbro <bicatali@gentoo.org>
+ +coinor-couenne-0.4.7.ebuild, +metadata.xml:
+ Import from science overlay, version bump, removed as-needed (applied
+ upstream)
diff --git a/sci-libs/coinor-couenne/Manifest b/sci-libs/coinor-couenne/Manifest
new file mode 100644
index 000000000000..5dbdce74752b
--- /dev/null
+++ b/sci-libs/coinor-couenne/Manifest
@@ -0,0 +1,3 @@
+DIST Couenne-0.4.7.tgz 12487353 SHA256 23d058aba7564878ec65cdf8aaba6bec83e3809b31520be1ca014444f25badf6 SHA512 ae87ebee778d6782fffe9e6f6c7c8f604140f6134e29824f89e4f87bb86ac00ac1b2d8de274b23de16078a48a1444fbe7960b15ffefdc1798dca8972a8946deb WHIRLPOOL 21d0d1ff4f9d1ea7daf6976546faf6eeaece5205a171763c71813872bd828696bce6b99d7b222e4dd61a637ee053bf5c1271794815eb4e027e5eecac3ace70de
+EBUILD coinor-couenne-0.4.7.ebuild 1197 SHA256 2cd5efc91a91c5bf0f8fcd80e0235daf5c19cfef429b213ef37384e4f4653abb SHA512 3e86a991c3fa453b842e882ffc131b7300738e400e6189e2d82b0bf2961add4528bb84b59e0e1b4b7225991887699a44f38c33bb94bedd02b825a8bea8a8a237 WHIRLPOOL 254999c0d8b31072f85d21ea06cd643b1af64bab88ce7509a1152c5329c0421d52ebf7f3cd89e6b34a03cdde4203cc18acc853e2cc6c971d5e6a0aac67f22a49
+MISC metadata.xml 521 SHA256 93004cfbd69376f251fd362e0c2cdb70bbe4af5898452e319e49e365749ef783 SHA512 01f42517e4f4664336e9e4f7edd9abca9f0800f6502db6317730bc626d80769cf68be1f3bdc60dfa1208928b277628a239ca8cc2060dd165c31c4162c594b55f WHIRLPOOL 67281e397ff20f82154597b03c97e21e43011288235a9cda759375f5874c980dc83f63f5e47dea27c6a028fe238b32b1ebaef6d94c3f3f7d37344f5958fa03ea
diff --git a/sci-libs/coinor-couenne/coinor-couenne-0.4.7.ebuild b/sci-libs/coinor-couenne/coinor-couenne-0.4.7.ebuild
new file mode 100644
index 000000000000..85b995f142b2
--- /dev/null
+++ b/sci-libs/coinor-couenne/coinor-couenne-0.4.7.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/coinor-couenne/coinor-couenne-0.4.7.ebuild,v 1.1 2014/01/15 19:40:37 bicatali Exp $
+
+EAPI=5
+
+inherit autotools-utils multilib
+
+MYPN=Couenne
+
+DESCRIPTION="COIN-OR Convex Over and Under ENvelopes for Nonlinear Estimation"
+HOMEPAGE="https://projects.coin-or.org/Couenne/"
+SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYPN}-${PV}.tgz"
+
+LICENSE="EPL-1.0"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc static-libs test"
+
+RDEPEND="sci-libs/coinor-bonmin:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MYPN}-${PV}/${MYPN}"
+
+src_configure() {
+ local myeconfargs=(
+ --enable-dependency-linking
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ # resolve as-needed
+ # circular dependencies between libCouenne and libBonCouenne :(
+ pushd "${BUILD_DIR}"/src > /dev/null
+ rm libCouenne.la main/libBonCouenne.la || die
+ emake LIBS+="-Lmain/.libs -lBonCouenne" libCouenne.la
+ emake -C main
+ popd > /dev/null
+}
+
+src_install() {
+ autotools-utils_src_install
+ use doc && dodoc doc/couenne-user-manual.pdf
+ # already installed
+ rm "${ED}"/usr/share/coin/doc/${MYPN}/{README,AUTHORS,LICENSE} || die
+}
diff --git a/sci-libs/coinor-couenne/metadata.xml b/sci-libs/coinor-couenne/metadata.xml
new file mode 100644
index 000000000000..77cb214ea9d7
--- /dev/null
+++ b/sci-libs/coinor-couenne/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ Couenne (Convex Over and Under ENvelopes for Nonlinear Estimation)
+ is a spatial branch and bound algorithm that implements linearization, bound
+ reduction, and branching techniques for Mixed-integer, Nonlinear
+ Programming (MINLP) problems. The purpose of Couenne is to find global
+ optima of nonconvex MINLPs.
+</longdescription>
+</pkgmetadata>