summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-09-13 12:51:10 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-09-13 12:51:10 +0000
commit9491139021b4070ff6025967e6412130ed69d9b5 (patch)
treefe4103f9ecf99b9d2036be0a24e8bc502bc54f20 /sci-libs/vtk
parentDrop old vulnerable versions wrt #381637 (diff)
downloadgentoo-2-9491139021b4070ff6025967e6412130ed69d9b5.tar.gz
gentoo-2-9491139021b4070ff6025967e6412130ed69d9b5.tar.bz2
gentoo-2-9491139021b4070ff6025967e6412130ed69d9b5.zip
Fix building with libpng15 wrt #378393 by Diego Elio Pettenò
(Portage version: 2.2.0_alpha55/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/vtk')
-rw-r--r--sci-libs/vtk/ChangeLog6
-rw-r--r--sci-libs/vtk/files/vtk-5.6.1-libpng15.patch22
-rw-r--r--sci-libs/vtk/vtk-5.6.1.ebuild5
3 files changed, 30 insertions, 3 deletions
diff --git a/sci-libs/vtk/ChangeLog b/sci-libs/vtk/ChangeLog
index ed734d3bf4a3..c7faaf61ef40 100644
--- a/sci-libs/vtk/ChangeLog
+++ b/sci-libs/vtk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/vtk
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/ChangeLog,v 1.87 2011/08/04 19:25:48 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/ChangeLog,v 1.88 2011/09/13 12:51:10 ssuominen Exp $
+
+ 13 Sep 2011; Samuli Suominen <ssuominen@gentoo.org> vtk-5.6.1.ebuild,
+ +files/vtk-5.6.1-libpng15.patch:
+ Fix building with libpng15 wrt #378393 by Diego Elio Pettenò
04 Aug 2011; Fabian Groffen <grobian@gentoo.org> vtk-5.6.1.ebuild:
Allow to find Python from Prefix, bug #376917
diff --git a/sci-libs/vtk/files/vtk-5.6.1-libpng15.patch b/sci-libs/vtk/files/vtk-5.6.1-libpng15.patch
new file mode 100644
index 000000000000..5bb5cbfb8cd6
--- /dev/null
+++ b/sci-libs/vtk/files/vtk-5.6.1-libpng15.patch
@@ -0,0 +1,22 @@
+http://bugs.gentoo.org/378393
+
+--- VTK/IO/vtkPNGWriter.cxx
++++ VTK/IO/vtkPNGWriter.cxx
+@@ -147,7 +147,7 @@
+ void vtkPNGWriteErrorFunction(png_structp png_ptr,
+ png_const_charp vtkNotUsed(error_msg))
+ {
+- longjmp(png_ptr->jmpbuf, 1);
++ longjmp(png_jmpbuf(png_ptr), 1);
+ }
+ }
+
+@@ -223,7 +223,7 @@
+ png_init_io(png_ptr, this->TempFP);
+ png_set_error_fn(png_ptr, png_ptr,
+ vtkPNGWriteErrorFunction, vtkPNGWriteWarningFunction);
+- if (setjmp(png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ fclose(this->TempFP);
+ this->SetErrorCode(vtkErrorCode::OutOfDiskSpaceError);
diff --git a/sci-libs/vtk/vtk-5.6.1.ebuild b/sci-libs/vtk/vtk-5.6.1.ebuild
index 10bc97d7fff5..656c28ac5406 100644
--- a/sci-libs/vtk/vtk-5.6.1.ebuild
+++ b/sci-libs/vtk/vtk-5.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.6.1.ebuild,v 1.4 2011/08/04 19:25:48 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.6.1.ebuild,v 1.5 2011/09/13 12:51:10 ssuominen Exp $
EAPI="3"
@@ -83,7 +83,8 @@ src_prepare() {
"${FILESDIR}"/${PN}-5.6.0-R.patch \
"${FILESDIR}"/${PN}-5.6.0-odbc.patch \
"${FILESDIR}"/${P}-ffmpeg.patch \
- "${FILESDIR}"/${P}-gcc-46.patch
+ "${FILESDIR}"/${P}-gcc-46.patch \
+ "${FILESDIR}"/${P}-libpng15.patch
# Fix sure buffer overflow on some processors as reported by Flameyes in #338819
sed -e "s:CHIPNAME_STRING_LENGTH (48 + 1):CHIPNAME_STRING_LENGTH (79 + 1):" \