summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-05-14 16:42:32 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-05-14 16:42:32 +0000
commit1646ae13c780c5554b029d05bd79a286b0eae0c4 (patch)
tree0b739e6c2e008fef6d22625fb570b591cebcd974 /sci-libs/spqr
parent[media-sound/pms] version bump, removed old (diff)
downloadgentoo-2-1646ae13c780c5554b029d05bd79a286b0eae0c4.tar.gz
gentoo-2-1646ae13c780c5554b029d05bd79a286b0eae0c4.tar.bz2
gentoo-2-1646ae13c780c5554b029d05bd79a286b0eae0c4.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/spqr')
-rw-r--r--sci-libs/spqr/ChangeLog9
-rw-r--r--sci-libs/spqr/spqr-1.2.0.ebuild46
2 files changed, 53 insertions, 2 deletions
diff --git a/sci-libs/spqr/ChangeLog b/sci-libs/spqr/ChangeLog
index 091a8a92788d..1ee879cfc810 100644
--- a/sci-libs/spqr/ChangeLog
+++ b/sci-libs/spqr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/spqr
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/spqr/ChangeLog,v 1.3 2009/11/21 07:58:34 bicatali Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/spqr/ChangeLog,v 1.4 2010/05/14 16:42:32 bicatali Exp $
+
+*spqr-1.2.0 (14 May 2010)
+
+ 14 May 2010; Sébastien Fabbro <bicatali@gentoo.org> +spqr-1.2.0.ebuild:
+ Version bump
*spqr-1.1.2 (21 Nov 2009)
diff --git a/sci-libs/spqr/spqr-1.2.0.ebuild b/sci-libs/spqr/spqr-1.2.0.ebuild
new file mode 100644
index 000000000000..f96d4029c89e
--- /dev/null
+++ b/sci-libs/spqr/spqr-1.2.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/spqr/spqr-1.2.0.ebuild,v 1.1 2010/05/14 16:42:32 bicatali Exp $
+
+EAPI=2
+inherit eutils autotools
+
+MY_PN=SPQR
+DESCRIPTION="Multithreaded multifrontal sparse QR factorization library"
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/SPQR"
+SRC_URI="http://www.cise.ufl.edu/research/sparse/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc metis tbb"
+RDEPEND="sci-libs/cholmod[supernodal]
+ tbb? ( dev-cpp/tbb )
+ metis? ( >=sci-libs/cholmod-1.7.0-r1[metis] )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_PN}"
+
+src_prepare() {
+ cd "${WORKDIR}"
+ epatch "${FILESDIR}"/${PN}-1.1.0-autotools.patch
+ epatch "${FILESDIR}"/${PN}-1.1.0-gcc43.patch
+ cd "${S}"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with metis) \
+ $(use_with tbb)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README.txt Doc/ChangeLog || die "dodoc failed"
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins Doc/*.pdf || die
+ fi
+}