summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-09-26 20:09:59 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-09-26 20:09:59 +0000
commit8aa47c296a538ba0d620b8eb95a749e70a1946f5 (patch)
treeb04dd616507f1c065ca307a05d713388a1fecdef /sci-libs/scipy
parent Version bump. New test framework dependent on dev-python/nose. (diff)
downloadgentoo-2-8aa47c296a538ba0d620b8eb95a749e70a1946f5.tar.gz
gentoo-2-8aa47c296a538ba0d620b8eb95a749e70a1946f5.tar.bz2
gentoo-2-8aa47c296a538ba0d620b8eb95a749e70a1946f5.zip
Changed blas/atlas configuration to match newer numpy (should be still compatible with numpy-1.0.4 too. Disabled magic fortran flags detection
(Portage version: 2.2_rc9/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'sci-libs/scipy')
-rw-r--r--sci-libs/scipy/ChangeLog7
-rw-r--r--sci-libs/scipy/metadata.xml24
-rw-r--r--sci-libs/scipy/scipy-0.6.0-r4.ebuild17
3 files changed, 28 insertions, 20 deletions
diff --git a/sci-libs/scipy/ChangeLog b/sci-libs/scipy/ChangeLog
index aeb409f77bea..1a3a5ed1bcbe 100644
--- a/sci-libs/scipy/ChangeLog
+++ b/sci-libs/scipy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/scipy
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.32 2008/07/03 12:13:23 gentoofan23 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.33 2008/09/26 20:09:59 bicatali Exp $
+
+ 26 Sep 2008; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml,
+ scipy-0.6.0-r4.ebuild:
+ Changed blas/atlas configuration to match newer numpy (should be still
+ compatible with numpy-1.0.4 too. Disabled magic fortran flags detection
03 Jul 2008; Thomas Anderson <gentoofan23@gentoo.org>
+files/scipy-0.6.0-implicit.patch, scipy-0.6.0-r4.ebuild:
diff --git a/sci-libs/scipy/metadata.xml b/sci-libs/scipy/metadata.xml
index b07b17ec5277..3727426ef61d 100644
--- a/sci-libs/scipy/metadata.xml
+++ b/sci-libs/scipy/metadata.xml
@@ -1,17 +1,17 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
- <longdescription lang="en">
-SciPy is an open source library of scientific tools for Python. SciPy
-supplements the popular numpy module, gathering a variety of high level
-science and engineering modules together as a single package.
-SciPy includes modules for graphics and plotting, optimization, integration,
-special functions, signal and image processing, genetic algorithms, ODE
-solvers, and others.
+<herd>sci</herd>
+<longdescription lang="en">
+ SciPy is an open source library of scientific tools for Python. SciPy
+ supplements the popular numpy module, gathering a variety of high level
+ science and engineering modules together as a single package.
+ SciPy includes modules for graphics and plotting, optimization, integration,
+ special functions, signal and image processing, genetic algorithms, ODE
+ solvers, and others.
</longdescription>
- <use>
- <flag name="sandbox">Installs experimental scipy sandbox modules (pull some dependencies)</flag>
- <flag name="umfpack">Add support for sparse solving via UMFPACK</flag>
- </use>
+<use>
+ <flag name="sandbox">Adds experimental scipy sandbox modules</flag>
+ <flag name="umfpack">Adds support for sparse solving with <pkg>sci-libs/umfpack</pkg></flag>
+</use>
</pkgmetadata>
diff --git a/sci-libs/scipy/scipy-0.6.0-r4.ebuild b/sci-libs/scipy/scipy-0.6.0-r4.ebuild
index 00440da2aeb0..58e25b60ae4a 100644
--- a/sci-libs/scipy/scipy-0.6.0-r4.ebuild
+++ b/sci-libs/scipy/scipy-0.6.0-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.6.0-r4.ebuild,v 1.5 2008/07/03 12:13:23 gentoofan23 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.6.0-r4.ebuild,v 1.6 2008/09/26 20:09:59 bicatali Exp $
EAPI=1
NEED_PYTHON=2.3
@@ -59,7 +59,7 @@ scipy_fortran_setup() {
# when fortran flags are set, pic is removed.
use amd64 && [[ -n ${FFLAGS} ]] && FFLAGS="${FFLAGS} -fPIC"
- export SCIPY_FCONFIG="config_fc --fcompiler=${fc}"
+ export SCIPY_FCONFIG="config_fc --fcompiler=${fc} --noopt --noarch"
}
pkg_setup() {
@@ -89,14 +89,17 @@ src_unpack() {
[DEFAULT]
library_dirs = /usr/$(get_libdir)
include_dirs = /usr/include
- [atlas]
- include_dirs = $(pkg-config --cflags-only-I lapack \
+ [blas_opt]
+ include_dirs = $(pkg-config --cflags-only-I cblas \
| sed -e 's/^-I//' -e 's/ -I/:/g')
- library_dirs = $(pkg-config --libs-only-L lapack \
+ library_dirs = $(pkg-config --libs-only-L cblas \
| sed -e 's/^-L//' -e 's/ -L/:/g')
- atlas_libs = $(pkg-config --libs-only-l blas \
+ libraries = $(pkg-config --libs-only-l cblas \
| sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
- lapack_libs = $(pkg-config --libs-only-l lapack \
+ [lapack_opt]
+ library_dirs = $(pkg-config --libs-only-L lapack \
+ | sed -e 's/^-L//' -e 's/ -L/:/g')
+ libraries = $(pkg-config --libs-only-l lapack \
| sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
EOF
if use sandbox; then