summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2013-02-05 05:44:25 +0000
committerChristoph Junghans <ottxor@gentoo.org>2013-02-05 05:44:25 +0000
commitbdd1830cca897b3d48ff3db6f882e89aa99045fd (patch)
tree86d72d19a3901f8dabccb8f16bc08a6895cd29ec /sci-libs/openmm
parentadding ~arm (diff)
downloadgentoo-2-bdd1830cca897b3d48ff3db6f882e89aa99045fd.tar.gz
gentoo-2-bdd1830cca897b3d48ff3db6f882e89aa99045fd.tar.bz2
gentoo-2-bdd1830cca897b3d48ff3db6f882e89aa99045fd.zip
clean up install locations
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'sci-libs/openmm')
-rw-r--r--sci-libs/openmm/ChangeLog8
-rw-r--r--sci-libs/openmm/metadata.xml1
-rw-r--r--sci-libs/openmm/openmm-4.1.1-r1.ebuild71
-rw-r--r--sci-libs/openmm/openmm-4.1.1.ebuild37
4 files changed, 79 insertions, 38 deletions
diff --git a/sci-libs/openmm/ChangeLog b/sci-libs/openmm/ChangeLog
index b11449a94c23..32f4d1aa4afa 100644
--- a/sci-libs/openmm/ChangeLog
+++ b/sci-libs/openmm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/openmm
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/openmm/ChangeLog,v 1.4 2013/01/08 19:22:39 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/openmm/ChangeLog,v 1.5 2013/02/05 05:44:25 ottxor Exp $
+
+*openmm-4.1.1-r1 (05 Feb 2013)
+
+ 05 Feb 2013; Christoph Junghans <ottxor@gentoo.org> +openmm-4.1.1-r1.ebuild,
+ -openmm-4.1.1.ebuild, metadata.xml:
+ clean up install locations
08 Jan 2013; Christoph Junghans <ottxor@gentoo.org> openmm-4.1.1.ebuild:
removed fetch restriction as license allows redistribution
diff --git a/sci-libs/openmm/metadata.xml b/sci-libs/openmm/metadata.xml
index e77ce3b9e8fd..770c6c8fc3f1 100644
--- a/sci-libs/openmm/metadata.xml
+++ b/sci-libs/openmm/metadata.xml
@@ -9,5 +9,6 @@
<use>
<flag name="cuda">enable cuda back-end</flag>
<flag name="opencl">enable opencl back-end</flag>
+ <flag name="wrappers">build wrappers for C and Fortran</flag>
</use>
</pkgmetadata>
diff --git a/sci-libs/openmm/openmm-4.1.1-r1.ebuild b/sci-libs/openmm/openmm-4.1.1-r1.ebuild
new file mode 100644
index 000000000000..6a2ed996f750
--- /dev/null
+++ b/sci-libs/openmm/openmm-4.1.1-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/openmm/openmm-4.1.1-r1.ebuild,v 1.1 2013/02/05 05:44:25 ottxor Exp $
+
+EAPI="5"
+
+PYTHON_DEPEND="2:2.6"
+
+inherit cmake-utils cuda python
+
+MY_P="${PN^^[om]}${PV}-Source"
+DESCRIPTION="provides tools for modern molecular modeling simulation"
+HOMEPAGE="https://simtk.org/home/openmm"
+SRC_URI="mirror://gentoo/${MY_P}.zip"
+
+LICENSE="MIT LGPL-2.1+ BSD RU-BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cuda doc examples opencl wrappers"
+
+RDEPEND="
+ cuda? ( >=dev-util/nvidia-cuda-toolkit-4.2.9-r1 )
+ opencl? ( virtual/opencl )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ wrappers? ( dev-cpp/gccxml virtual/jre )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ use cuda && cuda_src_prepare
+ default
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use cuda OPENMM_BUILD_CUDA_LIB)
+ $(cmake-utils_use opencl OPENMM_BUILD_OPENCL_LIB)
+ $(cmake-utils_use doc OPENMM_GENERATE_API_DOCS)
+ $(cmake-utils_use wrappers OPENMM_BUILD_C_AND_FORTRAN_WRAPPERS)
+ $(cmake-utils_use !cuda CUDA_BUILD_CUBIN)
+ $(cmake-utils_use opencl OPENMM_BUILD_RPMD_PLUGIN)
+ $(cmake-utils_use opencl OPENMM_BUILD_PYTHON_WRAPPERS)
+ ) # last 3 options are workarounds for broken build system
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use doc; then
+ dodoc "${ED}"/usr/docs/*.pdf
+ dohtml -r "${ED}"/usr/docs/*.html "${ED}"/usr/docs/api-*
+ fi
+ rm -f "${ED}"/usr/docs/*.pdf
+ rm -rf "${ED}"/usr/docs/*.html "${ED}"/usr/docs/api-*
+ rmdir "${ED}"/usr/docs || die
+
+ if use examples; then
+ insinto /usr/share/"${PN}"
+ doins -r "${ED}"/usr/examples
+ fi
+ rm -rf "${ED}"/usr/examples
+
+ rm -rf "${ED}"/usr/licenses
+}
diff --git a/sci-libs/openmm/openmm-4.1.1.ebuild b/sci-libs/openmm/openmm-4.1.1.ebuild
deleted file mode 100644
index 71bbf0db54f2..000000000000
--- a/sci-libs/openmm/openmm-4.1.1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/openmm/openmm-4.1.1.ebuild,v 1.4 2013/01/08 19:22:39 ottxor Exp $
-
-EAPI="5"
-
-inherit cmake-utils
-
-MY_P="${PN^^[om]}${PV}-Source"
-DESCRIPTION="provides tools for modern molecular modeling simulation"
-HOMEPAGE="https://simtk.org/home/openmm"
-SRC_URI="mirror://gentoo/${MY_P}.zip"
-
-LICENSE="MIT LGPL-2.1+ BSD RU-BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="cuda opencl"
-
-RDEPEND="
- cuda? ( dev-util/nvidia-cuda-toolkit )
- opencl? ( virtual/opencl )"
-DEPEND="${RDEPEND}
- dev-util/cmake"
-
-S="${WORKDIR}/${MY_P}"
-
-src_configure() {
- mycmakeargs=(
- $(cmake-utils_use cuda OPENMM_BUILD_CUDA_LIB)
- $(cmake-utils_use opencl OPENMM_BUILD_OPENCL_LIB)
- $(cmake-utils_use !cuda CUDA_BUILD_CUBIN)
- $(cmake-utils_use opencl OPENMM_BUILD_RPMD_PLUGIN)
- $(cmake-utils_use opencl OPENMM_BUILD_PYTHON_WRAPPERS)
- ) # last 3 options are workarounds for broken build system
-
- cmake-utils_src_configure
-}