summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-12-19 18:38:31 +0000
committerJustin Lecher <jlec@gentoo.org>2010-12-19 18:38:31 +0000
commit458d20ce6a1b54deaa97a192ec3fa46e5655cb35 (patch)
tree859aa8d3db2460ec02e8947b52bc4c5f39047b46 /sci-libs/mkl/mkl-10.0.5.025.ebuild
parentAdded support to www-servers/{nginx,gatling}. Thanks to Fernando V. (bug #211... (diff)
downloadgentoo-2-458d20ce6a1b54deaa97a192ec3fa46e5655cb35.tar.gz
gentoo-2-458d20ce6a1b54deaa97a192ec3fa46e5655cb35.tar.bz2
gentoo-2-458d20ce6a1b54deaa97a192ec3fa46e5655cb35.zip
Fix again the compiler detection
(Portage version: 2.2.0_alpha6/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/mkl/mkl-10.0.5.025.ebuild')
-rw-r--r--sci-libs/mkl/mkl-10.0.5.025.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sci-libs/mkl/mkl-10.0.5.025.ebuild b/sci-libs/mkl/mkl-10.0.5.025.ebuild
index 5a414f5fc0e7..0eec4e414a85 100644
--- a/sci-libs/mkl/mkl-10.0.5.025.ebuild
+++ b/sci-libs/mkl/mkl-10.0.5.025.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mkl/mkl-10.0.5.025.ebuild,v 1.9 2010/12/19 18:23:16 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mkl/mkl-10.0.5.025.ebuild,v 1.10 2010/12/19 18:38:31 jlec Exp $
inherit eutils toolchain-funcs check-reqs
@@ -61,7 +61,7 @@ pkg_setup() {
# Check and setup fortran
if use fortran95; then
# blas95 and lapack95 don't compile with gfortran < 4.2
- [[ $(tc-getFC) =~ g ]] && [[ $(gcc-major-version)$(gcc-minor-version) -lt 42 ]] &&
+ [[ $(tc-getFC) =~ (gfortran|g77) ]] && [[ $(gcc-major-version)$(gcc-minor-version) -lt 42 ]] &&
die "blas95 and lapack95 don't compile with gfortran < 4.2"
fi
MKL_FC="gnu"