summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2011-03-29 15:42:35 +0000
committerAndrey Grozin <grozin@gentoo.org>2011-03-29 15:42:35 +0000
commita650cceabc59340f1d1fa1ac429d23295e498a15 (patch)
tree103190c8f96fc95034d4411bed50085c0ce6d81d /sci-libs/mathgl
parentBased on 2.6.32.36 + genpatches-2.6.32.36 + grsecurity-2.2.2-2.6.32.36-201103... (diff)
downloadgentoo-2-a650cceabc59340f1d1fa1ac429d23295e498a15.tar.gz
gentoo-2-a650cceabc59340f1d1fa1ac429d23295e498a15.tar.bz2
gentoo-2-a650cceabc59340f1d1fa1ac429d23295e498a15.zip
Version bump
(Portage version: 2.2.0_alpha29/cvs/Linux i686)
Diffstat (limited to 'sci-libs/mathgl')
-rw-r--r--sci-libs/mathgl/ChangeLog8
-rw-r--r--sci-libs/mathgl/files/mathgl-octave-3.4.patch7
-rw-r--r--sci-libs/mathgl/mathgl-1.11.1.1.ebuild148
3 files changed, 162 insertions, 1 deletions
diff --git a/sci-libs/mathgl/ChangeLog b/sci-libs/mathgl/ChangeLog
index a9505a494278..d39ecbe47ddb 100644
--- a/sci-libs/mathgl/ChangeLog
+++ b/sci-libs/mathgl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/mathgl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/ChangeLog,v 1.22 2011/03/20 19:59:40 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/ChangeLog,v 1.23 2011/03/29 15:42:35 grozin Exp $
+
+*mathgl-1.11.1.1 (29 Mar 2011)
+
+ 29 Mar 2011; Andrey Grozin <grozin@gentoo.org> +mathgl-1.11.1.1.ebuild,
+ +files/mathgl-octave-3.4.patch:
+ Version bump
20 Mar 2011; Justin Lecher <jlec@gentoo.org> mathgl-1.10.2.1-r1.ebuild,
mathgl-1.11.0.1.ebuild:
diff --git a/sci-libs/mathgl/files/mathgl-octave-3.4.patch b/sci-libs/mathgl/files/mathgl-octave-3.4.patch
new file mode 100644
index 000000000000..ac982bfdf308
--- /dev/null
+++ b/sci-libs/mathgl/files/mathgl-octave-3.4.patch
@@ -0,0 +1,7 @@
+diff -r -U1 mathgl-1.11.1.1.orig/configure.ac mathgl-1.11.1.1/configure.ac
+--- mathgl-1.11.1.1.orig/configure.ac 2011-03-22 02:13:29.000000000 +0600
++++ mathgl-1.11.1.1/configure.ac 2011-03-29 22:04:59.000000000 +0700
+@@ -364,2 +364,3 @@
+ OCTAVE_INCFLAGS="-I`$OCTAVE -p OCTINCLUDEDIR`"
++ OCTAVE_INCFLAGS=`echo ${OCTAVE_INCFLAGS} | sed -e 's|/octave$||'`
+ AC_MSG_RESULT([$OCTAVE_ARCH])
diff --git a/sci-libs/mathgl/mathgl-1.11.1.1.ebuild b/sci-libs/mathgl/mathgl-1.11.1.1.ebuild
new file mode 100644
index 000000000000..7909077ba2db
--- /dev/null
+++ b/sci-libs/mathgl/mathgl-1.11.1.1.ebuild
@@ -0,0 +1,148 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/mathgl-1.11.1.1.ebuild,v 1.1 2011/03/29 15:42:35 grozin Exp $
+
+EAPI=3
+
+WX_GTK_VER=2.8
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit autotools wxwidgets python versionator toolchain-funcs
+
+DESCRIPTION="Math Graphics Library"
+HOMEPAGE="http://mathgl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz mirror://sourceforge/${PN}/STIX_font.tgz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc fltk gif glut gsl hdf5 jpeg octave python qt4 wxwidgets"
+
+RDEPEND="media-libs/libpng
+ virtual/opengl
+ python? ( dev-python/numpy )
+ glut? ( media-libs/freeglut )
+ fltk? ( x11-libs/fltk:1 )
+ gif? ( media-libs/giflib )
+ jpeg? ( virtual/jpeg )
+ hdf5? ( >=sci-libs/hdf5-1.8 )
+ gsl? ( sci-libs/gsl )
+ octave? ( >=sci-mathematics/octave-3.4.0 )
+ qt4? ( x11-libs/qt-gui:4 )
+ wxwidgets? ( x11-libs/wxGTK:2.8 )"
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-2.2.4
+ doc? ( app-text/texi2html virtual/texi2dvi )
+ python? ( dev-lang/swig )
+ octave? ( dev-lang/swig )"
+
+pkg_setup() {
+ if ! version_is_at_least "4.3.0" "$(gcc-version)"; then
+ eerror "You need >=gcc-4.3.0 to compile this package"
+ die "Wrong gcc version"
+ fi
+ if use hdf5 && has_version sci-libs/hdf5[mpi]; then
+ export CC=mpicc
+ export CXX=mpicxx
+ fi
+ use python && python_pkg_setup
+ use wxwidgets && wxwidgets_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ mkdir "${S}"/fonts
+ cd "${S}"/fonts
+ unpack STIX_font.tgz
+}
+
+src_prepare() {
+ # bug #267061
+ epatch "${FILESDIR}"/${PN}-1.10.2-gcc43.patch
+
+ # bug #358245
+ epatch "${FILESDIR}"/${PN}-octave-3.4.patch
+
+ # correct location of numpy/arrayobject.h
+ if use python; then
+ sed \
+ -e '/SUBDIRS/s:lang::g' \
+ -i Makefile.am || die
+ fi
+
+ echo "#!${EPREFIX}/bin/sh" > config/py-compile
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --docdir="${ROOT}"usr/share/doc/${PF} \
+ $(use_enable glut) \
+ $(use_enable qt4 qt) \
+ $(use_enable wxwidgets wx) \
+ $(use_enable fltk) \
+ $(use_enable gif) \
+ $(use_enable jpeg) \
+ $(use_enable hdf5 hdf5_18) \
+ $(use_enable python) \
+ $(use_enable octave) \
+ $(use_enable gsl) \
+ $(use_enable doc docs)
+}
+
+src_compile() {
+ # see bug #249627
+ local JOBS
+ use doc && JOBS=-j1
+ emake ${JOBS} || die "emake failed"
+
+ if use python; then
+ python_copy_sources lang
+ compilation() {
+ local numpy_h
+ numpy_h=$(python_get_sitedir)/numpy/core/include/numpy/arrayobject.h
+ einfo "fixing numpy.i for Python-${PYTHON_ABI}"
+ sed -e "s|<numpy/arrayobject.h>|\"${numpy_h}\"|" \
+ -i numpy.i \
+ || die "sed failed"
+ emake PYTHON_HEADERS="-I$(python_get_includedir)" pyexecdir="$(python_get_sitedir)"
+ }
+ python_execute_function -s --source-dir lang compilation
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ if use python; then
+ installation() {
+ emake DESTDIR="${D}" PYTHON="$(PYTHON)" pyexecdir="$(python_get_sitedir)" pythondir="$(python_get_sitedir)" install
+ }
+ python_execute_function -s --source-dir lang installation
+ python_clean_installation_image
+ fi
+ dodoc README AUTHORS || die "dodoc failed"
+}
+
+pkg_postinst() {
+ if use octave; then
+ octave <<-EOF
+ pkg install /usr/share/${PN}/octave/${PN}.tar.gz
+ EOF
+ fi
+ use python && python_mod_optimize ${PN}.py
+}
+
+pkg_prerm() {
+ if use octave; then
+ octave <<-EOF
+ pkg uninstall ${PN}
+ EOF
+ fi
+}
+
+pkg_postrm() {
+ use python && python_mod_cleanup ${PN}.py
+}