summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2010-01-30 09:36:07 +0000
committerAndrey Grozin <grozin@gentoo.org>2010-01-30 09:36:07 +0000
commit1e35798245f7f4fc69298324ce33a3aa03d7cb37 (patch)
treef648b0cb1c55e93f09ba0cceb7c271d97bdd925b /sci-libs/mathgl
parentConvert to ruby-fakegem. Apply ruby19 patch from ruby overlay. (diff)
downloadgentoo-2-1e35798245f7f4fc69298324ce33a3aa03d7cb37.tar.gz
gentoo-2-1e35798245f7f4fc69298324ce33a3aa03d7cb37.tar.bz2
gentoo-2-1e35798245f7f4fc69298324ce33a3aa03d7cb37.zip
Added USE flag mpi end fixed dependency on hdf5[mpi=], closing bug #302715, thanks to Kacper Kowalik <xarthisius.kk@gmail.com>
(Portage version: 2.2_rc62/cvs/Linux i686)
Diffstat (limited to 'sci-libs/mathgl')
-rw-r--r--sci-libs/mathgl/ChangeLog7
-rw-r--r--sci-libs/mathgl/mathgl-1.10.ebuild11
-rw-r--r--sci-libs/mathgl/mathgl-1.9.0.1.ebuild109
-rw-r--r--sci-libs/mathgl/metadata.xml1
4 files changed, 15 insertions, 113 deletions
diff --git a/sci-libs/mathgl/ChangeLog b/sci-libs/mathgl/ChangeLog
index b0a125301a68..02e8c6418253 100644
--- a/sci-libs/mathgl/ChangeLog
+++ b/sci-libs/mathgl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/mathgl
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/ChangeLog,v 1.9 2010/01/04 12:02:51 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/ChangeLog,v 1.10 2010/01/30 09:36:07 grozin Exp $
+
+ 30 Jan 2010; Andrey Grozin <grozin@gentoo.org> -mathgl-1.9.0.1.ebuild,
+ mathgl-1.10.ebuild, metadata.xml:
+ Added USE flag mpi end fixed dependency on hdf5[mpi=], closing bug
+ #302715, thanks to Kacper Kowalik <xarthisius.kk@gmail.com>
*mathgl-1.10 (04 Jan 2010)
diff --git a/sci-libs/mathgl/mathgl-1.10.ebuild b/sci-libs/mathgl/mathgl-1.10.ebuild
index 145e6cf1af05..87850d5b2bf0 100644
--- a/sci-libs/mathgl/mathgl-1.10.ebuild
+++ b/sci-libs/mathgl/mathgl-1.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/mathgl-1.10.ebuild,v 1.1 2010/01/04 12:02:51 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/mathgl-1.10.ebuild,v 1.2 2010/01/30 09:36:07 grozin Exp $
EAPI=2
WX_GTK_VER=2.8
@@ -13,7 +13,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc fltk gif glut gsl hdf5 jpeg octave python qt4 wxwidgets"
+IUSE="doc fltk gif glut gsl hdf5 jpeg mpi octave python qt4 wxwidgets"
RDEPEND="media-libs/libpng
virtual/glu
@@ -22,8 +22,9 @@ RDEPEND="media-libs/libpng
fltk? ( x11-libs/fltk:1.1 )
gif? ( media-libs/giflib )
jpeg? ( media-libs/jpeg )
- hdf5? ( >=sci-libs/hdf5-1.8 )
+ hdf5? ( >=sci-libs/hdf5-1.8[mpi=] )
gsl? ( sci-libs/gsl )
+ mpi? ( virtual/mpi[cxx] )
octave? ( sci-mathematics/octave )
qt4? ( x11-libs/qt-gui:4 )
wxwidgets? ( x11-libs/wxGTK:2.8 )"
@@ -38,6 +39,10 @@ pkg_setup() {
eerror "You need >=gcc-4.3.0 to compile this package"
die "Wrong gcc version"
fi
+ if use mpi; then
+ export CC=mpicc
+ export CXX=mpicxx
+ fi
}
src_prepare() {
diff --git a/sci-libs/mathgl/mathgl-1.9.0.1.ebuild b/sci-libs/mathgl/mathgl-1.9.0.1.ebuild
deleted file mode 100644
index 545de02ce54f..000000000000
--- a/sci-libs/mathgl/mathgl-1.9.0.1.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/mathgl-1.9.0.1.ebuild,v 1.2 2009/09/15 04:37:30 grozin Exp $
-
-EAPI=2
-WX_GTK_VER=2.8
-inherit autotools wxwidgets python versionator toolchain-funcs
-
-DESCRIPTION="Math Graphics Library"
-HOMEPAGE="http://mathgl.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tgz mirror://sourceforge/${PN}/STIX_font.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc fltk gif glut gsl hdf5 jpeg octave python qt4 wxwindows"
-
-RDEPEND="media-libs/libpng
- virtual/glu
- python? ( dev-python/numpy )
- glut? ( virtual/glut )
- fltk? ( x11-libs/fltk:1.1 )
- gif? ( media-libs/giflib )
- jpeg? ( media-libs/jpeg )
- hdf5? ( sci-libs/hdf5 )
- gsl? ( sci-libs/gsl )
- octave? ( sci-mathematics/octave )
- qt4? ( x11-libs/qt-gui:4 )
- wxwindows? ( x11-libs/wxGTK:2.8 )"
-DEPEND="${RDEPEND}
- >=sys-devel/libtool-2.2.4
- doc? ( app-text/texi2html virtual/texi2dvi )
- python? ( dev-lang/swig )
- octave? ( dev-lang/swig )"
-
-pkg_setup() {
- if ! version_is_at_least "4.3.0" "$(gcc-version)"; then
- eerror "You need >=gcc-4.3.0 to compile this package"
- die "Wrong gcc version"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- mkdir "${S}"/fonts
- cd "${S}"/fonts
- unpack STIX_font.tgz
-}
-
-src_prepare() {
- # bug #267061
- epatch "${FILESDIR}"/${P}-gcc43.patch
- epatch "${FILESDIR}"/${P}-hdf5.patch
-
- # correct location of numpy/arrayobject.h
- if use python; then
- local numpy_h
- numpy_h=$(python_get_sitedir)/numpy/core/include/numpy/arrayobject.h
- einfo "fixing numpy.i"
- sed -e "s|<numpy/arrayobject.h>|\"${numpy_h}\"|" \
- -i lang/numpy.i \
- || die "sed failed"
- fi
-
- eautoreconf
-}
-
-src_configure() {
- econf --docdir="${ROOT}"usr/share/doc/${PF} \
- $(use_enable glut) \
- $(use_enable qt4 qt) \
- $(use_enable wxwindows wx) \
- $(use_enable fltk) \
- $(use_enable gif) \
- $(use_enable jpeg) \
- $(use_enable hdf5) \
- $(use_enable python) \
- $(use_enable octave) \
- $(use_enable gsl) \
- $(use_enable doc docs)
-}
-
-src_compile() {
- # see bug #249627
- local JOBS
- use doc && JOBS=-j1
- emake ${JOBS} || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc README AUTHORS || die "dodoc failed"
-}
-
-pkg_postinst() {
- if use octave; then
- octave <<-EOF
- pkg install /usr/share/${PN}/octave/${PN}.tar.gz
- EOF
- fi
-}
-
-pkg_prerm() {
- if use octave; then
- octave <<-EOF
- pkg uninstall ${PN}
- EOF
- fi
-}
diff --git a/sci-libs/mathgl/metadata.xml b/sci-libs/mathgl/metadata.xml
index d0e39e80724a..d4c35619bd85 100644
--- a/sci-libs/mathgl/metadata.xml
+++ b/sci-libs/mathgl/metadata.xml
@@ -9,5 +9,6 @@
<longdescription>Math Graphics Library</longdescription>
<use>
<flag name='octave'>Add bindings for <pkg>sci-mathematics/octave</pkg></flag>
+ <flag name='mpi'>Use mpi wrappers for compilation. Requirement for <pkg>sci-libs/hdf5</pkg>[mpi]</flag>
</use>
</pkgmetadata>