summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-01-27 16:11:37 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-01-27 16:11:37 +0000
commitf508afbfddc421ac7f2144986a9f78fafac2f360 (patch)
tree6ae0dfdd85aa7121e290a77fdb0d0e0ecc1df0f4 /sci-libs/ipp/ipp-6.0.0.063.ebuild
parentBump to new phonon-4.3.0 (diff)
downloadgentoo-2-f508afbfddc421ac7f2144986a9f78fafac2f360.tar.gz
gentoo-2-f508afbfddc421ac7f2144986a9f78fafac2f360.tar.bz2
gentoo-2-f508afbfddc421ac7f2144986a9f78fafac2f360.zip
Version bump and re-define the extracting tool with upstream change of license management (for 6.0.0.063 too).
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/ipp/ipp-6.0.0.063.ebuild')
-rw-r--r--sci-libs/ipp/ipp-6.0.0.063.ebuild48
1 files changed, 22 insertions, 26 deletions
diff --git a/sci-libs/ipp/ipp-6.0.0.063.ebuild b/sci-libs/ipp/ipp-6.0.0.063.ebuild
index d70fc7db1dc7..a1f552e9b94f 100644
--- a/sci-libs/ipp/ipp-6.0.0.063.ebuild
+++ b/sci-libs/ipp/ipp-6.0.0.063.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/ipp/ipp-6.0.0.063.ebuild,v 1.1 2009/01/19 22:58:10 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/ipp/ipp-6.0.0.063.ebuild,v 1.2 2009/01/27 16:11:37 bicatali Exp $
inherit check-reqs
@@ -15,7 +15,7 @@ SRC_URI="amd64? ( ${COM_URI}/l_${PB}_em64t_p_${PV}.tar.gz )
x86? ( ${COM_URI}/l_${PB}_ia32_p_${PV}.tar.gz )
ia64? ( ${COM_URI}/l_${PB}_itanium_p_${PV}.tar.gz )"
-SLOT=0
+SLOT="0"
LICENSE="Intel-SDP"
IUSE=""
@@ -59,33 +59,28 @@ pkg_setup() {
}
src_unpack() {
-
- ewarn
- ewarn "Intel ${PN} requires at least 300Mb of disk space"
- ewarn "Make sure you have enough in ${PORTAGE_TMPDIR}, /tmp and in /opt"
- ewarn
unpack ${A}
+ cd l_${PB}_*_${PV}
- cd l_${PB}_*_${PV}/install
# need to make a file to install non-interactively.
# to produce such a file, first do it interactively
# tar xf l_*; ./install.sh --duplicate ipp.ini;
- # the file will be instman/ipp.ini
- # binary blob extractor installs crap in /opt/intel
- addwrite /opt/intel
+
+ # binary blob extractor uses stupid directory
+ addwrite /usr/local/share/macrovision
+
cp ${IPP_LICENSE} "${WORKDIR}"/
- IPP_TMP_LICENSE="$(basename ${IPP_LICENSE})"
cat > ipp.ini <<- EOF
- [IPP_${IPP_ARCH}]
- EULA_ACCEPT_REJECT=ACCEPT
+ ACTIVATION=license_file
+ CONTINUE_WITH_OPTIONAL_ERROR=yes
+ PSET_INSTALL_DIR=${S}
+ PSET_LICENSE_FILE=${IPP_LICENSE}
+ INSTALL_MODE=NONRPM
+ ACCEPT_EULA=accept
EOF
+
einfo "Extracting ..."
- ./install \
- --silent ${PWD}/ipp.ini \
- --nonrpm \
- --licensepath "${WORKDIR}"/${IPP_TMP_LICENSE} \
- --installpath "${S}" \
- --log log.txt &> /dev/null
+ ./install.sh --silent ${PWD}/ipp.ini &> log.txt
# This check is arbitrary to say the least...
# We used to look for a specific library (ie: libippmmx.so) but that
@@ -98,11 +93,12 @@ src_unpack() {
die "extracting failed"
fi
+ # clean up
+ cd "${S}"
+ find . -type d -print0 | xargs --null chmod 755
+ rm -rf tmp* uninstall.sh
rm -rf "${WORKDIR}"/l_*
-}
-
-src_compile() {
- einfo "Binary package, nothing to compile"
+ rm -rf /usr/local/share/macrovision
}
src_install() {
@@ -110,9 +106,9 @@ src_install() {
dodir ${instdir}
# install license file
- if [[ ! -f ${INTEL_LIC_DIR}/${IPP_TMP_LICENSE} ]]; then
+ if [[ ! -f ${INTEL_LIC_DIR}/$(basename ${IPP_LICENSE}) ]]; then
insinto ${INTEL_LIC_DIR}
- doins "${WORKDIR}"/${IPP_TMP_LICENSE}
+ doins ${IPP_LICENSE}
fi
# cp quicker than doins