summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2013-10-21 00:26:42 +0000
committerAaron W. Swenson <titanofold@gentoo.org>2013-10-21 00:26:42 +0000
commit641f3a6bc373ba43b3fac83ad4567fb900b2d7ff (patch)
tree89cd97debe18b6b161cf33d99110e27badd1b72c /sci-libs/geos
parentStablize 3.2.51-r2/3.11.2 on amd64/x86, remove oldest stables (diff)
downloadgentoo-2-641f3a6bc373ba43b3fac83ad4567fb900b2d7ff.tar.gz
gentoo-2-641f3a6bc373ba43b3fac83ad4567fb900b2d7ff.tar.bz2
gentoo-2-641f3a6bc373ba43b3fac83ad4567fb900b2d7ff.zip
version bump
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key D1BBFDA0)
Diffstat (limited to 'sci-libs/geos')
-rw-r--r--sci-libs/geos/ChangeLog8
-rw-r--r--sci-libs/geos/files/3.4.2-solaris-isnan.patch14
-rw-r--r--sci-libs/geos/geos-3.4.2.ebuild57
3 files changed, 78 insertions, 1 deletions
diff --git a/sci-libs/geos/ChangeLog b/sci-libs/geos/ChangeLog
index 4342687f7e47..75dabc7bf242 100644
--- a/sci-libs/geos/ChangeLog
+++ b/sci-libs/geos/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/geos
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/ChangeLog,v 1.82 2013/09/30 17:12:52 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/ChangeLog,v 1.83 2013/10/21 00:26:42 titanofold Exp $
+
+*geos-3.4.2 (21 Oct 2013)
+
+ 21 Oct 2013; Aaron W. Swenson <titanofold@gentoo.org>
+ +files/3.4.2-solaris-isnan.patch, +geos-3.4.2.ebuild:
+ version bump
30 Sep 2013; Agostino Sarubbo <ago@gentoo.org> geos-3.4.1.ebuild:
Stable for x86, wrt bug #485974
diff --git a/sci-libs/geos/files/3.4.2-solaris-isnan.patch b/sci-libs/geos/files/3.4.2-solaris-isnan.patch
new file mode 100644
index 000000000000..a66d36f6587d
--- /dev/null
+++ b/sci-libs/geos/files/3.4.2-solaris-isnan.patch
@@ -0,0 +1,14 @@
+diff -Naruw geos-3.4.2.orig/include/geos/platform.h.in geos-3.4.2/include/geos/platform.h.in
+--- geos-3.4.2.orig/include/geos/platform.h.in 2013-08-25 15:10:32.000000000 +0000
++++ geos-3.4.2/include/geos/platform.h.in 2013-10-20 23:45:29.891690795 +0000
+@@ -98,8 +98,9 @@
+ // It does leave a version in std.
+ # define ISNAN(x) (std::isnan(x))
+ # elif (defined(__sun) || defined(__sun__)) && defined(__SUNPRO_CC)
++# define _XOPEN_SOURCE 600 //force iso/math_c99
+ # include <math.h>
+-# define ISNAN(x) (::isnan(x))
++# define ISNAN(x) (std::isnan(x))
+ # endif
+ #endif
+
diff --git a/sci-libs/geos/geos-3.4.2.ebuild b/sci-libs/geos/geos-3.4.2.ebuild
new file mode 100644
index 000000000000..aed409ab85fc
--- /dev/null
+++ b/sci-libs/geos/geos-3.4.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/geos-3.4.2.ebuild,v 1.1 2013/10/21 00:26:42 titanofold Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_{6,7} )
+inherit autotools eutils python-single-r1 python-utils-r1
+
+DESCRIPTION="Geometry engine library for Geographic Information Systems"
+HOMEPAGE="http://trac.osgeo.org/geos/"
+SRC_URI="http://download.osgeo.org/geos/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x64-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
+IUSE="doc php python ruby static-libs"
+
+RDEPEND="
+ php? ( >=dev-lang/php-5.3[-threads] )
+ ruby? ( dev-lang/ruby )
+"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ php? ( dev-lang/swig )
+ python? ( dev-lang/swig ${PYTHON_DEPS} )
+ ruby? ( dev-lang/swig )
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/3.4.2-solaris-isnan.patch
+ eautoreconf
+ echo "#!${EPREFIX}/bin/bash" > py-compile
+}
+
+src_configure() {
+ econf \
+ $(use_enable python) \
+ $(use_enable ruby) \
+ $(use_enable php) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake
+
+ use doc && emake -C "${S}/doc" doxygen-html
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ use doc && dohtml -r doc/doxygen_docs/html/*
+ use python && python_optimize "${D}$(python_get_sitedir)"/geos/
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}